Routing

last person joined: 4 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  MPLS Static LSP issue

    Posted 01-08-2014 06:27

    Good time, everyone 🙂

     

    I have a little issue in my MPLS lab. I got 3 Juniper routers, running 12.1R1.9. Connected in a line (R1--R2--R3). Got OSPF routing configured across them. Then i am trying to configure a static LSP as described here

     

    http://www.juniper.net/techpubs/en_US/junos11.2/topics/usage-guidelines/mpls-configuring-static-lsps.html

     

    Now, the document says that:

     

    • Criteria for analyzing an incoming packet:

      • The install statement creates an LSP that handles IPv4 packets. All static MPLS routes created using the install statement are installed in the default IPv4 routing table (inet.0), and the creating protocol is identified as static. This process is no different from creating static IPv4 routes at the [edit routing-options static] hierarchy level.
      • In the to statement, you configure the IP destination address to check when incoming packets are analyzed. If the address matches, the specified label (push out-label) is assigned to the packet, and the packet enters an LSP. Each prefix that you specify is installed as a static route in the routing table.

    However, when i create the entry, it doesn't go into inet.0 table. Instead it goes to inet.3 table.

     

    Here is the configuration and the show output

     

    [edit protocols mpls]
    root@Core3# show
       static-label-switched-path 10.0.0.0/24 {
         ingress {
             install 10.0.0.0/24;
             next-hop 192.168.1.2;
             to 192.168.0.1;
             push 1000002;
                         }
    }
    interface em0.0;
    interface all;

     

    root@Core3# run show route

    inet.0: 8 destinations, 9 routes (8 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    10.0.0.0/24 *[OSPF/150] 00:53:04, metric 0, tag 0
    > to 192.168.1.2 via em1.0
    10.0.1.0/24 *[Direct/0] 00:54:09
    > via em0.0
    10.0.1.1/32 *[Local/0] 00:54:09
    Local via em0.0
    192.168.0.0/16 *[OSPF/150] 00:53:04, metric 0, tag 0
    > to 192.168.1.2 via em1.0
    192.168.0.0/24 *[OSPF/10] 00:53:04, metric 2
    > to 192.168.1.2 via em1.0
    192.168.1.0/24 *[Direct/0] 00:54:08
    > via em1.0
    192.168.1.3/32 *[Local/0] 00:54:08
    Local via em1.0
    [OSPF/150] 00:53:04, metric 0, tag 0
    > to 192.168.1.2 via em1.0
    224.0.0.5/32 *[OSPF/10] 00:54:44, metric 1
    MultiRecv

     

    inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    10.0.0.0/24 *[MPLS/6/1] 00:00:42, metric 0
    > to 192.168.1.2 via em1.0, Push 1000002
    192.168.0.1/32 *[MPLS/6/1] 00:00:42, metric 0
    > to 192.168.1.2 via em1.0, Push 1000002

     

     

    mpls.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    0 *[MPLS/0] 00:54:44, metric 1
    Receive
    1 *[MPLS/0] 00:54:44, metric 1
    Receive
    2 *[MPLS/0] 00:54:44, metric 1
    Receive
    13 *[MPLS/0] 00:54:44, metric 1
    Receive

     

    Any help would be highly appreciated. 🙂

     

    Regards,

    Sergey.



  • 2.  RE: MPLS Static LSP issue



  • 3.  RE: MPLS Static LSP issue

    Posted 01-08-2014 07:54

    Thanks Antonio,

     

    I have added a static route to the egress router, but that still didn't bring the MPLS routes into inet.0 table. As far as i understand, the INSTALL command should put the route into the inet.0 table, shouldn't it?

     

    Regards,

    Sergey.



  • 4.  RE: MPLS Static LSP issue

    Posted 01-08-2014 08:58
    Sergey, did you specify the resolve option as specified in the PDF? 🙂


  • 5.  RE: MPLS Static LSP issue

    Posted 01-08-2014 09:09

    Antonio,

     

    Yes, i did. Here is the interface and protocol:

     

    192.168.0.1 is the IP address of the egress router.

     

    interfaces {
        em0 {
            unit 0 {
                family inet {
                    address 10.0.1.1/24;
                }
                family mpls;
            }
        }
        em1 {
            unit 0 {
                family inet {
                    address 192.168.1.3/24;
                }
                family mpls;
            }
        }
    }
    routing-options {
        static {
            route 192.168.0.1/32 {
                next-hop 192.168.1.2;
                resolve;
            }
        }
    }
    protocols {
        rsvp {
            interface em0.0;
            interface all;
        }
        mpls {
            static-label-switched-path 10.0.0.0/24 {
                ingress {
                    install 10.0.0.0/24 active;
                    next-hop 192.168.1.2;
                    to 192.168.0.1;
                    push 1000002;
                }
            }
            interface em0.0;
            interface all;
        }
        ospf {
            export OSPF_REDIST;
            area 0.0.0.0 {
                interface em0.0;
                interface em1.0;
            }
        }
    }
    policy-options {
        policy-statement OSPF_REDIST {
            term main {
                from protocol [ local direct static ];
            }
            then accept;
        }
    }
    

     

     



  • 6.  RE: MPLS Static LSP issue

    Posted 01-08-2014 09:14

    I see. You need to invent a "fake" IP address. You are right "install" does the trick for dynamic LSPs but not for static LSPs, so here's what you can do for static:

    routing-options {
    static {
    route 192.168.0.1/32 {
    next-hop fake_ip;
    resolve;
    }
    }

    protocols {
    mpls {
    static-label-switched-path 10.0.0.0/24 {
    ingress {
    install 10.0.0.0/24 active;
    next-hop 192.168.1.2;
    to fake_ip;
    push 1000002;
    }
    }

    That's actually the example in the PDF 🙂



  • 7.  RE: MPLS Static LSP issue

    Posted 01-08-2014 09:25

    Antonio,

     

    Sorry to be a pain, but i still don't get it. The router doesn't let me configure empty values for "to" and "next-hop" parameters. What page is this example on? I can't find it 🙂

     

    Thanks,

    Sergey.



  • 8.  RE: MPLS Static LSP issue

    Posted 01-08-2014 09:38
    Sorry there was a problem with parsing and it shows empty but it's not empty.

    next-hop 1.1.1.1
    ...
    to 1.1.1.1

    same value, fake one. Can be 1.1.1.1 or anything, but same value must be.

    It's page 120, section IPv4 over MPLS Half-Duplex Snake Tests


  • 9.  RE: MPLS Static LSP issue

    Posted 01-08-2014 14:51

    This is the config:

     

    routing-options {
    static {
    route 192.168.0.1/32 {
    next-hop 1.1.1.1;
    resolve;
    }
    }

    protocols {
    mpls {
    static-label-switched-path 10.0.0.0/24 {
    ingress {
    next-hop 192.168.1.2;
    to 1.1.1.1;
    push 1000002;
    }
    }



  • 10.  RE: MPLS Static LSP issue

    Posted 01-09-2014 04:03

    Hi Antonio,

     

    Thanks for your help. Here is my resulting configuration:

    interfaces {
        em0 {
            unit 0 {
                family inet {
                    address 10.0.1.1/24;
                }
                family mpls;
            }
        }
        em1 {
            unit 0 {
                family inet {
                    address 192.168.1.3/24;
                }
                family mpls;
            }
        }
    }
    routing-options {
        static {
            route 192.168.0.1/32 {
                next-hop 1.1.1.1;
                resolve;
            }
            route 192.168.0.0/24 next-hop 192.168.1.2;
        }
    }
    protocols {
        mpls {
            static-label-switched-path 10.0.0.0/24 {
                ingress {
                    install 10.0.0.0/24 active;
                    next-hop 192.168.1.2;
                    to 1.1.1.1;
                    push 1000002;
                }
            }
            interface all;
        }
    }
    

     However, i still don't have the route to 10.0.0.0/24 in my inet.0 table. Here is the route table

     

    inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    10.0.1.0/24        *[Direct/0] 00:54:25
                        > via em0.0
    10.0.1.1/32        *[Local/0] 00:54:25
                          Local via em0.0
    192.168.0.0/24     *[Static/5] 00:02:06
                        > to 192.168.1.2 via em1.0
    192.168.0.1/32     *[Static/5] 00:03:16, metric2 0
                        > to 192.168.1.2 via em1.0, Push 1000002
    192.168.1.0/24     *[Direct/0] 00:54:22
                        > via em1.0
    192.168.1.3/32     *[Local/0] 00:54:22
                          Local via em1.0
    
    inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    1.1.1.1/32         *[MPLS/6/1] 00:00:52, metric 0
                        > to 192.168.1.2 via em1.0, Push 1000002
    10.0.0.0/24        *[MPLS/6/1] 00:00:52, metric 0
                        > to 192.168.1.2 via em1.0, Push 1000002
    

     I how got a route to 192.168.0.1/32 that has a label attached to it, but still no route to 10.0.0.0/24



  • 11.  RE: MPLS Static LSP issue
    Best Answer

    Posted 01-09-2014 04:11
    The "active" in "install active" is known not to work for static LSPs. If you want 10.0.0/24 in inet.0, you need:

    set routing-options static route 10.0.0/24 next-hop 1.1.1.1 resolve


  • 12.  RE: MPLS Static LSP issue

    Posted 01-09-2014 05:56

    Thank you very much Antonio!

     

    I finally got it right! 🙂