Routing
Routing

MSDP not advertising routes

[ Edited ]
09.12.17   |  
‎09-12-2017 07:54 AM

Hi guys,

 

I am trying to get a multicast VPN over MPLS to work but having major issues. I know the basics of multicast but the addition of L3VPN's over MPLS does not make it easier. Let alone the fact that we are running EVPN which casues some more issues. At the moment i'm just trying out random stuff out to see what does what.

 

On both Router A and Router B (both EX9200's) i have setup:

set routing-instances VRF protocols pim rp local address 1.1.1.1
set routing-instances VRF protocols pim interface lo0.1 mode sparse
set routing-instances VRF protocols pim interface lo0.1 version 2
set routing-instances VRF protocols msdp group MC local-address 1.1.1.1
set routing-instances VRF protocols msdp group MC peer 1.1.1.2
set routing-instances VRF protocols mvpn route-target import-target target target:100:1010
set routing-instances VRF protocols mvpn route-target export-target target target:100:1010

 

On Router A i have my external multicast sources:

set routing-instances VRF protocols pim interface ge-0/0/2.0 mode sparse
set routing-instances VRF protocols pim interface ge-0/0/2.0 version 2
set routing-instances VRF protocols msdp group MC local-address 1.1.1.1
set routing-instances VRF protocols msdp group MC peer 1.2.3.4 export reject_any
set protocols igmp interface ge-0/0/2.0 version 3

 

On Router A everything is fine. MSDP (inet4) table is populated by the external sources router: 

user@routerA> show route table VRF.inet.4
VRF.inet.4: 180 destinations, 180 routes (180 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
224.1.3.40,1.2.3.4/64*[MSDP/175/2] 00:00:08, from 1.2.3.3
> to 1.2.2.2 via ge-0/0/2.0

 

Router B is only connected to Router A so it needs to get the multicast information from Router A. 

The MSDP session is up but i cannot seem to get it to advertise any routes:

user@routerB> show msdp instance VRF
Peer address Local address State Last up/down Peer-Group SA Count
1.1.1.1 1.1.1.2 Established 00:58:34 MC 0/0
user@routerA> show route advertising-protocol msdp 1.1.1.2
<none>

 

Router A refuses to advertise any inet.4 route information to Router B even though the session is established.

I tried configuring export filters but it did not change behaviour.

 

Does anyone have an idea what i missing for MSDP to export the routing table?

 

1 REPLY
Routing

Re: MSDP not advertising routes

09.13.17   |  
‎09-13-2017 11:23 AM

 

Can you share your full config  ?