Routing
Highlighted
Routing

MX80 - stitch two interfaces with same VLAN-ID id in a VR.

‎09-21-2017 06:22 PM

Hi. We have an MX80 that needs to take packets tagged on xe-0/0/2.123 and forward them to ae0.123 within a virtual-router instance, whilst having a L3 interface living on this VLAN. I've tried to add the interfaces into a bridge domain created within the routing-instance, but we get this error:

 

'bridge-domains' configuration can only be used for 'instance-type virtual-switch'

 

How do we go about doing this? Here is the relevant config:

 

xe-0/0/2 {
flexible-vlan-tagging;
unit 123 {
vlan-id 123;
}

 

xe-0/0/0 {
gigether-options {
802.3ad ae0;
}

ae0 {
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 123 {
vlan-id 123;
}

 

irb {
unit 123 {
family inet {
address 192.168.1.1/24;
}
}

}

 

routing-instances {
TEST-VR {
instance-type virtual-router;
interface xe-0/0/2.123;
interface ae0.123;
interface irb.123;
}
##
## Warning: 'bridge-domains' configuration can only be used for 'instance-type virtual-switch'
##
bridge-domains {
VLAN123 {
domain-type bridge;
vlan-id 123;
interface xe-0/0/2.123;
interface ae0.123;
routing-interface irb.123;
}
}

 

 

3 REPLIES 3
Highlighted
Routing
Solution
Accepted by topic author JosephD
‎09-22-2017 09:43 AM

Re: MX80 - stitch two interfaces with same VLAN-ID id in a VR.

‎09-21-2017 06:34 PM

just remove xe-0/0/2.123 and ae0.123 from routing-instance TEST-VR, keep them only under bridge-domain



===================================================
If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.
Highlighted
Routing

Re: MX80 - stitch two interfaces with same VLAN-ID id in a VR.

[ Edited ]
‎09-22-2017 04:15 AM

'bridge-domains' configuration can only be used for 'instance-type virtual-switch'


One more thing to add to what said, You can also use instance-type virtual-switch and configure bridge-domain in it as the warning message says but You can't configure bridge-domain in instance-type virtual-router.

 

HTH

Highlighted
Routing

Re: MX80 - stitch two interfaces with same VLAN-ID id in a VR.

[ Edited ]
‎09-22-2017 09:59 AM

We removed xe-0/0/2.123 and ae0.123 from the routing-instance config but still had issues committing - same error. Unfortunately this instance has to be type virtual-router, so we wound up moving the bridge-domain out of the VR and into the base instance. It was able to commit after that. We've verified connectivity through the TEST-VR instance over irb.123, as well as tagged packets on vlan123 going through the bridged interfaces. Thanks all for pointing us in the right direction. Much appreciated!

Feedback