Routing
Highlighted
Routing

OSPF cannot establish using irb interface in EX9208?

[ Edited ]
‎09-12-2019 04:33 PM

Hi all,

 

Is it any specific config to establish OSPF using irb interface (back-to-back) on EX9208? No issue to establish OSPF using physical interface instead using irb?

 

The ospf is stuck in "Exstart" status.

 

Thanks and appreciate any feedback

 

17 REPLIES 17
Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-12-2019 05:35 PM

Hello,

 

I think it should work, could you share the configuration? Exstart/Exchange is usually due MTU mismatch.

 

Thanks.

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-12-2019 06:04 PM

Hi,

 

I'm already enable traceoption and result traceoption said MTU mismatch. I'm check both EX9208 and the MTU is match on physical MTU 1518.

 

 

Thanks

 

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

[ Edited ]
‎09-12-2019 06:57 PM

Hi kronicklez,

 

Please refer this KB, MTU calculation for IRB interface is little tricky.

https://kb.juniper.net/KB27446

MTU on physical port may match but there are other consideration too which you can check in above article.

 

For troubleshooting please check following:

 

#1 please check irb inet mtu on both side

show interfaces irb.x | match mtu

 

#2 please ping the loopback of other router and source it from local loopback. If you think physical MTU is 1518 I think you should be able to ping with 1472 packet size (18 ethernet + 20 IP + 8 ICMP). If ping fails at 1472 find out the path mtu by decreasing the size

 

ping x.x.x.x source y.y.y.y size 1472 do-not-fragment << try it from both side

 

PS: If my response solve your query please accept this as solution, kudos are appreciated too !!

 

Thanks

Vishal

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-12-2019 06:59 PM

You need to check the MTU of the irb interface, not the physical interfaces. The MTU of the irb is derived from the physical interfaces which are part of the VLAN/bridge-domain (the smallest one is used). 

 

Regards,

Yasmin Lara - Juniper Ambassador #QuadE - JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
JNCIS-CLOUD, JNCDS-DC, JNCIA-DevOps
Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 01:55 AM

Hi all,

 

Below is my config. Even i delete the MTU on irb and physical but OSPF still in "Exstart" state. Traceoption still said MTU mismatch. Junos version 13.3R5.9

 

CSW01> show configuration interfaces irb.124
description "Back-to-Back L3-Routing";
family inet {
mtu 1518;
address 10.10.10.1/30;
}

 

CSW01> show configuration interfaces ae0
description "LAG Back-to-Back to ";
mtu 1518;
aggregated-ether-options {
minimum-links 1;
link-speed 10g;
lacp {
passive;
}
}
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ 60-104 123-124 142 400-402 502 ];
}

CSW02> show configuration interfaces irb.124
description "Back-to-Back L3-Routing";
family inet {
mtu 1518;
address 10.10.10.2/30;
}

 

CSW02> show configuration interfaces ae0
description "LAG Back-to-Back to ";
mtu 1518;
aggregated-ether-options {
minimum-links 1;
link-speed 10g;
lacp {
passive;
}
}
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ 60-104 123-124 142 400-402 502 ];
}


Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 02:03 AM

Does the arp resolves (ping work) between 10.10.10.1 and 10.10.10.2  and  vice versa ?

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 02:08 AM

According to https://kb.juniper.net/KB27446 that was kindly provided by Vishal earlier, MTU for your IRB interface will be chosen as minimum of configured MTU and calculated MTU (taking into account MTUs of all relevant physical interfaces).

 

You have MTU 1518 for ae0, plus vlan tagging, which will yield MTU of 1500 for family inet, so the effective MTU for your IRB interface most likely is 1500. Can you please provide output of "show interface irb.124 extensive" | match MTU to confirm?

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------

 

 

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 02:34 AM

Hi,

 

No issue connectivity if i ping from CSW01 to CSW02 and vice versa. Rule OSPF need to establish the MTU need to same on both router only right? Even i delete MTU on irb and result still same. The same config apply on EX8208 and no issue. So not sure why EX9208 behaviour like this.

 

 

Thanks

 

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 02:43 AM

Hi,

 

Probably the fastest way to resolve this is to check "show interface irb.xxx extensive | match MTU" on both sides. Can you please post these outputs here?

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 05:19 AM

Configure OSPF traceoptions with following flags. It will show sent and receive MTU size.

set protocols ospf traceoptions file ospf-trace

set protocols ospf traceoptions flag database-description detail

set protocols ospf traceoptions flag error detail

 

 

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790)
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 05:37 AM

Hi,

 

when i use command show interface irb.124 extensive at both EX9208 (Core1 = MTU 1504 Core2: MTU 1500) then i can see it not same. In the physical mtu i configure same MTU 1518. Supposedly it should same right and follow the physical MTU configuration.

 

Thanks and appreciate any feedback

 

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 05:46 AM

Hi,

 

MTU for IRB interface will be calculated as minimum of a configured MTU on IRB interface, and MTU of all physical interfaces that are included in the bridge domain. By default (e.g. without vlan tagging), family inet MTU will be physical interface MTU - 14 (e.g. 1518 - 14 = 1504). If you have single vlan tag, it will consume additional 4 bytes from the physical interface MTU, which will result in MTU being 1518 - 14 - 4 = 1500.

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------

Highlighted
Routing
Solution
Accepted by topic author kronicklez
‎09-16-2019 09:09 AM

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 05:51 AM

And regardless of the calculated MTU, you can always configure MTU of 1500 on IRB interface on both sides which will 100% resolve your problem.

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 08:45 AM

Hi Sergi,

 

Thanks for your advise. I'm hard coded the irb MTU to 1500 both site and ospf establish.

 

I'm still try to understand why the MTU is not same on irb even the physical MTU is same both interface and number of vlan configure on that trunk interface also same.

 

Thanks

 

 

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 08:59 AM

Hi,

 

That's rather unusual to accept your own post as a solution - if someone's idea worked, that post should be marked instead. If you really want to understand why MTU for family inet on your IRB interfaces is different on these two nodes, you should check all interfaces included into corresponding vlans, and check their MTU one by one. Most likely, there is an interface which is not configured with MTU, or has a different MTU configuration on one of these EXs.

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------

 

 

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 09:01 AM

Hi Sergi,

 

Apologize..supposedly i mark your advise as solution but i do wrong clik the solution. Sorry again.

 

Highlighted
Routing

Re: OSPF cannot establish using irb interface in EX9208?

‎09-13-2019 09:25 AM

Hi,

 

No worries at all Smiley Happy

Please keep us posted on your search for the root cause - I'm pretty sure this MTU mismatch is not accidential and there should be a reason for it.

 

P.S. Not sure, but you may be able to un-mark the post as the accepted solution.

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------