Routing
Highlighted
Routing

PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 02:11 AM

Hello Team,

I am configuring Juniper router as a NNI ( option A) and PE ( opposite ASBR is Cisco )

Now what is happening , Juniper router forward the routes to ASBR which it ( Juniper ) received from MPBGP.

But Juniper not advertising the routes which it received from its CE and also it not forwarding the router to its CE which juniper received from ASBR.

However route received from Cisco ASBR forwarded by Juniper to MPBGP.

My task is to configure Juniper router as ( M series ) as NNI and PE.

Please advise, I am pasting the compelte configuration here


#####################################################################
root> show configuration
## Last commit: 2017-01-06 08:13:42 UTC by root
version 10.1R1.8;
system {
root-authentication {
encrypted-password "$1$XPbY6t8a$RVTe1ltTgleeIh/zm4Im30"; ## SECRET-DATA
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 15.15.15.2/30;
}
}
}
em1 {
unit 0 {
family inet {
address 192.168.1.2/30;
}
family mpls;
}
}
em2 {
unit 0 {
family inet {
address 12.12.12.5/30;
}
}
}
lo0 {
unit 0 {
family inet {
address 11.11.11.11/32;
}
}
}
}
routing-options {
autonomous-system 10991;
}
protocols {
mpls {
interface em1.0;
}
bgp {
group MPBGP {
type internal;
local-address 11.11.11.11;
family inet-vpn {
unicast;
}
neighbor 7.7.7.1;
}
}
ospf {
area 0.0.0.0 {
interface em1.0;
interface lo0.0;
}
}
ldp {
interface em1.0;
}
}
policy-options {
prefix-list NNI-POOL {
15.15.15.0/30;
}
policy-statement NNI-EXPORT {
term accept {
from next-hop 15.15.15.1;
then {
community add NNI-COM;
accept;
}
}
}
policy-statement NNI-IMPORT {
term accept {
from community [ EXPORT-COMM IMPORT-COMM ];
then accept;
}
term accept1 {
from next-hop 12.12.12.6;
then accept;
}
}
policy-statement RT-EXPORT {
term advetise {
from protocol [ direct bgp ];
then {
community add EXPORT-COMM;
accept;
}
}
}
policy-statement RT-IMPORT {
term accept {
from community IMPORT-COMM;
then accept;
}
term NNI-accept {
from community NNI-COM;
then accept;
}
}
community EXPORT-COMM members target:10991:200;
community IMPORT-COMM members target:10991:100;
community NNI-COM members target:10991:1;
}
routing-instances {
YAHOO {
instance-type vrf;
interface em2.0;
route-distinguisher 10991:200;
vrf-import RT-IMPORT;
vrf-export RT-EXPORT;
vrf-target target:10991:200;
vrf-table-label;
protocols {
bgp {
group YAHOO {
type external;
peer-as 65000;
as-override;
neighbor 12.12.12.6;
}
}
}
}
YAHOO-GTWAY {
instance-type vrf;
interface em0.0;
route-distinguisher 10991:1;
vrf-import NNI-IMPORT;
vrf-export NNI-EXPORT;
protocols {
bgp {
group NNI {
type external;
peer-as 13789;
neighbor 15.15.15.1;
}
}
}
}
}

root>

 

7 REPLIES 7
Highlighted
Routing

Re: PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 08:39 AM

Hi Folks,
Based on the config snapshot, i do find we are missing the as-override knob for the BGP session. Can you please fix that?

 

YAHOO-GTWAY {
instance-type vrf;
interface em0.0;
route-distinguisher 10991:1;
vrf-import NNI-IMPORT;
vrf-export NNI-EXPORT;
protocols {
bgp {
group NNI {
type external;
peer-as 13789;
neighbor 15.15.15.1;
}
}
}
}
}
root>

 

-Python
#Please mark my solution as accepted if it helped, Kudos are appreciated as well.

-Python JNCIE 3X [SP|DC|ENT] JNCIP-SEC JNCDS 3X [ WAN | DC|SEC] JNCIS-Cloud JNCIS-DevOps CCIP ITIL
#Please mark my solution as accepted if it helped, Kudos are appreciated as well.
Highlighted
Routing

Re: PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 06:32 PM

Hi Python,

 

AS override not required as below peering is for the ASBR 

 

 

############################

YAHOO-GTWAY {
instance-type vrf;
interface em0.0;
route-distinguisher 10991:1;
vrf-import NNI-IMPORT;
vrf-export NNI-EXPORT;
protocols {
bgp {
group NNI {
type external;
peer-as 13789;
neighbor 15.15.15.1;
}
}
}
}
}
root>

#############################

Highlighted
Routing

Re: PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 06:38 PM

Hi sgauravdeep,
Can you please share a simple topolgy diagram with AS numbers and box names; i can help you with it.

 

-Python

-Python JNCIE 3X [SP|DC|ENT] JNCIP-SEC JNCDS 3X [ WAN | DC|SEC] JNCIS-Cloud JNCIS-DevOps CCIP ITIL
#Please mark my solution as accepted if it helped, Kudos are appreciated as well.
Highlighted
Routing

Re: PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 08:02 PM

Hi Python, 

 

Sure dear, 

 

Please find attachd digrams and along with configuration for both ASBRs

 

Just a brief regarding the topology attached

 

1. IOU3 = Cisco ASBR

2. Juniper 1 = ASBR

3. IOU5 = CE router 

4. IOU8 and IOU9 = CE routers 

5. All CE routers has same AS=65000

6. Juniper AS = 10991

7. Cisco ASBR AS = 13789

 

Problem, Cisco ASBR is advertising correct routing to Juniper ASBR, however Juniper forwards the routes only to IOU9 and not IOU8. 

 

Simillary, Juniper is receiving the routes from both CEs ( IOU8 and IOU9) however it forwards routes to Cisco NNI ( ASBR ) from IOU9 only

 

 

 

Attachments

Highlighted
Routing

Re: PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 10:55 PM

Hello,

If IOU8 and IOU3/ASBR are in different VRFs on Juniper-1, then the Juniper-1 router won't advertise IOU8 routes to IOU3 and vice versa.

To make this happen, You need to configure BGP RIB-groups + perhaps "auto-export" and adjust Your VRF policies accordingly

https://www.juniper.net/techpubs/en_US/junos12.1/topics/example/auto-export-configuring-verifying.ht...

HTH

Thx

Alex

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 11:07 PM

Hi, 

 

yeah I've checked "auto-export" feature.

 

But if we enabled it for specific VRF( lets sya ) , then it will allow unnecessary ( or unwanted )  routes from other vrfs as well,

 

So far, my research inclined me  to use RIB group.

 

Pls correct me if I am on wrong direction as far as auto-export is concern.

 

and What is the default behaviour of Juniper configured as NNI and PE 

 

Highlighted
Routing

Re: PLS HElP, JUNIPER NNI and PE ( Same router ) Issue

‎01-06-2017 11:50 PM

Hello,


@sgauravdeep wrote:

Hi, 

 

 

 

But if we enabled it for specific VRF( lets sya ) , then it will allow unnecessary ( or unwanted )  routes from other vrfs as well,

 

 

 


You can control this with VRF import policies.

 


@sgauravdeep wrote:

Hi, 

 

 

 

and What is the default behaviour of Juniper configured as NNI and PE 

 


In JUNOS, there isn't anything special about having different eBGP peers in different VRFs on same PE.

Expecting that PE would export everything from any local VRF to an eBGP peer in its own separate VRF is the strangest thing I've seen for ages. If You point me to the product from other vendor that does it, I'd be very interested.

HTH

Thx
Alex

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !