Routing
Highlighted
Routing

Problem with OSPF areas on Junos GNS3 emulation.

‎09-28-2014 12:36 PM

I'm trying to implemenet this topology

Capture.JPG

But Junos1 isn't receiving the default route 0.0.0.0/0 in its routing table or the ospf routes.

Junos 2 isn't also receiving the redistributed RIP routes and the rip routers aren't really recognizing each other.

 

R1-showroute.JPGR2-run-show-route.JPGR5-rip-configs.JPG

 

Here's the configuration of each router.

Junos1:

root@Jun1# show 
## Last changed: 2014-09-27 19:02:51 UTC
version 10.1R1.8;
system {
    host-name Jun1;
    root-authentication {
        encrypted-password "$1$P0DBC9.e$f/RmifPMoDV1KvLhQkEPF."; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {               
                address 12.12.12.1/24;
            }
        }
    }
}
routing-options {
    router-id 1.1.1.1;
}
protocols {
    ospf {
        area 0.0.0.10 {
            stub;
            interface em0.0;
        }
    }
}

[edit]

 

Junos2:

root@Jun2# show | no-more 
## Last changed: 2014-09-27 19:04:59 UTC
version 10.1R1.8;
system {
    host-name Jun2;
    root-authentication {
        encrypted-password "$1$XS/UBpEu$mX.tdqPzQos0qDghAXBeh."; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {
                address 12.12.12.2/24;
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 23.23.23.2/24;
            }
        }
    }
    em2 {
        unit 0 {
            family inet {
                address 24.24.24.2/24;
            }
        }
    }
    em3 {
        unit 0 {
            family inet {
                address 25.25.25.2/24;
            }
        }
    }
}
routing-options {
    router-id 2.2.2.2;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface em1.0;
            interface em2.0;
        }
        area 0.0.0.10 {
            stub default-metric 10 no-summaries;
            interface em0.0;
        }
        area 0.0.0.20 {
            nssa {
                default-lsa {
                    default-metric 20;
                    metric-type 2;
                    type-7;
                }
                no-summaries;
            }
            interface em3.0;
        }
    }
}

[edit]

 

Junos3:


root@Jun3# show | no-more 
## Last changed: 2014-09-27 19:03:49 UTC
version 10.1R1.8;
system {
    host-name Jun3;
    root-authentication {
        encrypted-password "$1$EFIhgJH7$WnWSIdSuDQu0RE0GrPQrg/"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {
                address 23.23.23.3/24;
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 34.34.34.3/24;
            }
        }
    }
}
routing-options {
    router-id 3.3.3.3;
}
protocols {
    ospf {
        area 0.0.0.10 {
            interface em0.0;
            interface em1.0;
        }
    }
}

[edit]

 

Junos4:

root@Jun4# show | no-more 
## Last changed: 2014-09-28 10:25:03 UTC
version 10.1R1.8;
system {
    host-name Jun4;
    root-authentication {
        encrypted-password "$1$yqKTECO6$PQVgf0iBXATficAwCOCH8/"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {
                address 34.34.34.4/24;
                address 24.24.24.4/24;
            }
        }
    }
}
routing-options {
    router-id 4.4.4.4;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface em0.0;
            interface em1.0;
        }
    }
}

[edit]

 

Junos5: 

root@Jun5# show | no-more 
## Last changed: 2014-09-27 19:04:30 UTC
version 10.1R1.8;
system {
    host-name Jun5;
    root-authentication {
        encrypted-password "$1$Ce/ZTzNE$egKrbkHmL0CL9izkoDsHU1"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {
                address 25.25.25.5/24;
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 56.56.56.5/24;
            }
        }
    }
}
routing-options {
    router-id 5.5.5.5;
}
protocols {
    ospf {
        export RIP;
        area 0.0.0.20 {
            stub;
            interface em0.0;
        }
    }
    rip {
        group walid {
            neighbor em1.0;
        }
    }
}
policy-options {
    policy-statement RIP {
        from protocol rip;
        then accept;
    }
}

[edit]

 

junos6:

root@Jun6# show | no-more 
## Last changed: 2014-09-27 19:04:52 UTC
version 10.1R1.8;
system {
    host-name Jun6;
    root-authentication {
        encrypted-password "$1$wI2B0vxt$UEKbbHBQGDU7RKJEj5CBq/"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {
                address 56.56.56.6/24;
            }
        }
    }
}
routing-options {
    router-id 6.6.6.6;
}
protocols {
    rip {
        group walid {
            neighbor em0.0;
        }
    }
}

[edit]

 

 

I know its a messy lengthy post but I really would appreciate the help as I'm trying to study for my certification.

Thanks in advance

10 REPLIES 10
Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-28-2014 11:29 PM

I don't see any other interface configured on R6, except the interface towards R5. Do you want to have the 56.56.56/24 route learned as external on R5? For RIP, create a policy to export directly connected routes in RIP.

 

R5 should be configured for NSSA, not stub.

 

R2 should advertise 0/0, I don't see any configuration problem there.

 

I see that R2 is not received 34.34.34/24 as well. So seems that R2 has some issues. Can you restart it?

 

 

 

=====

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 02:44 AM

First, I can't thank you enough for your replies.

After I followed your reply I did the following

1-  I created the policy for rip on Junos6 and the same on Junos5 and exported eventually for redistribuion on Junos5.

Junos5 now receives rip route in its routing table, I configured Junos5 to be nssa

and here's its configuration

Jun5
root@Jun5# show 
## Last changed: 2014-09-27 21:23:20 UTC
version 10.1R1.8;
system {
    host-name Jun5;
    root-authentication {
        encrypted-password "$1$Ce/ZTzNE$egKrbkHmL0CL9izkoDsHU1"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {               
                address 25.25.25.5/24;
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 56.56.56.5/24;
            }
        }
    }
}
routing-options {
    router-id 5.5.5.5;
}
protocols {
    ospf {
        export RIP;
        area 0.0.0.20 {
            nssa;
            interface em0.0;
        }
    }                                   
    rip {
        group walid {
            export rip-routes;
            neighbor em1.0;
        }
    }
}
policy-options {
    policy-statement RIP {
        from protocol rip;
        then accept;
    }
    policy-statement rip-routes {
        from protocol direct;
        then accept;
    }
}

 

2- R1 now finds the default route in its routing table.

3- I misconfigured Junos3 by assigning the ports to area 10 instead of 0 and I replaced it and now Junos2 sees the 34.34.34.0/24 route

The problem of the external routes of rip being redistributed still exists as Junos2 still doesn't receive any external routes.

please check

Junos2

root@Jun2# run show route 

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

12.12.12.0/24      *[Direct/0] 02:20:19
                    > via em0.0
12.12.12.2/32      *[Local/0] 02:20:19
                      Local via em0.0
23.23.23.0/24      *[Direct/0] 02:20:19
                    > via em1.0
23.23.23.2/32      *[Local/0] 02:20:19
                      Local via em1.0
24.24.24.0/24      *[Direct/0] 02:20:19
                    > via em2.0
24.24.24.2/32      *[Local/0] 02:20:19
                      Local via em2.0
25.25.25.0/24      *[Direct/0] 02:20:19
                    > via em3.0
25.25.25.2/32      *[Local/0] 02:20:19
                      Local via em3.0
34.34.34.0/24      *[OSPF/10] 00:00:58, metric 2
                    > to 23.23.23.3 via em1.0
224.0.0.5/32       *[OSPF/10] 02:20:20, metric 1
                      MultiRecv         

[edit]
root@Jun2# run show ospf route 
Topology default Route Table:

Prefix             Path  Route      NH       Metric NextHop       Nexthop      
                   Type  Type       Type            Interface     Address/LSP
1.1.1.1            Intra Router     IP            1 em0.0         12.12.12.1
3.3.3.3            Intra Router     IP            1 em1.0         23.23.23.3
4.4.4.4            Intra Router     IP            2 em1.0         23.23.23.3
5.5.5.5            Intra AS BR      IP            1 em3.0         25.25.25.5
12.12.12.0/24      Intra Network    IP            1 em0.0
23.23.23.0/24      Intra Network    IP            1 em1.0
24.24.24.0/24      Intra Network    IP            1 em2.0
25.25.25.0/24      Intra Network    IP            1 em3.0
34.34.34.0/24      Intra Network    IP            2 em1.0         23.23.23.3

[edit]
root@Jun2# run show ospf database 

    OSPF database, Area 0.0.0.0
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len 
Router  *2.2.2.2          2.2.2.2          0x80000009    60  0x22 0x1917  48
Router   3.3.3.3          3.3.3.3          0x80000014     4  0x22 0x3b59  48
Router   4.4.4.4          4.4.4.4          0x80000028     5  0x22 0xffbd  48
Network *23.23.23.2       2.2.2.2          0x80000001    60  0x22 0xeaeb  32
Network  34.34.34.4       4.4.4.4          0x80000013     5  0x22 0x2d64  32
Summary *12.12.12.0       2.2.2.2          0x80000009   508  0x22 0x9572  28
Summary *25.25.25.0       2.2.2.2          0x80000005     8  0x22 0xc71d  28
ASBRSum *5.5.5.5          2.2.2.2          0x80000001   100  0x22 0x62bc  28

    OSPF database, Area 0.0.0.10
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len 
Router   1.1.1.1          1.1.1.1          0x80000007  2189  0x20 0x9c40  36
Router  *2.2.2.2          2.2.2.2          0x8000000a  1008  0x20 0x5b74  36
Network  12.12.12.1       1.1.1.1          0x80000004  2189  0x20 0x649f  32
Summary *0.0.0.0          2.2.2.2          0x80000001    60  0x20 0xcf5d  28

    OSPF database, Area 0.0.0.20
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len 
Router  *2.2.2.2          2.2.2.2          0x80000009   100  0x20 0x7c03  36
Router   5.5.5.5          5.5.5.5          0x80000003    73  0x20 0xcaa0  36
Network *25.25.25.2       2.2.2.2          0x80000001   100  0x20 0x25a5  32
NSSA    *0.0.0.0          2.2.2.2          0x80000001    60  0x20 0x8f07  36

[edit]

  Thanks for your care and Thank you in advance

 

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 03:03 AM

Why don't you export the connected route(56.56.56/24) in OSPF on R5?

 

The policy will be export the learned RIP routes from R6.

 

Can you configure a loopback on R6, advertise it in RIP and then check that is received by R5 through RIP and by R2 through OSPF as external?

 

 

 

=====

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 03:16 AM

I did as you asked me, and it was indeed learned in Junos5 Rip routes and in R2 routes as OSPF, not external route. 

I don't know if this is correct or not but here's the configuration

Junos6

root@Jun6# show 
## Last changed: 2014-09-27 21:28:44 UTC
version 10.1R1.8;
system {
    host-name Jun6;
    root-authentication {
        encrypted-password "$1$wI2B0vxt$UEKbbHBQGDU7RKJEj5CBq/"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {               
                address 56.56.56.6/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 1.1.1.1/24;
            }
        }
    }
}
routing-options {
    router-id 6.6.6.6;
}
protocols {
    rip {
        group walid {
            export rip-routes;
            neighbor em0.0;
        }
    }
}                                       
policy-options {
    policy-statement rip-routes {
        from {
            protocol direct;
            interface lo0.0;
        }
        then accept;
    }
}

[edit]

 

Junos5
# Last changed: 2014-09-27 21:23:20 UTC
version 10.1R1.8;
system {
    host-name Jun5;
    root-authentication {
        encrypted-password "$1$Ce/ZTzNE$egKrbkHmL0CL9izkoDsHU1"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            family inet {               
                address 25.25.25.5/24;
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 56.56.56.5/24;
            }
        }
    }
}
routing-options {
    router-id 5.5.5.5;
}
protocols {
    ospf {
        export RIP;
        area 0.0.0.20 {
            nssa;
            interface em0.0;
        }
    }                                   
    rip {
        group walid {
            export rip-routes;
            neighbor em1.0;
        }
    }
}
policy-options {
    policy-statement RIP {
        from protocol rip;
        then accept;
    }
    policy-statement rip-routes {
        from protocol direct;
        then accept;
    }
}



root@Jun5# run show route 

inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[OSPF/150] 00:05:46, metric 20, tag 0
                    > to 25.25.25.2 via em0.0
1.1.1.0/24         *[RIP/100] 00:00:49, metric 2, tag 0
                    > to 56.56.56.6 via em1.0
25.25.25.0/24      *[Direct/0] 02:24:59
                    > via em0.0
25.25.25.5/32      *[Local/0] 02:24:59
                      Local via em0.0
56.56.56.0/24      *[Direct/0] 02:24:59
                    > via em1.0
56.56.56.5/32      *[Local/0] 02:24:59
                      Local via em1.0
224.0.0.5/32       *[OSPF/10] 02:24:59, metric 1
                      MultiRecv
224.0.0.9/32       *[RIP/100] 00:05:58, metric 1
                      MultiRecv

 

 

And on Junos2

 

root@Jun2# run show route 

inet.0: 11 destinations, 11 routes (11 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.0/24         *[OSPF/150] 00:00:58, metric 2, tag 0
                    > to 25.25.25.5 via em3.0
12.12.12.0/24      *[Direct/0] 02:25:15
                    > via em0.0
12.12.12.2/32      *[Local/0] 02:25:15
                      Local via em0.0
23.23.23.0/24      *[Direct/0] 02:25:15
                    > via em1.0
23.23.23.2/32      *[Local/0] 02:25:15
                      Local via em1.0
24.24.24.0/24      *[Direct/0] 02:25:15
                    > via em2.0
24.24.24.2/32      *[Local/0] 02:25:15
                      Local via em2.0
25.25.25.0/24      *[Direct/0] 02:25:15
                    > via em3.0
25.25.25.2/32      *[Local/0] 02:25:15
                      Local via em3.0
34.34.34.0/24      *[OSPF/10] 00:05:54, metric 2
                    > to 23.23.23.3 via em1.0
224.0.0.5/32       *[OSPF/10] 02:25:16, metric 1
                      MultiRecv

[edit]
root@Jun2# run show ospd
                    ^
syntax error, expecting <command>.
root@Jun2# run show ospf route 
Topology default Route Table:

Prefix             Path  Route      NH       Metric NextHop       Nexthop      
                   Type  Type       Type            Interface     Address/LSP
1.1.1.1            Intra Router     IP            1 em0.0         12.12.12.1
3.3.3.3            Intra Router     IP            1 em1.0         23.23.23.3
4.4.4.4            Intra Router     IP            2 em1.0         23.23.23.3
5.5.5.5            Intra AS BR      IP            1 em3.0         25.25.25.5
1.1.1.0/24         Ext2  Network    IP            2 em3.0         25.25.25.5
12.12.12.0/24      Intra Network    IP            1 em0.0
23.23.23.0/24      Intra Network    IP            1 em1.0
24.24.24.0/24      Intra Network    IP            1 em2.0
25.25.25.0/24      Intra Network    IP            1 em3.0
34.34.34.0/24      Intra Network    IP            2 em1.0         23.23.23.3

 

 

I see 1.1.1.1/24 is learned as an EXT2 route

But I am confused as 56.56.56.0/24 should be found the same as 1.1.1.1/24 (lo0)

As I exported directly connected routes in Rip and then exported rip to ospf

Thanks in advance

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 06:04 AM

OK, I see what you are trying to do. Most likely this will not work. I haven't tested though.

 

So what is your purpose? To have the 56.56.56/24 in the routing table of R2?

 

Why don't configure that interface as passive in area 20 and be done with it?

 

 

 

=====

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 06:32 AM

If Junos5 ospf interface is passive it won't form adjancies and the NSSA area will fail? or do you mean sometihng else?

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 06:36 AM

I'm talking about em1 interface(the interface between R5 and R6). You don't run any OSPF there.

 

Add this interface as passive under OSPF protocol configuration on R5.

 

 

 

=====

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 07:19 AM
protocols {
    ospf {
        export RIP;
        area 0.0.0.20 {
            nssa;
            interface em0.0;
        }
    }                                   
    rip {
        group walid {
            export rip-interfaces;
            neighbor em1.0;
        }
    }
}


I am not running em1 for ospf its just for rip

 

Highlighted
Routing
Solution
Accepted by topic author Wall-ED
‎08-26-2015 01:27 AM

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 07:28 AM

Yes, you are right. But adding em1 under OSPF as passive, doesn't mean that you are running OSPF on em1:

 

set protocols ospf area 20 interface em1 passive

 

 

 

=====

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

Highlighted
Routing

Re: Problem with OSPF areas on Junos GNS3 emulation.

‎09-29-2014 08:10 AM

It worked !

Thanks a lot

 

root@Jun2# run show route                                     

inet.0: 12 destinations, 12 routes (12 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.0/24         *[OSPF/150] 00:29:02, metric 2, tag 0
                    > to 25.25.25.5 via em3.0
12.12.12.0/24      *[Direct/0] 03:12:26
                    > via em0.0
12.12.12.2/32      *[Local/0] 03:12:26
                      Local via em0.0
23.23.23.0/24      *[Direct/0] 03:12:26
                    > via em1.0
23.23.23.2/32      *[Local/0] 03:12:26
                      Local via em1.0
24.24.24.0/24      *[Direct/0] 03:12:26
                    > via em2.0
24.24.24.2/32      *[Local/0] 03:12:26
                      Local via em2.0
25.25.25.0/24      *[Direct/0] 03:12:26
                    > via em3.0
25.25.25.2/32      *[Local/0] 03:12:26
                      Local via em3.0
34.34.34.0/24      *[OSPF/10] 00:00:09, metric 2
                      to 23.23.23.3 via em1.0
                    > to 24.24.24.4 via em2.0
56.56.56.0/24      *[OSPF/10] 00:00:05, metric 2
                    > to 25.25.25.5 via em3.0
224.0.0.5/32       *[OSPF/10] 03:12:27, metric 1
                      MultiRecv

[edit]

 

I'm sorry for the many questions I have bothered you with, I appreciate your patience.

Thanks again and have a nice day 🙂

Feedback