Routing

last person joined: 3 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  Q-in-Q - Unable to send multiple inner tags through single outer VLAN on MX

    Posted 03-03-2016 13:44

    Hello,

    I am working with an MX480 connected to a Cisco network.  I am trying to send multiple inner vlans through a single outer qinq tunnel interface.  Addtionally, I have the inner VLANs terminating to IRB interfaces on the MX.  When I use the following config I am able to pass traffic when I use a single outer and single inner tag, but if I try to add addtional inner tags, it won't pass any packets.  

     

    CONFIG WORKING WITH SINGLE TAGS:

     

    interfaces

    ge-2/1/2 {
    description "--- UPLINK TO TNDM-METR-SW1 G1/5 NNI-TRAFFIC ---";
    flexible-vlan-tagging;
    mtu 9000;
    encapsulation flexible-ethernet-services;
    unit 1345 {
    description "TEST QINQ UPLINK";
    encapsulation vlan-bridge;
    vlan-tags outer 1976 inner 345;

    irb {
    unit 345 {
    description "TEST QINQ 1";
    family inet {
    address 63.247.144.101/30;

    bridge-domains
    Z-OUTER-TEST {
    vlan-id 1976;
    }
    Z-TEST-INNER1 {
    vlan-id 345;
    interface ge-2/1/2.1345;
    routing-interface irb.345;

     

     

    I have tried adding multiple units - one for each inner/outer combination.  I've also tried the following with no success:

     

    ge-2/1/2 {
    description "--- UPLINK TO TNDM-METR-SW1 G1/5 NNI-TRAFFIC ---";
    flexible-vlan-tagging;
    mtu 9000;
    encapsulation flexible-ethernet-services;
    unit 1976 {
    vlan-id 1976;
    family bridge {
    interface-mode trunk;
    inner-vlan-id-list [ 345 456 ];
    }
    }
    bridge-domains
    Z-INNER-TEST1 {
    vlan-id 345;
    routing-interface irb.345;
    }
    Z-INNER-TEST2 {
    vlan-id 456;
    routing-interface irb.456;
    }
    Z-OUTER-TEST {
    vlan-id 1976;
    }

     

    NO LUCK

     

    Can someone please post a working example of how to send multiple inner VLANS through a single outer VLAN?

    Thanks in advance!

    -Colin Anderson

     



  • 2.  RE: Q-in-Q - Unable to send multiple inner tags through single outer VLAN on MX

    Posted 03-05-2016 06:14

    Try this:

    ge-2/1/2 {
     description "--- UPLINK TO TNDM-METR-SW1 G1/5 NNI-TRAFFIC ---";
     flexible-vlan-tagging;
     mtu 9000;
     encapsulation flexible-ethernet-services;
     unit 1976 {
    encapsulation vlan-bridge; vlan-id 1976; family bridge { interface-mode trunk; inner-vlan-id-list [ 345 456 ];

    It looks like you forgot to set encapsulation for unit 1976:



  • 3.  RE: Q-in-Q - Unable to send multiple inner tags through single outer VLAN on MX

    Posted 03-07-2016 12:04

    Thanks for the reply, but unfortunatly that didn't fix it.  When I add the second inner-vlan the first irb interface shows up/up, but the second one shows up/down.

    c.anderson@TNDM-T3-EDGE-01# run show interfaces terse irb    
    Interface               Admin Link Proto    Local                 Remote
    irb                     up    up
    irb.345                 up    up   inet     63.247.144.101/30
                                       multiservice
    irb.456                 up    down inet     63.247.144.105/30

    I can ping across irb.345 (which is transported through 1976) as well so I know the q-in-q is working for the first tag.

    If I try taking the top working example above and create a new unit 1456 with "vlan-tags outer 1976 inner 456" I get the same up/down on the irb.456 interface.  

     

    Any other suggestions are appreciated.

     

    Current Config NOT WORKING:

    interfaces 
    	ge-2/1/2 
    		flexible-vlan-tagging;
    		mtu 9000;
    		encapsulation flexible-ethernet-services;
    		unit 1976 {
    			encapsulation vlan-bridge;
    			vlan-id 1976;
    			family bridge {
    				interface-mode trunk;
    				inner-vlan-id-list [ 345 456 ];
    			}
    		}
    	irb {
    		unit 345 {
    			family inet {
    				address 63.247.144.101/30;
    			}
    		}
    		unit 456 {                              
    			family inet {
    				address 63.247.144.105/30;
    			}
    
    
    bridge-domains
    	Z-INNER-TEST1 {
    		vlan-id 345;
    		routing-interface irb.345;
    	}
    	Z-INNER-TEST2 {
    		vlan-id 456;
    		routing-interface irb.456;
    	}
    	Z-OUTER-TEST {
    		vlan-id 1976;
    	}
    

    Thanks!

     



  • 4.  RE: Q-in-Q - Unable to send multiple inner tags through single outer VLAN on MX
    Best Answer

    Posted 03-07-2016 14:14

    Okay, maybe I was over-engineering things here...

     

    Here is the config I used to get it working:

    interfaces ge-2/1/2 
    flexible-vlan-tagging;
    mtu 9000;
    encapsulation flexible-ethernet-services;
    unit 345 {
        vlan-tags outer 1976 inner 345;
        family inet {
            address 63.247.144.101/30;
        }
    }
    unit 456 {
        vlan-tags outer 1976 inner 456;
        family inet {
            address 63.247.144.105/30;
        }
    }
    
    bridge-domains
    
    Z-INNER-TEST1 {
        vlan-id 345;
    }
    Z-INNER-TEST2 {
        vlan-id 456;
    }
    Z-OUTER-TEST {
        vlan-id 1976;
    }

    Looks so simple!

    I was also able to send a 3rd trunked vlan just by adding another unit, setting encap vlan-bridge and inner/outer tags, and adding the interface.unit to the bridge-domain.