Routing

last person joined: 2 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  QFX mc-lag and family inet interfaces

    Posted 06-15-2018 16:03

    Hello everyone.

    I`m trying to set up mc-lag in my lab environment which looks like this:

                                            MX104

                                          /    ae0     \

                                       /                     \

                                    /   ae1(mc-lag)   \

                                QFX1 -------------- QFX2

                                                  ae0

     

    So i`ve got mc-lag between MX104 and 2 QFX 5110 switches.

    MX104:

    description "To QFX MC-LAG";
    flexible-vlan-tagging;
    mtu 9000;
    encapsulation flexible-ethernet-services;
    aggregated-ether-options {
        minimum-links 1;
        link-speed 10g;
        lacp {
            active;
            periodic fast;
        }
    }
    unit 4000 {
        vlan-id 4000;
    }
    

    On QFX-1:

    ae0 which used for iccp:

    mtu 9000;
    aggregated-ether-options {
    minimum-links 1;
    link-speed 10g;
    lacp {
    active;
    periodic fast;
    }
    }
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members all;
    }
    }
    }

    ae1 - mc-lag interface

    mtu 9000;
    aggregated-ether-options {
        lacp {
            active;
            periodic fast;
            system-id 00:01:02:03:04:05;
            admin-key 3;
        }
        mc-ae {
            mc-ae-id 3;
            chassis-id 0;
            mode active-active;
            status-control active;
            init-delay-time 240;
        }
    }
    unit 0 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members [ DC ICCP-4000 QFX-2_MX QFX-1_MX ];
            }
        }
    }
    

    Interface for ICCP:

    show interfaces irb unit 4000
    family inet {
        address 10.1.2.1/30 {
            arp 10.1.2.2 l2-interface ae0.0 mac f0:4b:3a:99:80:20;
        }
    }
    

     

    on QFX-2

    ae0

    mtu 9000;
    aggregated-ether-options {
        minimum-links 1;
        link-speed 10g;
        lacp {
            active;
            periodic fast;
        }
    }
    unit 0 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members all;
            }
        }
    }
    

    ae1:

    mtu 9000;
    aggregated-ether-options {
        lacp {
            active;
            periodic fast;
            system-id 00:01:02:03:04:05;
            admin-key 3;
        }
        mc-ae {
            mc-ae-id 3;
            chassis-id 1;
            mode active-active;
            status-control standby;
            init-delay-time 240;
        }
    }
    unit 0 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members [ DC ICCP-4000 QFX-2_MX QFX-1_MX ];
            }
        }
    }
    

    Interface for ICCP:

    show interfaces irb unit 4000
    family inet {
        address 10.1.2.2/30 {
            arp 10.1.2.1 l2-interface ae0.0 mac f0:4b:3a:99:03:20;
        }
    }
    

    everything works fine.

    than i want to add l3-interfaces between QFX1-MX and QFX2-MX:

    on MX104:

    show interfaces ae0 | display inheritance | except #
    description "To QFX MC-LAG";
    flexible-vlan-tagging;
    mtu 9000;
    encapsulation flexible-ethernet-services;
    aggregated-ether-options {
        minimum-links 1;
        link-speed 10g;
        lacp {
            active;
            periodic fast;
        }
    }
    unit 4000 {
        vlan-id 4000;
    }
    unit 4001 {
        description "To QFX-1 routing";
        vlan-id 4001;
        family inet {
            address 10.1.1.9/30;
        }
    }
    unit 4002 {
        description "To QFX-2 routing";
        vlan-id 4002;
        family inet {
            address 10.1.1.13/30;
        }
    }
    
    

    On QFX-1:

    show interfaces irb
    unit 4000 {
        family inet {
            address 10.1.2.1/30 {
                arp 10.1.2.2 l2-interface ae0.0 mac f0:4b:3a:99:80:20;
            }
        }
    }
    unit 4001 {
        family inet {
            address 10.1.1.10/30;
        }
    }
    

    on QFX-2

     show interfaces irb
    unit 4000 {
        family inet {
            address 10.1.2.2/30 {
                arp 10.1.2.1 l2-interface ae0.0 mac f0:4b:3a:99:03:20;
            }
        }
    }
    unit 4002 {
        family inet {
            address 10.1.1.14/30;
        }
        family iso;
        family mpls;
    }
    

    And the problem that i can only ping from QFX-1 to MX ( 10.1.1.8/30 ) but can not ping from QFX-2 to MX ( 10.1.1.12/30)

    when i`m shutting down QFX-1 i can ping 10.1.1.12/30

     

     



  • 2.  RE: QFX mc-lag and family inet interfaces

    Posted 06-15-2018 23:12

    You better use vrrp on vlan4001 and 4002 on qfx. This should be a common arp issue on mc-lag. I cannot find how QFX mc-lag treat broadcast on the ICL but I think that vrrp should fix it.



  • 3.  RE: QFX mc-lag and family inet interfaces
    Best Answer

     
    Posted 06-23-2018 23:13

    Can you check if ARP is learned on the MX and QFX?

    If ARP is not learned, then add a static ARP or go with VRRP to fix this issue.



  • 4.  RE: QFX mc-lag and family inet interfaces

    Posted 07-05-2018 14:21

    Sorry guys for late answer.

    Yes, static arp solves problem.