Routing
Routing

[QUESTION][OSPF] Cisco to Juniper migration

[ Edited ]
‎05-23-2019 09:06 PM
Hello Guys,
 
I am looking forward to how to migrate Cisco OSPF to Juniper OSPF
Please answer it.. if you know..
 
Here Cisco Config,
 
interface Ethernet0/0
udld disable
ip ospf cost 1000
no ip ospf passive-interface
 
router ospf 1
area 0.0.0.0 nssa no-summary no-redistribution
default-information originate
timers throttle spf 10 100 5000
timers lsa-arrival 80
timers throttle lsa 10 100 5000
auto-cost reference-bandwidth 100000
passive-interface default
 
What is Juniper Config?
 
Very thanks in advance,
4 REPLIES 4
Routing

Re: [QUESTION][OSPF] Cisco to Juniper migration

‎05-23-2019 10:40 PM

Hi Charlies,

 

Some options might need tweaking based on different options on Juniper, included comments below.  Please check if this helps.  

Interface Config:
------------------
Comments:
---------
udld disable is not needed on Juniper;

Config:
---------
set interfaces ge-0/0/0

OSPF:
------------------
Comments:
---------
Default is no-passive; The config to set passive-interface as default isn't there.
NSSA config options: https://www.juniper.net/documentation/en_US/junos/topics/example/ospf-not-so-stubby-area-configuring...
Can't find exact equivalent of lsa-arrival timer (time to allow repeat of same LSA) but check the rate-limiting options.
LSA refresh: https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/ospf-flooding-reduction-...
LSA throttle (rate-limiting): https://www.juniper.net/documentation/en_US/junos/topics/topic-map/ospf-database-protection.html
SPF options

root@jtac-QFX5100-48S-6Q-r053# set protocols ospf lsa-refresh-interval ?
Possible completions:
<lsa-refresh-interval> LSA refresh interval (minutes) (25..50)


root@jtac-QFX5100-48S-6Q-r053# set protocols ospf database-protection ?
Possible completions:
<[Enter]> Execute this command
+ apply-groups Groups from which to inherit configuration data
+ apply-groups-except Don't inherit configuration data from these groups
ignore-count Maximum number of times to go into ignore state (1..32)
ignore-time Time to stay in ignore state and ignore all neighbors (30..3600 seconds)
maximum-lsa Maximum allowed non self-generated LSAs (1..1000000)
reset-time Time after which the ignore count gets reset to zero (60..86400 seconds)
warning-only Emit only a warning when LSA maximum limit is exceeded
warning-threshold Percentage of LSA maximum above which to trigger warning (30..100 percent)
| Pipe through a command


Juniper# set protocols ospf spf-options ?
Possible completions:
+ apply-groups Groups from which to inherit configuration data
+ apply-groups-except Don't inherit configuration data from these groups
delay Time to wait before running an SPF (50..8000 milliseconds)
holddown Time to hold down before running an SPF (2000..20000 milliseconds)
no-ignore-our-externals Do not ignore self-generated external and NSSA LSAs
rapid-runs Number of maximum rapid SPF runs before holddown (1..10)


Config:
---------
set protocols ospf area 0 interface ge-0/0/0 metric
set protocols ospf area 0.0.0.0 nssa no-summaries default-lsa default-metric 10
set protocols ospf reference-bandwidth 100000

 

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Highlighted
Routing

Re: [QUESTION][OSPF] Cisco to Juniper migration

‎05-25-2019 11:05 AM

Hi,

 

You can also use below IOS to Junos converter.

 

How to use the IOS to JUNOS translator (I2J) tool for converting full IOS configuration files into J...

 

//Regards

AD

 

[KUDOS PLEASE! If you think I earned it!

If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]

Routing

Re: [QUESTION][OSPF] Cisco to Juniper migration

‎06-27-2019 09:04 PM

Hi Charlies,

 

Was your query resolved? Please help share the resolution and/or mark the relevant post as Solution so others can benefit from your post.  

 

Thank you in advance for your time.

 

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Routing

Re: [QUESTION][OSPF] Cisco to Juniper migration

‎06-28-2019 12:12 AM

Hi Charlies,

 

Please find the converted configuration from IOS to Juniper.

 

interfaces {
    fe-0/0/0 {
        hold-time up 0 down 2000;
        unit 0 {
            proxy-arp;
        }
    }
}
routing-options {
    static {
        route 0.0.0.0/0 discard;
    }
}
protocols {
    ospf {
        export default-route;
        reference-bandwidth 100000000000;
    }
}
policy-options {
    policy-statement default-route {
        term 1 {
            from {
                protocol static;
                route-filter 0.0.0.0/0 exact;
            }
            then accept;
        }
    }
}

 

 

Regards,
Akash


'Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!'