Routing
Highlighted
Routing

RPM not Working

‎11-21-2018 03:47 AM

Hello all, can someone help me with this SRX RPM, it already applied, but i still cannot recieved the package from internet ( still cannot connect to internet), my junos version is 12.1X47-D10

 

error1.PNGerror 2.PNG

7 REPLIES 7
Highlighted
Routing

Re: RPM not Working

‎11-21-2018 03:58 AM

Hi,

Could you share the config and let us know what you want to acheive? If possible, a diagram which shows how your PC and ISP are connected

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790)
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
Highlighted
Routing

Re: RPM not Working

‎11-21-2018 04:38 AM

You can run the test manually from the routing instance to confirm.  But it looks like the ge-0/0/5.0 interface in routing instance Neuviz cannot reach 8.8.8.8

 

ping 8.8.8.8 routing-instance Neuviz

 

Is there an ip address to use as the source in this RI?

Is the return route from the internet to that address in place?

 

check the trace route out as well.

traceroute 8.8.8.8 routing-instance Neuviz

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
Routing

Re: RPM not Working

‎11-21-2018 08:35 AM

conf 1.PNGconf 2.PNGconf 3.PNGconf.PNG

Hello Nellikka, thanks for the response,

i want to make it automaticly switch to other ISP is the main ISP down and vice versa..

are my configuration is right?? or missing something??

 

my topology is like this..

topoo.PNG

Highlighted
Routing

Re: RPM not Working

‎11-21-2018 08:47 AM

Hello Spuluka,

 

thanks for your response..

of course it cannot reach to 8.8.8.8 because the ISP 2 is down..

i am confuse, why the RPM is not working (switch the package to ISP 1), but the status is Applied..

and i use a firewall to split the ip segmentation ( split the user like priority client to ISP 1 and other client to ISP 2 ).

 

conf 5.PNG

Highlighted
Routing

Re: RPM not Working

‎11-21-2018 04:00 PM

Sorry I had the failure scenario backwards.

 

The RPM route next hop is that reachable from the RI where applied?

It looks like the route might not be active because the next hop is in the ohter routing instance.  But it is hard to be sure without a diagram.  All the RPM probe does is install that route during failure.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
Routing

Re: RPM not Working

‎11-22-2018 02:23 AM

Hello Spuluka,

 

i already fix the RPM, and it works..

but the RPM will work if i disable the firewall filter..

can the RPM + ip-monitoring works with firewall filter??

 

Thanks.

 

Highlighted
Routing

Re: RPM not Working

‎11-22-2018 04:26 AM

As long as the FBF filter is downstream of the routing tables that are inserted by the RPM this should be no problem.  But the filter can override the routing table destination decision with a source based next hop if it is applied to the same table where you are inserting the RPM based route option.

 

We would need to see the interface connections and where the filter is applied.

 

And then do some trace routes and routing table examinations of each hop during the RPM failure scenario to troubleshoot.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home