Routing on EX switch broken after changing from VC to non VC - solved

07.20.17   |  
‎07-20-2017 12:28 PM

I'm posting this mostly in case someone else comes across it.


We had an EX4500 which was configured to be a virtual chassis but the 2nd member (of 2 total) was removed by an unscrupulous person. It was my job to upgrade it, and convert it back to a single switch (router).


I had the config but I forgot to remove the "set routing-options nonstop-routing" statement from the config when I re-applied it. I had already deleted the rest of the virtual chassis commands.


This statement is accepted by the switch when you commit, even when you don't have a virtual chassis setup. And in my case it disabled routing completely.


Normally there is an IP address next to a port if you do "show interfaces terse" or "show interfaces routing". In my case the IP address was not there.


Also show route showed no default route, despite a default route being clearly set in the config.


Deleting the "set routing-options nonstop-routing" statement magically fixed routing. Took me a while to figure it out. While the site was down.


Hopefully someone comes across this and it solves their problem.