Routing
Highlighted
Routing

Segment routing using OSPF on MX error: can't config SRGB

‎05-16-2020 03:28 PM

Hi everybody,

I am trying to lab up Segment routing on vMX, but keep getting this error:

 

jcluser@vMX1# commit
[edit protocols ospf source-packet-routing]
'srgb'
can't config SRGB
error: configuration check-out failed

 

##CONFIG##

jcluser@vMX1# show protocols ospf | display set
set protocols ospf source-packet-routing node-segment ipv4-index 1
set protocols ospf source-packet-routing srgb start-label 1000
set protocols ospf source-packet-routing srgb index-range 9000
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
set protocols ospf area 0.0.0.0 interface lo0.0

## JUNOS VERSION##

jcluser@vMX1# run show version
Hostname: vMX1
Model: vmx
Junos: 19.4R1.10

 

What am I missing?

Thanks and have a good weekend!!

1 REPLY 1
Highlighted
Routing
Solution
Accepted by topic author sarahr202
‎05-16-2020 05:51 PM

Re: Segment routing using OSPF on MX error: can't config SRGB

‎05-16-2020 04:57 PM

Hi sarahr202,

 

Howdy, do you have the following configuration knob enabled perhaps?

 

[edit chassis network-services]
user@R1# set enhanced-ip
 
Please check the following link as well for more details about this issue and some other question you might have: https://forums.juniper.net/t5/Routing/SRGB-range-configuration-error/m-p/460487#M19408
 

If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \:)/

Regards,

 

Lil Dexx
JNCIE-ENT#863, 3X JNCIP-[SP-ENT-DC], 4X JNCIA [cloud-DevOps-Junos-Design], Champions Ingenius, SSYB

Feedback