Routing

last person joined: 3 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  VLANs confusing

    Posted 10-04-2010 10:07

    Hello Everybody,

     

    I'm newbie with Juniper and a little bit confused with two types of VLANs. Could anyone explain the difference between "interface -> vlan -> ..." and "vlans -> ..." ?

     

    Best regards,

    Stasnilav



  • 2.  RE: VLANs confusing

    Posted 10-04-2010 11:05

    The interface->vlan is where you configure your various layer-3 vlan interfaces.  The vlan hierarchy is where you define the vlans by name, and associate those to the vlan-id as well as associate the l-3 interface to the vlan.

     

    Ron



  • 3.  RE: VLANs confusing

    Posted 10-05-2010 00:06

    I don't quite see what you mean.

    Which of them is ordinary vlans (as used in simple switches, in cisco, etc). What the difference between ordinary vlan and other one? Why is the other called vlan too?



  • 4.  RE: VLANs confusing

    Posted 10-05-2010 05:22

    the vlans section is where you configure a "normal" vlan.  The layer-3 section (interfaces->vlan) is where you setup IP addresses for use with those VLANs so the switch can route traffic at layer-3 rather than just via layer-2.

     

    Ron



  • 5.  RE: VLANs confusing
    Best Answer

    Posted 10-05-2010 05:50

     

    Maybe a comparison will help.
    --Firstly configuring a VLAN:
    IOS
    #vlan-database
    (vlan)# vlan 5 name Accounting
    (vlan)# vlan 6 name Management
    (vlan)# apply
    JUNOS
    set vlan Accounting vlan-id 5
    set vlan Management vlan-id 6

     

    Assign an IP address to a VLAN:
    IOS
    (config)#interface vlan 5
    (config-if)#ip address 10.0.0.254 255.255.255.0

     

    JUNOS
    set interfaces vlan unit 5 family inet address 10.0.0.254/24
    set vlan Accounting l3-interface vlan.5

     

    Assigning a port to a VLAN (Access):
    IOS
    (config)#interface fastEthernet 2/2
    (config-if)#switchport mode access
    (config-if)#switchport access vlan 5

     

    JUNOS
    set interfaces fe-2/0/2 unit 0 family ethernet-switching port-mode access
    set interfaces fe-2/0/2 unit 0 family ethernet-switching vlan members Management

     

    Assigning a port to a VLAN (6 Trunked with 5 Native)
    IOS
    (config)#interface fastEthernet 2/2
    (config-if)#switchport mode trunk
    (config-if)#switchport trunk encapsulation dot1q
    (config-if)#switchport trunk native vlan 5
    (config-if)#switchport trunk allowed vlan 5,6

     

    JUNOS
    set interfaces fe-2/0/2 unit 0 family ethernet-switching port mode trunk
    set interfaces fe-2/0/2 unit 0 family ethernet-switching native-vlan-id 5
    set interfaces fe-2/0/2 unit 0 family ethernet-switching vlan members 6

     

    Hope this helps



  • 6.  RE: VLANs confusing

    Posted 10-08-2010 06:17

    Thanks a lot! It is very helpful.