Routing
Routing

frequent RE High CPU Utilization MX480

‎04-05-2019 10:07 PM

Hi All,

 

Am getting RE High CPU utilization frequently on the NMS server. it keeps appearing after every 30mins or less and stays for like 20~30 mins and then resolves. when it appears, if i chech "show chassis routing-engine", i see kernel usage is 9%, users is 5% and roughly ~86% is always idle. not sure why it says high utilization when more than ~80% os idle. 

 i have run the  "show chassis routing-engine" several times and all the time, there is no single process using more 10%. 

 

we have done recent junos upgrade from 15.1 to 17.3R3-S2.2, i have also noticed that "comit" takes long after the upgrade. 

 

Model: mx480
Junos: 17.3R3-S2.2

Routing Engine status:
  Slot 0:
    Current state                  Master
    Election priority              Master (default)
    Temperature                 53 degrees C / 127 degrees F
    CPU temperature             49 degrees C / 120 degrees F
    DRAM                      2048 MB (2048 MB installed)
    Memory utilization          35 percent
    5 sec CPU utilization:
      User                       3 percent
      Background                 0 percent
      Kernel                     7 percent
      Interrupt                  3 percent
      Idle                      87 percent
    1 min CPU utilization:
      User                       8 percent
      Background                 0 percent
      Kernel                    11 percent
      Interrupt                  2 percent
      Idle                      78 percent
    5 min CPU utilization:
      User                       7 percent
      Background                 0 percent
      Kernel                    10 percent
      Interrupt                  2 percent
      Idle                      81 percent
    15 min CPU utilization:
      User                       6 percent
      Background                 0 percent
      Kernel                    10 percent
      Interrupt                  2 percent
      Idle                      82 percent
    Model                          RE-S-1300
    Serial ID                      9009065063
    Start time                     2019-04-05 06:18:06 EAT
    Uptime                         1 day, 1 hour, 47 minutes, 51 seconds
    Last reboot reason             Router rebooted after a normal shutdown.
    Load averages:                 1 minute   5 minute  15 minute
                                       0.70       0.78       0.83
Regards,
Lish
FON
5 REPLIES 5
Routing

Re: frequent RE High CPU Utilization MX480

‎04-05-2019 10:23 PM
Routing

Re: frequent RE High CPU Utilization MX480

[ Edited ]
‎04-06-2019 12:10 AM

Hi,

Thanks for the referenced thread. 

i have gone through and it mentions "latest supported junos for "RE-1-1300"  is 14.2 .... so since we are runing non-suported junos, could it be that the "sh chasis routing-engine" output is not correct and that RE CPU utilzation is high even though the output says 80% idle? or is the router sharing misleading SNMP traps to the NMS ? 

 

what would you advise us to do here ? downgrade to 14.2 and stay there ?

 

 

 

 

Regards,
Lish
FON
Routing
Solution
Accepted by topic author lish
‎04-13-2019 12:10 AM

Re: frequent RE High CPU Utilization MX480

‎04-06-2019 05:36 AM

I suspect the cpu alarm on NMS is just a false positive based on your description and nothing to worry about.  You might be able to clear this by turning off the standard cpu mib in the NMS and searching the Juniper mibs for the specific ones that you see using the junos commands.  The standard mib is seeing a top level blended stat that is less helpfulful anyway.

 

As to the Junos support per specific RE.  The end of support per version means two things.

 

They no longer include that routing engine in any of the unit tests as Junos is released so you might run into bugs and other issues by using Junos past the final version.  And if you have JTAC tickets that are tricky and linked at all to RE processing you will be asked to downgrade to a supported version.

 

Each new version of Junos puts more demands on both CPU and local storage.  As you go up past the last supported version you can have disk space or performance issues  like the long commit times you are seeing.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Routing

Re: frequent RE High CPU Utilization MX480

‎04-13-2019 12:14 AM
Thanks Steve,

On top of the high cpu utilization, we noticed the FPC line card just started rebooting randomly affecting service. It rebooted like 4 times in single day . We downgraded to 15.1 which is not the last supported version but its what we were running before the upgrade and this new problems we're not there.

Since the downgrade we have noticed all is behaving now.the high cpu alarms are gone.

Regards,
Lish
FON
Routing

Re: frequent RE High CPU Utilization MX480

‎04-13-2019 05:03 AM

Thanks for the update.  Makes sense that the issues occured may be the reason the new version was not listed as supported on the hardware.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home