Routing
Highlighted
Routing

how to configure 40G port on mx204

‎02-25-2020 11:20 PM

Can someone guide me how to configure the 4 port to 40G on mx204?

Right now I see

xe-0/0/0:0 up up
xe-0/0/0:1 up up
xe-0/0/0:2 up up
xe-0/0/0:3 up up
I refer https://www.juniper.net/documentation/en_US/junos/topics/topic-map/rate-selectability-configuring.ht...

not working as it should.

Thanks

7 REPLIES 7
Routing

Re: how to configure 40G port on mx204

‎02-26-2020 01:51 AM

Hi

 

As the document suggests which method are you using of the 2 methods "pic level" or "port level" ?

Both the method didnt work ? Are you getting some error while changing the config.

Highlighted
Routing

Re: how to configure 40G port on mx204

‎02-26-2020 01:58 AM

Hi,

 

please refer to the below link , it mentions some rules to follow to be able to change rate on MX204 ports
https://www.juniper.net/documentation/en_US/junos/topics/topic-map/rate-selectability-overview.html#...

 

If this solves your problem, please mark this post as "Accepted Solution

Regards,
A.A.
Highlighted
Routing

Re: how to configure 40G port on mx204

‎02-26-2020 06:40 AM

I configured port 0,1 at 40g

[edit chassis fpc 0 pic 0]
root@x# show
port 0 {
speed 40g;
}
port 1 {
speed 40g;
}

 

  But when I run show interface command I see them as xe.. not et-0

 

xe-0/0/0:0 up up
xe-0/0/0:1 up up
xe-0/0/0:2 up up
xe-0/0/0:3 up up

 

There is no option in configuration to delete and configure as et-0/0/0

Can someone guide me how to fix?

Highlighted
Routing

Re: how to configure 40G port on mx204

‎02-26-2020 06:50 AM

Please check below link to make sure your configuration for both pic 0 and pic 1 are valid:

https://apps.juniper.net/home/port-checker/index.html

 

Also check "show system alarms" to see if any alarms related to PIC.

If your configuration is valid, but port didn't get changed from xe to et, you mostly need to restart the PIC or FPC 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Highlighted
Routing

Re: how to configure 40G port on mx204

‎02-26-2020 06:57 AM

There is only one port 0 @ 40G connected to ex4300 switch and I checked the configuration via that app.

 

2 alarms currently active
Alarm time Class Description
 UTC Minor FPC 0 PIC 1 Invalid port profile configuration
 UTC Minor FPC 0 PIC 0 Invalid port profile configuration

but when I checked config before commit it passed,

 

 

Highlighted
Routing

Re: how to configure 40G port on mx204

‎02-26-2020 08:57 AM

If you are not using any ports on PIC1, please configure following:

 

set chassis fpc 0 pic 1 number-of-ports 0

 

After that restart the FPC.  You should see the 40Gig ports

If that doesn't work please send complete "show chassis alarm/show chassis hardware/show configuration chassis" output

 

Thanks
Vishal

Highlighted
Routing

Re: how to configure 40G port on mx204

‎02-26-2020 01:18 PM

Hi,

I'm still quite new to Juniper, so sorry if this is bad advice, but are you using a break out cable?

 

In past (with another vendor) I have had 40G QSFP ports on a switch, and attached a breakout cable, which converted the one port into four 10G SFP+ ports.

 

Could your issue be something like this?

Feedback