Routing
Highlighted
Routing

l2circuit is UP, but no traffic is forwarded

‎07-15-2013 07:50 AM

Hi, 

  as subject, I have a problem with a l2circuit.

The l2circuit is Up, test with ping mpls is fine, but no traffic is forwarded through that circuit. (tried to ping from a CE to the other. - with wireshark I can see the arp request coming in the em1.10 interface, with the correct vlan id)

 

root@JUNOS6> show l2circuit connections 
Layer-2 Circuit Connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NP -- interface h/w not present   
MM -- mtu mismatch               Dn -- down                       
EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down    
CM -- control-word mismatch      Up -- operational                
VM -- vlan id mismatch		 CF -- Call admission control failure
OL -- no outgoing label          IB -- TDM incompatible bitrate 
NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration 
BK -- Backup Connection          ST -- Standby Connection
CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
LD -- local site signaled down   RS -- remote site standby
RD -- remote site signaled down  XX -- unknown

Legend for interface status  
Up -- operational            
Dn -- down                   
Neighbor: 10.0.0.2 
    Interface                 Type  St     Time last up          # Up trans
    em1.10(vc 10)             rmt   Up     Jul 15 14:42:36 2013           1
      Remote PE: 10.0.0.2, Negotiated control-word: Yes (Null)
      Incoming label: 299776, Outgoing label: 299776
      Negotiated PW status TLV: No      
      Local interface: em1.10, Status: Up, Encapsulation: VLAN
                    

 

root@JUNOS6> ping mpls l2circuit interface em1.10 
!!!!!
--- lsping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss

 

root@JUNOS6> show interfaces em1.10 
  Logical interface em1.10 (Index 71) (SNMP ifIndex 510) 
    Flags: SNMP-Traps VLAN-Tag [ 0x8100.10 ]  Encapsulation: VLAN-CCC
    Bandwidth: 0
    Input packets : 10 
    Output packets: 0
    Protocol ccc, MTU: 1514
      Flags: Is-Primary

 

root@JUNOS7> show interfaces em1.10 
  Logical interface em1.10 (Index 74) (SNMP ifIndex 510) 
    Flags: SNMP-Traps VLAN-Tag [ 0x8100.10 ]  Encapsulation: VLAN-CCC
    Bandwidth: 0
    Input packets : 5 
    Output packets: 0
    Protocol ccc, MTU: 1514
      Flags: Is-Primary

 

 

How can I troubleshoot that problem?

 

Here my configuration:

 

interfaces {
    em0 {
        unit 0 {
            family inet {               
                address 192.168.0.1/30; 
            }                           
            family mpls;                
        }                               
    }                                   
    em1 {                               
        vlan-tagging;                   
        encapsulation vlan-ccc;         
        unit 10 {                       
            encapsulation vlan-ccc;     
            vlan-id 10;                 
        }                               
        unit 11 {                       
            vlan-id 11;                 
            family inet {               
                address 192.168.3.1/24; 
            }                           
        }                               
    }                                   
    lo0 {                               
        unit 0 {                        
            family inet {               
                address 10.0.0.1/32;    
            }                           
        }                               
    }                                   
}                                       
protocols {                             
    mpls {                              
        traffic-engineering mpls-forwarding;
        interface lo0.0;                
        interface em0.0;                
    }                                   
    ospf {                              
        traffic-engineering;            
        area 0.0.0.0 {                  
            interface lo0.0 {           
                passive;                
            }                           
            interface em0.0;            
        }                               
    }                                   
    ldp {                               
        interface em0.0;                
        interface lo0.0;                
        igp-synchronization holddown-interval 10;
    }                                   
    l2circuit {                         
        neighbor 10.0.0.2 {             
            interface em1.10 {          
                virtual-circuit-id 10;  
                control-word;           
                mtu 1400;               
                encapsulation-type ethernet-vlan;
                ignore-encapsulation-mismatch;
                ignore-mtu-mismatch;    
            }                           
        }                               
    }                                   
}                                       

 thanks a lot,

stefano

5 REPLIES 5
Highlighted
Routing
Solution
Accepted by topic author stefano@rfc2821.it
‎08-26-2015 01:27 AM

Re: l2circuit is UP, but no traffic is forwarded

‎07-15-2013 08:23 AM

Hello,

L2circuit and Kompella L2VPN do not work on Olive and never worked. 

You have to get a real kit to practice it.

HTH

Thanks

Alex

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: l2circuit is UP, but no traffic is forwarded

‎07-15-2013 08:33 AM

ok, thank you for your answer!

 

Do you know if trying to terminate the circuit from a olive to a cisco works?

 

thanks

stefano

Highlighted
Routing

Re: l2circuit is UP, but no traffic is forwarded

‎07-15-2013 08:48 AM

Hello,

Only control plane for L2circuit/Kompella L2VPN establishes on Olive side. The data plane does not work, and never worked.

Don't know what CSCO kit You are using, so no comment on this.

HTH

Thanks

Alex

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: l2circuit is UP, but no traffic is forwarded

‎01-30-2014 03:44 PM

I have tried this with the real kit juniper 210 and mx80 . L2vpn is up and security policies are ok . 

but still does not pass ip traffic . 

 

ex2200---srx210---( Gre & IPSEC MPLS) --------------Mx80 ---- sw 4200 

Ex2200 interface  vlan.8 ip address 10.30.154.2/24

Ex4200 - vlan8 10.30.154.1/24

 

mpls between SRX210 and Mx80 is ok and passing traffic for vpls instances but not for any RI  l2vpn instance

 

Instance: AUMEL-INF-PENSOL-EXEC-VLAN8
Local site: ADELAIDE (2)
connection-site Type St Time last up # Up trans
1 rmt Up Jan 30 00:50:31 2014 2
Remote PE: 10.255.255.254, Negotiated control-word: Yes (Null)
Incoming label: 800004, Outgoing label: 800771
Local interface: ge-0/0/0.8, Status: Up, Encapsulation: VLAN

 

Instance: pensol-ivr-management-2
Local site: adelaide (2)
connection-site Type St Time last up # Up trans
1 rmt Up Jan 30 00:50:31 2014 3
Remote PE: 10.255.255.254, Negotiated control-word: Yes (Null)
Incoming label: 800000, Outgoing label: 800769
Local interface: ge-0/0/0.153, Status: Up, Encapsulation: VLAN

 

@SRX-ADELAIDE# run ping mpls rsvp ADE-to-Carrum
!!!!!
--- lsping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss

 

gauravg@SRX-ADELAIDE# run ping mpls l2circuit interface ge-0/0/0.8
Requested connection is not found, exiting.

 

gauravg@SRX-ADELAIDE# run ping mpls l2circuit interface ge-0/0/0.153
Requested connection is not found, exiting.

 

 

 

gosain
Highlighted
Routing

Re: l2circuit is UP, but no traffic is forwarded

‎01-30-2014 04:30 PM

Just applyed the inputfilter for the packet mode and it worked ... 

 

 

set firewall family ccc filter allow-all term 1 then packet-mode 

set firewall family ccc filter allow-all term 1 then accept  

 

Cheers  !! 

 

 

gosain
Feedback