Routing
Highlighted
Routing

no-upper-interface error on qinq dynamic profile

‎11-24-2018 06:37 AM

Hi everyone,

 

I have  a running MX104 as PPPoE server using autoconfigure vlans working well.

 

Now I am trying to enable qinq autoconfigure vlans on the same interface (the only one available) and it isnt working.

 

The customers requests are coming to the interface, being authorized by radius but the connection starts and stops immediatly.

 

The machine is registering the no-upper-interface error as shown:

 

admin@BRAS-OPR01# run show network-access aaa terminate-code ppp detail | match 9
  9          no     0           ppp  dynamic-profile-instantiation-failed
  9          no     112         ppp  no-upper-interface
  9          no     0           ppp  recovery-active-state-cleanup

 

I have tried this configuration directly on the qinq interface but I had the same problem.

 

Does anyone knows this error? 

 

I am using a MX104 with Junos: 13.3R8.7 and this is my configuration:

 

admin@BRAS-OPR01# show dynamic-profiles stacked-vlan-profile
interfaces {
    demux0 {
        unit "$junos-interface-unit" {
            vlan-tags outer "$junos-stacked-vlan-id" inner "$junos-vlan-id";
            demux-options {
                underlying-interface "$junos-interface-ifd-name";
            }
            family pppoe {
                access-concentrator BRAS-OPR;
                duplicate-protection;
                dynamic-profile pppoe-profile;
            }
        }
    }
}

[edit]
admin@BRAS-OPR01# show dynamic-profiles pppoe-profile
routing-instances {
    "$junos-routing-instance" {
        interface "$junos-interface-name";
        routing-options {
            access-internal {
                route $junos-subscriber-ip-address {
                    qualified-next-hop "$junos-interface-name";
                }
            }
        }
    }
}
interfaces {
    pp0 {
        unit "$junos-interface-unit" {
            ppp-options {
                pap;
            }
            pppoe-options {
                underlying-interface xe-0/1/0.621;
                server;
            }
            keepalives interval 15;
            family inet {
                filter {
                    input "$junos-input-filter";
                    output "$junos-output-filter";
                }
                unnumbered-address "$junos-loopback-interface";
            }
        }
    }
}

[edit]
admin@BRAS-OPR01# show interfaces xe-0/1/0 auto-configure
stacked-vlan-ranges {
    dynamic-profile stacked-vlan-profile {
        accept pppoe;
        ranges {
            1-4094,1-4094;
        }
    }
}
vlan-ranges {
    dynamic-profile vlan-profile {
        accept pppoe;
        ranges {
            1-4094;
        }
    }
}
remove-when-no-subscribers;

 

Best regards,

Thiago Andrade

3 REPLIES 3
Routing

Re: no-upper-interface error on qinq dynamic profile

‎11-24-2018 06:44 AM

Hi,

 

Could you configure  "flexible-vlan-tagging" under the interface?

 

 

 

 

/Karan Dhanak
Highlighted
Routing

Re: no-upper-interface error on qinq dynamic profile

‎11-24-2018 06:52 AM

Also, change the underyling-interface to variable $junos-underlying-interface

 

    pppoe-options {
                underlying-interface xe-0/1/0.621;

 

 

/Karan Dhanak
Highlighted
Routing

Re: no-upper-interface error on qinq dynamic profile

‎11-26-2018 02:36 AM

Hi

 

The flexible-vlan-tagging was already set. I've changed the underlying interface but it still has the same problem.

 

Any other suggestion?

Feedback