SDN
SDN

Troubleshooting: Default kernel version for Contrail 2.x installation

by Juniper Employee on ‎09-23-2015 01:57 PM - edited on ‎09-19-2017 10:22 AM by Administrator Administrator (1,006 Views)

Setting the Correct Default Kernel for Contrail 2.x Installation on Ubuntu 14.04.2

 

Contrail 2.x software requires that you install a specific kernel version before you begin the Contrail installation.

 

For example, after running fab upgrade_kernel_all on Ubuntu 14.04.2 to upgrade the kernel, the command uname -a still displays the kernel version as 3.16.0-30-generic, which is the stock kernel version on Ubuntu 14.04.2.

 

The recommended kernel version for Contrail installations on Ubuntu 14.04.2 is 3.13.0-40-generic.

 

Since the stock kernel version is higher than the recommended kernel version, the operating system always boots with the stock kernel version even though the recommended kernel is installed.

 

For each server participating in the Contrail Fabric after running fab upgrade_kernel_all, set the correct default kernel version for Contrail 2.x installation on Ubuntu 14.04.2:

 

  1. Open the /etc/default/grub file.

  2. Within the grub file, change the GRUB_DEFAULT=0 value to:
    GRUB_DEFAULT='Advanced options for Ubuntu>Ubuntu, with Linux 3.13.0-40-generic’ 
  3. Enter the following commands to update grub, and reboot the system:
    root@test:~# update-grub
    root@test:~# reboot
  4. After all of the servers are back up and running, you can enter the uname -a command to verify the kernel version from which the operating system has booted.
  5. Continue with the Contrail installation process.