SRX Services Gateway
SRX Services Gateway

DNS problems on SRX110h2-va

a week ago
Hi, having a problem getting my router to be the DNS server on my SRX110.
 
I have set up dns-proxy and it works if I manually configure my connected clients (that connect using DHCP) to the routers IP address. but by default, they are assigned the DNS name servers from my ISP.   I want all my DHCP clients to get the router as the (forwarding) name server.
 
I have tried all sorts of configurations to give out my routers IP address instead of the WAN assign address, but nothing works.

 

Here is the configuration I am running:

https://pastebin.com/raw/At14arwX

1 REPLY 1
SRX Services Gateway
Solution
Accepted by topic author MarkG1234
a week ago

Re: DNS problems on SRX110h2-va

[ Edited ]
a week ago

Hello,

 


@MarkG1234 wrote:
but by default, they are assigned the DNS name servers from my ISP.   

 

This happens because of this line in Your config:

 

propagate-ppp-settings pp0.0

 

You need to delete it to stop ISP DNS server IPs being dished out to Your DHCP clients 

 

 


@MarkG1234 wrote:
 I want all my DHCP clients to get the router as the (forwarding) name server.
 
I have tried all sorts of configurations to give out my routers IP address instead of the WAN assign address, but nothing works.

 



You need to specify router IP as "name-server" in Your config, under pool. 

 

set services dhcp pool 192.168.1.0/24 name-server 192.168.1.1

 

 

BUT - this is old deprecated way to configure JUNOS DHCP server. Please try the new way - example at https://www.juniper.net/documentation/en_US/junos/topics/topic-map/dhcp-server-security-devices.html...

 

HTH

Thx

Alex

 

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !