SRX Services Gateway
SRX Services Gateway

Dual Control Links of SRX3600 issue, control link 1 can't work

04.12.12   |  
‎04-12-2012 09:06 PM

I connected Dual Control Linksfor SRX3600 in a Chassis Cluster. The SRX3k-CRM modules have been installed in two SRX3600. The Control Link Port 1 is up. But When I pull out the fiber which connect the Control Link Port 0,

the node1 lost, shown as bellow:

{primary:node0}[edit]
netscreen@ZH-SRX3600-A# run show chassis cluster status   
Cluster ID: 1
Node                  Priority          Status    Preempt  Manual failover

Redundancy group: 0 , Failover count: 1
    node0                   200         primary        no       no 
    node1                   0           lost           n/a      n/a

Redundancy group: 1 , Failover count: 1
    node0                   200         primary        no       no 
    node1                   0           lost           n/a      n/a

 

I have collected some information before I pull out the fiber which connect the Control Link Port 0.

 

The SRX 3600 software version is 11.2R2.5。

 

I find the physical port em1 is up when i run show interfaces terse but the status of Control interfaces em1 is down when i run show chassis cluster interfaces. I also find that the Heartbeat packets of Control link 1 of node 1 is 0 and the Heartbeat packets of Control link 1 of node 0 is 360 when i run show chassis cluster statistics on both nodes.  The result of show commands about chassis cluster and jsrpd log are uploaded as attachments.

 

What's the problem? Please help. Thanks.

 

Attachments

6 REPLIES
Highlighted
SRX Services Gateway

Re: Dual Control Links of SRX3600 issue, control link 1 can't work

04.18.12   |  
‎04-18-2012 07:25 AM

Do you have recovery set in the configuration?

set chassis cluster control-link-recovery

SRX Services Gateway

Re: Dual Control Links of SRX3600 issue, control link 1 can't work

06.06.12   |  
‎06-06-2012 01:58 PM

Was there a solution provided for this question?  I have very similar results...

SRX Services Gateway

Re: Dual Control Links of SRX3600 issue, control link 1 can't work

06.06.12   |  
‎06-06-2012 09:27 PM

Please check this KB21521, could be the issue with CRM Module.

Regards,
Pradeep JNCIE-SEC
SRX Services Gateway

Re: Dual Control Links of SRX3600 issue, control link 1 can't work

[ Edited ]
06.07.12   |  
‎06-07-2012 12:11 PM

not a CRM module problem but in fact an older SFP-T (from an MX-960) ... I replaced it with a new model SFP-T and the link came up.  Still no heartbeat recv'd.  I switched to an SFP-SX with still no result and then I found a missing link between our two switches *facepalm*... All good now.  The give away was that the link lights would not light on the second control port of node 1.  EM1 still showed up...  weird.

 

> show chassis cluster control-plane statistics    
Control link statistics:
    Control link 0:
        Heartbeat packets sent: 80453
        Heartbeat packets received: 80448
        Heartbeat packet errors: 0
    Control link 1:
        Heartbeat packets sent: 80453
        Heartbeat packets received: 2044
        Heartbeat packet errors: 0
Fabric link statistics:
    Probes sent: 80451
    Probes received: 80135
    Probe errors: 0

SRX Services Gateway

Re: Dual Control Links of SRX3600 issue, control link 1 can't work

12.02.13   |  
‎12-02-2013 01:34 AM

RESOLUTION: Reset the CRM card/module on both Firewalls using console access.

ROOT CAUSE: The issue could have caused because of plugging secondary control link when system was not in halt condition. It is recommended to connect control-link ports during halt condition.

 

To bring system to halt condition you ahve to run: 'request system halt' from CLI.

To power on you can press any key on the console.

SRX Services Gateway

Re: Dual Control Links of SRX3600 issue, control link 1 can't work

12.04.13   |  
‎12-04-2013 10:17 AM

Yes its works ...Thanks...

JMD