SRX Services Gateway
SRX Services Gateway

FTTP PPPoE configuration help

‎10-02-2019 04:43 AM

I am familiar with ADSL and VDSL (FTTC) configuration on SRX via an mPIM, but how do I configure a simple PPPoE connection (with static IP) against a standard ge interface?

10 REPLIES 10
SRX Services Gateway

Re: FTTP PPPoE configuration help

[ Edited ]
‎10-02-2019 06:39 AM

This is what I have so far:-

 

    ge-0/0/1 {
        unit 0 {
	     encapsulation ppp-over-ether;
        }
    }	
    pp0 {
        unit 0 {
            ppp-options {
                chap {
                    default-chap-secret "   "; 
                    local-name "   ";
                    passive;
                }
            }
            pppoe-options {                 
                underlying-interface ge-0/0/1.0;
                auto-reconnect 10;
                client;
            }
            family inet {
                address x.x.x.x/32;
		mtu 1492;
            }
        }
    }

 

I haven't included every settings that I have found from other examples; I was wondering whether anyone knows what they mean and their significance when included or not, as the case maybe:

 

1. apply-macro Startup_Connection;
2. no-rfc2486;
3. idle-timeout 0;

 

Also, can someone explain what exactly is meant by this setting please:  auto-reconnect 10;

SRX Services Gateway

Re: FTTP PPPoE configuration help

‎10-03-2019 01:56 AM

Can anyone help please? 

 

@spuluka are you out there? Smiley Happy

 

SRX Services Gateway

Re: FTTP PPPoE configuration help

‎10-03-2019 03:02 AM

It has been over 7 years since I had a static ip pppoe connection so I was hoping someone with more recent experience would chime in.  

 

My recollection was that I did not configure the address but it was provided by the ISP RADIUS server and the configuration was essentially the same as a dynamic pppoe one.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
SRX Services Gateway

Re: FTTP PPPoE configuration help

[ Edited ]
‎10-03-2019 06:54 AM

Hi Steve,

 

Thank you for your reply.

 

Any thoughts on these settings as above?

 

1. apply-macro Startup_Connection;
2. no-rfc2486;
3. idle-timeout 0;

4. auto-reconnect 10;

SRX Services Gateway

Re: FTTP PPPoE configuration help

[ Edited ]
3 weeks ago

 

Hoping someone can help, I'm getting a bit desperate! Here's my FTTP PPPoE (provided by BT in the UK) config. that doesn't work:-

 

    ge-0/0/1 {
        vlan-tagging;
        unit 0 {
            encapsulation ppp-over-ether;
            vlan-id 101;
        }
    }
    pp0 {
        unit 0 {
            ppp-options {
                chap {
                    default-chap-secret "PASSWORD"; ## SECRET-DATA
                    local-name "USERNAME";
                    passive;
                }
            }
            pppoe-options {
                underlying-interface ge-0/0/1.0;
                auto-reconnect 10;
                client;
            }
            family inet {
                mtu 1492;
                negotiate-address;
            }
        }
    }

 

By doesn't work, the PP0.0 connection doesn't come up, no IP is assigned and the ISP has no logon attempts on their RADIUS server.

 

Can any one spot any issues with this setup?

SRX Services Gateway

Re: FTTP PPPoE configuration help

3 weeks ago

Hi,

This is my working configuration.

set interfaces pp0 unit 0 apply-macro "New Connection"
set interfaces pp0 unit 0 ppp-options chap default-chap-secret ""
set interfaces pp0 unit 0 ppp-options chap local-name 21401079
set interfaces pp0 unit 0 ppp-options chap no-rfc2486
set interfaces pp0 unit 0 ppp-options chap passive
set interfaces pp0 unit 0 ppp-options pap local-name 21401079
set interfaces pp0 unit 0 ppp-options pap no-rfc2486
set interfaces pp0 unit 0 ppp-options pap local-password ""
set interfaces pp0 unit 0 ppp-options pap passive
set interfaces pp0 unit 0 pppoe-options underlying-interface fe-0/0/0.0
set interfaces pp0 unit 0 pppoe-options idle-timeout 0
set interfaces pp0 unit 0 pppoe-options auto-reconnect 5
set interfaces pp0 unit 0 pppoe-options client
set interfaces pp0 unit 0 family inet negotiate-address
set interfaces pp0 unit 1 apply-macro MTNL-ADSL
set interfaces pp0 unit 1 ppp-options chap default-chap-secret ""
set interfaces pp0 unit 1 ppp-options chap local-name 23711444
set interfaces pp0 unit 1 ppp-options chap no-rfc2486
set interfaces pp0 unit 1 ppp-options chap passive
set interfaces pp0 unit 1 ppp-options pap local-name 23711444
set interfaces pp0 unit 1 ppp-options pap no-rfc2486
set interfaces pp0 unit 1 ppp-options pap local-password ""
set interfaces pp0 unit 1 ppp-options pap passive
set interfaces pp0 unit 1 pppoe-options underlying-interface fe-0/0/3.0
set interfaces pp0 unit 1 pppoe-options idle-timeout 0
set interfaces pp0 unit 1 pppoe-options auto-reconnect 5
set interfaces pp0 unit 1 pppoe-options client
set interfaces pp0 unit 1 family inet negotiate-address
set interfaces st0 unit 0 point-to-point
set interfaces st0 unit 0 family inet address 172.18.15.3/32
set interfaces vlan unit 0 family inet address 172.18.15.1/27
set routing-options static route 0.0.0.0/0 next-hop pp0.0
set routing-options static route 0.0.0.0/0 qualified-next-hop pp0.1 metric 1

 

What error you are getting, I can help you. This is a resent configuration I had done for one of my sites. Here two PPPoE connection primary and a scondary one.

Thanks,
Jsree

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too .....
SRX Services Gateway

Re: FTTP PPPoE configuration help

[ Edited ]
3 weeks ago

apply macro means the name of the connection,

idle-timeout 0 means, when there is no traffic, the PPPoe interface becomes idle and didn't negotiate with PPPoE server, When traffic from LAN side started to come to the router, the router will initiate a PPPoE request to PPPoE server and connection will establish, but in realtime it didn't work and I had to reboot my bridged modem to get the connection. So I put this command there and it normally doesn't allow PPPoE connection to go idle and show always up.

auto-reconnect means the router will try to reconnect the PPPoE server automatically when there is a disconnection. 

Thanks,
Jsree

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too .....
SRX Services Gateway

Re: FTTP PPPoE configuration help

[ Edited ]
a week ago

This is where I'm upto:-

 

    ge-0/0/1 {
        vlan-tagging;
        unit 0 {
            encapsulation ppp-over-ether;
            vlan-id 101;
        }
    }
    pp0 {
        unit 0 {
            ppp-options {
                chap {
                    default-chap-secret "Password"; ## SECRET-DATA
                    local-name "Username";
                    passive;
                }
            }
            pppoe-options {
                underlying-interface ge-0/0/1.0;
                auto-reconnect 10;
                client;
            }
            family inet {
                mtu 1492;
                negotiate-address;
            }
        }
    }

 

Key differences:

1. I need to send the VLAN tag 101 - does what I have look correct?

2. I don't have idle-timeout 0 - does this matter?

3. I don't think no-rfc2486 is relevant in my case.

4. The connection uses CHAP authentication only.

SRX Services Gateway
Solution
Accepted by topic author EMTSU
a week ago

Re: FTTP PPPoE configuration help

a week ago

Dear EMTSU,

In my case, the VLAN tag is configured in ONT where the fiber terminates. So it is not needed, but if your ISP doesn't support that, then you can do it in your router itself. 

Idle time out is needed and in my experience, it makes sure the connection is always up.

My ISP didn't mention, what authentication they are using, so as per PPoe wizard in SRX there is an option to automatically identify it. I selected that, that's why both authentication there.

When I started to configure the first PPoE connection, I have gone through a number of different problems as you have experienced. What I did was, I configure my laptop as a PPoE client and directly connected to my ISP modem (bridged MODE) and check whether it is working or not, If the PPPoE connection is working with my windows machine then the ISP side is  OK and your router configuration is to blame. Please go through the below link to configure your windows machine. 

https://helpdesk.voyager.co.nz/index.php?/Knowledgebase/Article/View/222/49/ufb---pc-to-ont-isolatio...

 

Please also let me know what error you are experiencing while configuring the above link.

 

 

Thanks,
Jsree

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too .....
SRX Services Gateway

Re: FTTP PPPoE configuration help

a week ago

It turns out that I very nearly had the right config...... The VLAN tag not being needed was the key to success, despite my ISP being insistent that it was! Also in the mix, there was a fault with the service too. Thank you for all of your help and sticking with me.