SRX Services Gateway
SRX Services Gateway

How can I debug a PPPoA connection on a ADSL PIM ( SRX240)

07.06.10   |  
‎07-06-2010 01:00 AM

How can i debug what is happening or not happenign with an ADSL interface in a SRX240..  I need to set up a PPPoA connection.. The physical layer is coming up, but i don' get any connection.. I'm not sure if i have a chap/pap issue.. The DSL line is good, my trusty old SSG20 works fine with it..

 

Any clues greatly apprecaited.

 

4 REPLIES
SRX Services Gateway

Re: How can I debug a PPPoA connection on a ADSL PIM ( SRX240)

07.11.10   |  
‎07-11-2010 08:29 AM

In operational mode: show interfaces at-1/0/0 extensive.

Look for PAP and CHAP status. If they say 'closed' check the user/pass. Does the username has a @yourisp.com in the end and you have missed this....?

Look for showtime seconds and if they go up then the physical link is synchronized, which oftenly means some credentials error or error in encapsulation.

look for errors in general and post them here.

 

SRX Services Gateway

Re: How can I debug a PPPoA connection on a ADSL PIM ( SRX240)

09.16.10   |  
‎09-16-2010 03:09 AM

Try using only PAP or only CHAP, do not configure both.

 

Kindly share your configs also image version.

 

SRX Services Gateway

Re: How can I debug a PPPoA connection on a ADSL PIM ( SRX240)

09.19.10   |  
‎09-19-2010 11:52 PM

Try configuring Passive option under ppp-options.

SRX Services Gateway

Re: How can I debug a PPPoA connection on a ADSL PIM ( SRX240)

09.27.10   |  
‎09-27-2010 05:16 AM

Hi Andrew,

Pls find below sample configuration of ADSL ppoa i did not a customer which worked.

 


interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 192.168.1.0/24;
            }
        }
    }
    at-2/0/0 {
        encapsulation atm-pvc;
        atm-options {
            vpi 0;
        }
        dsl-options {
            operating-mode auto;
        }
        unit 0 {
            encapsulation atm-ppp-llc;
            vci 0.50;
            ppp-options {
                pap {
                    access-profile pppoa-client;
                    local-name adsl_username_here;
                    local-password adsl_password_here
                    passive;
                }
            }
            family inet {
                negotiate-address;
            }
        }
    }
}
routing-options {
    static {
        route 0.0.0.0/0 next-hop at-2/0/0.0;
    }
}


access {
    profile pppoa-client {
        client adsl_username_here pap-password adsl_password_here
    }
}

 

 

Good luck.

Regards,
Haze