SRX Services Gateway
Highlighted
SRX Services Gateway

Issue with PPPOE

‎09-22-2019 04:06 AM

Guys,

 

I have an issue with my SRX320 connectivity. ge-0/0/7 is connected using the fiber coming to my house however, I am not getting any IP. However, if I apply the same configuration to ge-0/0/5 and connected to one of the ports of the provider router, then I see that PP0 is up and I have internet access.

BTW, ge-0/0/1 and ge-0/0/2 are my LAN interfaces on different subnets.

 

I appreciate any help here. Thank you.

Attachments

15 REPLIES 15
Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-22-2019 01:09 PM

Hello there,

 

Generally, ISPs providing fiber link to end users don't use PPoE. They would rather provide you with simple DHCP connection.

 

I believe in your case, the ISP's router is acting as your DSL modem and the fiber link is simply a connection between the site and ISP.

 

It has nothing to do with ge-0/0/7.

 

Since ge-0/0/7 supports transceiver you are physically able to plug in the optical link bypassing the router. It means you are essentially bypassing the DSL modem.

 

If possible, try connecting a ethernet (NOT optical) transceiver on ge-0/0/7 and connect it to the router. I am very hopeful that you will also see PP0 interface is up via ge-0/0/7.

 

Hope this helps!

Thanks! 

 

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-22-2019 03:13 PM

If I use a copper SFP on my ge-0/0/7 and connect it to the provider's router then I can do PPOE and no problem. However, I would like to take the provide router which is a Home Hub 3000 (HH3000) completely out of the loop.

So, I am not sure why PP0 is not getting IP in the case it is directly connected to the ISP directly. 

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-22-2019 04:41 PM

Are you using the optic from the Home hub when making the connection?

 

Looking over the specs on the Home Hub 3000 it seems this is an integration ONT for GPON along with being the consumer firewall.  The good news is it looks like the optic is separate and removal sfp and not integrated.  These are special optics.

 

So you should be able to pull the optic module out of the Home Hub and install this into the SRX.  This will get you the right optical frequencies to join the PON network.  

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-23-2019 04:53 AM

Hi

Thanks for your reply. If I use a Copper SFP on SRX ge-0/0/7 and connect to a LAN port of my Home Hub 3000, then I can do PPPOE and get a public IP on SRX. (Please note that my HH3000 and SRX will both get public IP).

However, as you mentioned, I simply removed the Fiber SFP coming with my Home Hub 3000 and conected it to ge-0/0/7 and that is where I have an issue as I am not getting the IP and PP0 is inet down!

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-26-2019 06:13 AM

Found some more details on Bell Canada in particular that says they also deliver via vlan tag which due to triple play services is probably true on other carriers as well.  so in addition to moving the SFP you need to configure a matching vlan tag for the carrier involved to replace this.

 

https://www.dslreports.com/forum/r31118482-Yes-you-CAN-bypass-the-HomeHub-3000

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-26-2019 05:01 PM

I am with Bell Canada as well and the link you sent me matches my case. Can you please tell me how my configuration should be changed then please? I really appreciate your time and professionalism.

 

Cheers 

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-27-2019 05:24 AM

You will need to set ge-0/0/7 port and assign vlan 35 to unit 0

ge-0/0/7 {
    vlan-tagging;
    unit 0 {                           
        vlan-id 35;                     
        family inet {                   
            dhcp;      
        }                               
    }          

The mtu setting he settled on is the default for Junos so no change should be needed.

 

Your other settings for the security, nat and ppoe should all be the same as you have now.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-27-2019 06:11 AM

Hi

It doesnt allow me to remove encapsulation ppp from unit 0 and replace it by family inet. Please see below... Thx

.

.

}
}
ge-0/0/7 {
vlan-tagging;
unit 0 {
encapsulation ppp-over-ether;
vlan-id 35;
}
}
irb {
unit 0 {
family inet {
address 192.168.1.1/24;
}
}

etoghi@HOME-FIREWALL> configure
Entering configuration mode

[edit]
etoghi@HOME-FIREWALL# delete interfaces ge-0/0/7 unit 0 encapsulation ppp-over-ether

[edit]
etoghi@HOME-FIREWALL# set interfaces ge-0/0/7 unit 0 family inet

[edit]
etoghi@HOME-FIREWALL# commit
[edit interfaces pp0 unit 0 pppoe-options underlying-interface]
'underlying-interface ge-0/0/7.0'
Underlying interface must be configured
error: commit failed: (statements constraint check failed)

[edit]
etoghi@HOME-FIREWALL#

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-27-2019 03:53 PM

Hello Etoghi,

 

Since you are still using PPPoE, you are required to use an underlying interface. 

 

Try this instead :- 

 

ge-0/0/7 {
    vlan-tagging;
     unit 0 {
       encapsulation ppp-over-ether;
       vlan-id 35;
      }
}

pp0 {
  unit 0 {
    ppp-options {
      pap {
        access-profile ppp;
        local-name YYYYY;
        no-rfc2486;
        local-password #######
        passive;
      }   
  }
  pppoe-options {
    underlying-interface ge-0/0/7.0;
    auto-reconnect 30;
    client;
}
    family inet {
    negotiate-address;
}
}
}

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-27-2019 05:58 PM

Thanks for your reply. I actually updated the configuration (please see the attached file) and still pp0 is down!

 

Appreciate your help. 

Attachments

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-28-2019 03:29 AM

Looks like ge-0/0/7 is missing family inet dhcp to request the address.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-28-2019 04:59 AM

I can;t configure family inet 0 dhcp. Please see JUNOS response.... 

 

etoghi@HOME-FIREWALL# commit
[edit interfaces ge-0/0/7 unit 0 encapsulation]
'encapsulation ppp-over-ether'
Can't configure protocol family with encapsulation ppp-over-ether

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-28-2019 07:18 AM

Hello Etoghi,

 

DHCP is not needed on the underlying interface. "negotiate address" under pp0 interface will be negotiating it.

 

If its not coming up with this configuration, I think you need to check the HH300's settings and make sure that the vlans and other settings are correct.

 

From the link shared in previous posts by spuluka, it appears that there needs to be a MRU & MTU setting adjustment too.

 

On Junos, you can refer the following to understand this setting.

https://www.juniper.net/documentation/en_US/junos/topics/concept/pppoe-subscriber-access-mru-mtu-ove...

 

Thanks!

 

 

 

 

SRX Services Gateway

Re: Issue with PPPOE

‎09-29-2019 08:06 AM

I changdthe e MTU to 1492 and MSS to 1448 but still no success. I just noticed that ge-0/0/7 is Up/down. is this normal? Shouldn't I see the interface ge-0/0/7 up/up if SFP is properly connected? Please see the attachement. 

 

 

Attachments

Highlighted
SRX Services Gateway

Re: Issue with PPPOE

‎09-29-2019 08:40 AM

Hello Etoghi,

 

Instead of randomly trying settings, I would suggest to log into your HH router and check the settings.

 

In my opinion, you should see the physical link Up/Up if link is properly connected and SFP is detected.

 

Thanks!

Feedback