SRX Services Gateway
Highlighted
SRX Services Gateway

Juniper SIP Config from Cisco

‎03-07-2012 09:12 AM

Hi,

 

Running Junos 11.1R4.4

 

I have been asked to quickly transfer a cisco config to a juniper srx for basic routing of a SIP connection.  The Cisco device was an old 2600 which had died.

 

All appeared fine until users reported calls dropping and phones being unusable for 20 minutes or so, randomly.  However I cannot establish if this had happened with the cisco in place!  People say they didnt think so etc.

 

The cisco config is below, it is pretty basic, I just want some input as to the configuration you would use on the juniper srx in question,  basically I set up a Virtual router using 2 ports, simple stuff, polocies in and out to match the Cisco config.

 

The part I am most interested in is "ip pim bidir-enable" on the cisco, am I right in saying Junos this bidirectional multicast is enabled by default?

 

interface FastEthernet0/0
 description *** WAN interface - SIP Trunk to ISP(SIP Provider)**                                                                              *
 ip address xx.xx.xx.194 255.255.255.252
 ip access-group 101 in
 ip nat outside
 speed 100
 full-duplex
!
interface Serial0/0
 no ip address
 shutdown
!
interface Ethernet1/0
 description *** LAN Interface connected to NEC system ***
 ip address 192.168.1.150 255.255.255.0
 ip nat inside
 half-duplex
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source static 192.168.1.101 xx.xxx.xxx.194
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xxx.xxx.193
no ip http server
ip pim bidir-enable
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 101 permit ip xx.xxx.xxx.128 0.0.0.15 host xx.xxx.xxx.194
!
line con 0
 login local
line aux 0
line vty 0 4
 login local
!
!
end

 

MMcD [JNCIP-SEC, JNCIS-ENT, CCNA, MCP]
____________________________________________________

[Please Mark My Solution Accepted if it Helped, Kudos are Appreciated Too]