SRX

last person joined: yesterday 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  LACP on SRX 300

    Posted 08-10-2016 23:41

    Does the SRX 300 support LACP?

     

    I seem to be reading conflicting reports online.

     

    When I try to configure LACP on the SRX300 I get the following error:

     

    [edit]
    root@.......# commit check
    [edit interfaces ae1 unit 0 family ethernet-switching vlan]
    'members all'
    Access ports cannot specify vlan "all"
    error: configuration check-out failed

     

     

     

    my config:

     

     

    ## Last commit: 2016-08-09 04:03:12 GMT+10 by root
    version 15.1X49-D50.3;
    system {
    host-name ...........;
    time-zone GMT+10;
    root-authentication {
    encrypted-password ".............."; ## SECRET-DATA
    }
    name-server {
    8.8.8.8;
    }
    name-resolution {
    no-resolve-on-input;
    }
    services {
    ......
    }
    syslog {
    .....
    }
    max-configurations-on-flash 5;
    max-configuration-rollbacks 5;
    archival {
    ......
    }
    license {
    .....
    }
    ntp {
    .....
    }
    }
    security {
    policies {
    from-zone DataNetwork to-zone DataNetwork {
    policy data2data {
    description "Allows traffic within Data zone";
    match {
    source-address any;
    destination-address any;
    application any;
    }
    then {
    permit;
    }
    }
    }
    from-zone DataNetwork to-zone VoiceNetwork {
    policy data2voice {
    description "Allows traffic between Data and Voice zones";
    match {
    source-address any;
    destination-address any;
    application any;
    }
    then {
    permit;
    }
    }
    }
    from-zone VoiceNetwork to-zone DataNetwork {
    policy voice2data {
    description "Allows traffic between Voice and Data zones";
    match {
    source-address any;
    destination-address any;
    application any;
    }
    then {
    permit;
    }
    }
    }
    }
    zones {
    security-zone DataNetwork {
    description "Data vlan";
    interfaces {
    irb.10 {
    host-inbound-traffic {
    system-services {
    all;
    }
    protocols {
    all;
    }
    }
    }
    }
    }
    security-zone VoiceNetwork {
    description "Voice vlan";
    interfaces {
    irb.20 {
    host-inbound-traffic {
    system-services {
    all;
    }
    }
    }
    }
    }
    }
    }
    chassis {
    aggregated-devices {
    ethernet {
    device-count 2;
    }
    }
    }
    interfaces {
    ge-0/0/0 {
    ether-options {
    802.3ad ae1;
    }
    }
    ge-0/0/1 {
    ether-options {
    802.3ad ae1;
    }
    }
    ge-0/0/2 {
    description "Data Port";
    unit 0 {
    family ethernet-switching {
    interface-mode access;
    vlan {
    members default;
    }
    }
    }
    }
    ge-0/0/3 {
    description "Voice Port";
    unit 0 {
    family ethernet-switching {
    interface-mode access;
    vlan {
    members Voice-VLAN;
    }
    }
    }
    }
    ge-0/0/4 {
    description "Data Port";
    unit 0 {
    family ethernet-switching {
    interface-mode access;
    vlan {
    members default;
    }
    }
    }
    }
    ge-0/0/5 {
    description "Trunk port to ground fl D-Link switch";
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members all;
    }
    }
    }
    }
    irb {
    unit 10 {
    description Data;
    family inet {
    address 10.0.0.245/24;
    }
    }
    unit 20 {
    description Voice;
    family inet {
    address 10.2.2.1/24;
    }
    }
    }
    ae1 {
    aggregated-ether-options {
    lacp {
    active;
    }
    }
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members all;
    }
    }
    }
    }
    }
    routing-options {
    static {
    route 0.0.0.0/0 next-hop 10.0.0.254;
    }
    }
    protocols {
    l2-learning {
    global-mode switching;
    }
    }
    vlans {
    Voice-VLAN {
    description "Voice Network";
    vlan-id 20;
    l3-interface irb.20;
    }
    default {
    description "Data Network";
    vlan-id 10;
    l3-interface irb.10;
    }
    }



  • 2.  RE: LACP on SRX 300
    Best Answer

    Posted 08-11-2016 00:06

    Hello,

     

     

    I would like to inform you that LACP is upport starting from version 15.1X49-D50.3 in switchin mode on SRX 300 and when I checked your configruation it is in switching mode and hence it should be supported.

     

    The error that you are getting on commit is due to a configraution issue on interface ae1 unit 0. Please use the below commands and then try to commit if it allows you to commit the configraution.

     

    # delete interfaces ae1 unit 0 family ethernet-switching port-mode trunk

    # set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk

     

    Hope this helps. 🙂

     

    Thanks,
    Pulkit Bhandari
    Please mark my response as Solution Accepted if it Helps, Kudos are Appreciated too. 🙂

     



  • 3.  RE: LACP on SRX 300

    Posted 08-14-2016 16:20

    Yes, in the SRX 300 juniper needs you to use interface-mode not port mode as we were all using before.

     

    ae1 {
    aggregated-ether-options {
    lacp {
    active;
    }
    }
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members all;
    }
    }
    }
    }



  • 4.  RE: LACP on SRX 300

    Posted 04-23-2017 13:01

    FWIW, I have a VLAN tagged L3 interface on a LAG working on a SRX300 (remote end is a Cisco 3064):

     

    me@somebox> show configuration interfaces ae10
    vlan-tagging;
    aggregated-ether-options {
    lacp {
    active;
    periodic fast;
    }
    }
    unit 10 {
    vlan-id 10;
    family inet {
    address 10.10.0.2/24;
    }
    }
    unit 20 {
    vlan-id 20;
    family inet {
    address 10.20.0.2/24;
    }
    }

     

    me@somebox> show lacp interfaces
    Aggregated interface: ae10
    LACP state: Role Exp Def Dist Col Syn Aggr Timeout Activity
    ge-0/0/2 Actor No No Yes Yes Yes Yes Fast Active
    ge-0/0/2 Partner No No Yes Yes Yes Yes Fast Active
    ge-0/0/1 Actor No No Yes Yes Yes Yes Fast Active
    ge-0/0/1 Partner No No Yes Yes Yes Yes Fast Active
    LACP protocol: Receive State Transmit State Mux State
    ge-0/0/2 Current Fast periodic Collecting distributing
    ge-0/0/1 Current Fast periodic Collecting distributing



  • 5.  RE: LACP on SRX 300

    Posted 08-11-2016 00:07

    Hi,

     

    LACP is supported on SRX300 starting from D50 release.

     

    Regards,

    Sahil Sharma

    ---------------------------------------------------

    Please mark my solution as accepted if it helped, Kudos are appreciated as well.