SRX Services Gateway
SRX Services Gateway

Out-of-band management fxp0 doesn't work on a vSRX

‎01-29-2019 02:25 AM

Hello,

 

I am working with a vSRX (version 18.3R1.9) and I can not configure the interface fxp0.

The interface is on the first network adapter. The " show interface fxp0 " command gives  the same mac address as on the configuration of the virtual machine

The network adapter is on the 201 tagged VLAN.

On the same ESX, if I put a virtual machine on the same network (vlan 201) it works properly but with fxp0.0 I can’t reach the gateway

Could the problem be that I have not yet added the serial number of the vSRX ?

 

Any ideas ????

 

Thanks

Regards

3 REPLIES 3
SRX Services Gateway
Solution
Accepted by topic author Gilles B
‎01-29-2019 11:54 PM

Re: Out-of-band management fxp0 doesn't work on a vSRX

‎01-29-2019 06:03 AM

Have you enabled promiscous mode on the vSwitch?

 

This is mentioned in the deployment guide for VMware on page 26 (https://www.juniper.net/documentation/en_US/vsrx/information-products/pathway-pages/security-vsrx-vm...)

 

NOTE: For the management interface, fxp0, VMware uses the VMXNET3 vNIC and requires promiscuous mode on the vSwitch.

 


--
Best regards,

Jonas Hauge Klingenberg
Juniper Ambassador & Technology Architect, SEC DATACOM A/S (Denmark)
SRX Services Gateway

Re: Out-of-band management fxp0 doesn't work on a vSRX

‎01-29-2019 06:11 AM

fxp0 interface does not support tagged vlans. Ensure that fxp0 is receiving untagged packets

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790)
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
SRX Services Gateway

Re: Out-of-band management fxp0 doesn't work on a vSRX

‎01-29-2019 11:54 PM

Thanks Nellikka et jonashauge for your help

Actually I had missed the promiscuous mode on the vSwitch.

Now it works fine the fxp0 interface

 

Best regards

 

Gilles