SRX Services Gateway
SRX Services Gateway

Panel LED Frontal blinking RED - Online MX

‎09-05-2019 04:28 AM

Dears, good morning!

I would like your help to answer a question about the ONLINE front panel LED on our mx204.

This equipment is already in production, and the online led is blinking red ... analyzing the mx chassis, says this status would be that the router is starting linux ..
There are no alarms on the chassis, and no other evidence of failure. Would anyone know why the led is blinking red?


Regards,

Robert A.

15 REPLIES 15
SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 04:55 AM

There are a couple of LEDs on the front panel, can you please specify the one blinking red right now?

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 05:04 AM

Hi Robert,

 

As the doc says, ideally the ONLINE LED blinks while the router starts linux. Only looking into similar issues, read issues where there were chassisd crashes observed post which the ONLINE LED blinks red and memory leak is found too.

 

Possible PR: https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1348753

 

Request you to check for any core dumps on the device and if any, create a case with JTAC to help decode the core dump. Can also check for any memory leak logs.

 

Regards,

Pradeep Kumar

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 07:48 AM

Robert,

 

Juniper documentation is clear that the Router is starting Linux if the Online LED is blinking red. However as you stated your router is in production and everything is working fine which points to a software issue or something was not synchronized properly.

 

  • Whats the status of the other LEDs (ALM and OK/Fail)?
  • Have you try rebooting the router?
  • Recommended Junos version for MX204 is 17.4R2, are you running this version?

 

Ref: https://www.juniper.net/documentation/en_US/release-independent/junos/topics/topic-map/mx204-host-su...

 

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 07:51 AM

Please also gather:

 

> show chassis craft-interface

> show chassis led

 

 

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 10:46 AM

Ipaniagua,

Thanks for reply,

The LEDs ALM (off), OK/Fail (On steadily) and LED Online RED blinking. We use the MX204, version 17.4R1-S2.2
We don't rebooted the router yet. We will make a window to reboot.

We will post feedback as soon as we reboot.


Best Regards,

Robert Alexandrino.

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 10:48 AM

Sorry, I did not inform the model and version of the equipment. We use the mx204 and version 17.4R1-S2.2
This command does not exist in the cli.

Thanks for reply,


Regards,

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 11:30 AM

Thanks for the information. Do you see any coredump files or alarms?

 

> show system core-dumps

> show chassis alarms

> show system alarms

 

 

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-05-2019 05:42 PM

Hi Robert

17.4R1-S2 is not having the fix for PR1348753/1353111. Please share the "show system core-dumps" and the first screen of "show system process extensive". 

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

[ Edited ]
‎09-06-2019 08:24 AM

Thanks for the return Apaniagua,
I see some core dumps but they are old problems. Follows the requested logs.

> show system core-dumps
/var/crash/*core*: No such file or directory
-rw-rw---- 1 root wheel 196968857 Jul 29 2018 /var/tmp/chassisd.core-tarball.0.tgz
-rw-rw---- 1 root wheel 200680945 Oct 24 2018 /var/tmp/chassisd.core-tarball.1.tgz
-rw-rw---- 1 root wheel 199465247 Jan 19 2019 /var/tmp/chassisd.core-tarball.2.tgz
-rw-rw---- 1 root wheel 201427779 Apr 16 18:02 /var/tmp/chassisd.core-tarball.3.tgz
-rw-rw---- 1 root wheel 202488398 Jul 12 17:26 /var/tmp/chassisd.core-tarball.4.tgz
/var/tmp/pics/*core*: No such file or directory
/var/crash/kernel.*: No such file or directory
/var/jails/rest-api/tmp/*core*: No such file or directory
/tftpboot/corefiles/*core*: No such file or directory
total files: 5

> show chassis alarms
No alarms currently active

> show system alarms
No alarms currently active

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-06-2019 08:27 AM

Thanks for the return shijot,
Could this failure be any software / release failure I'm producing?
Follows the requested commands.

> show system core-dumps
/var/crash/*core*: No such file or directory
-rw-rw---- 1 root wheel 196968857 Jul 29 2018 /var/tmp/chassisd.core-tarball.0.tgz
-rw-rw---- 1 root wheel 200680945 Oct 24 2018 /var/tmp/chassisd.core-tarball.1.tgz
-rw-rw---- 1 root wheel 199465247 Jan 19 2019 /var/tmp/chassisd.core-tarball.2.tgz
-rw-rw---- 1 root wheel 201427779 Apr 16 18:02 /var/tmp/chassisd.core-tarball.3.tgz
-rw-rw---- 1 root wheel 202488398 Jul 12 17:26 /var/tmp/chassisd.core-tarball.4.tgz
/var/tmp/pics/*core*: No such file or directory
/var/crash/kernel.*: No such file or directory
/var/jails/rest-api/tmp/*core*: No such file or directory
/tftpboot/corefiles/*core*: No such file or directory
total files: 5

> show system processes extensive
last pid: 79860; load averages: 0.08, 0.20, 0.22 up 490+22:50:25 12:26:39
292 processes: 6 running, 240 sleeping, 46 waiting
Mem: 316M Active, 8185M Inact, 2071M Wired, 1372M Buf, 5337M Free
Swap: 3072M Total, 3072M Free
PID USERNAME PRI NICE SIZE RES STATE C TIME WCPU COMMAND
11 root 155 ki31 0K 80K RUN 1 ??? 100.00% idle{idle: cpu1}
11 root 155 ki31 0K 80K CPU2 2 ??? 100.00% idle{idle: cpu2}
11 root 155 ki31 0K 80K RUN 3 ??? 100.00% idle{idle: cpu3}
11 root 155 ki31 0K 80K CPU4 4 ??? 100.00% idle{idle: cpu4}
11 root 155 ki31 0K 80K CPU0 0 ??? 95.90% idle{idle: cpu0}
5369 root 24 0 4774M 3867M kqread 4 565.0H 7.08% rpd{rpd}
5369 root 20 0 4774M 3867M kqread 2 125.5H 0.00% rpd{TraceThread}
5211 root 20 0 790M 74868K select 4 82.0H 0.00% mib2d
12 root -72 - 0K 736K WAIT 4 65.6H 0.00% intr{swi1: netisr 0}
5405 root 20 0 732M 23188K select 4 36.4H 0.00% snmpd
12 root -92 - 0K 736K WAIT 3 24.8H 0.00% intr{irq272: virtio_p}
5230 root 20 0 722M 12392K select 1 22.3H 0.00% ppmd
5407 root 20 0 823M 71188K select 3 21.6H 0.00% pfed
12 root -60 - 0K 736K WAIT 0 19.2H 0.00% intr{swi4: clock (0)}
5369 root 20 0 4774M 3867M kqread 1 18.0H 0.00% rpd{bgpio-0-th}
5566 root -16 - 0K 16K select 0 17.3H 0.00% ppt_11_80000065
9 root -16 - 0K 16K client 0 581:55 0.00% ifstate notify
5382 root 20 0 757M 20136K kqread 4 532:31 0.00% l2cpd
71522 root 35 15 721M 12328K select 4 463:08 0.00% sampled
5404 daemon 20 0 18624K 2324K select 4 455:33 0.00% mosquitto-nossl
5403 daemon 20 0 18624K 2324K select 4 454:44 0.00% mosquitto-nossl
5196 daemon 20 0 18624K 2084K select 2 431:13 0.00% mosquitto-nossl
5369 root 20 0 4774M 3867M kqread 2 393:19 0.00% rpd{krtio-th}
5154 root 20 0 720M 9520K select 1 392:20 0.00% eventd
5255 root 20 0 721M 11328K select 3 359:07 0.00% clksyncd
23 root -16 - 0K 32K psleep 0 352:07 0.00% pagedaemon{pagedaemon}
5299 root 20 0 723M 11256K select 4 341:52 0.00% license-check
12 root -60 - 0K 736K WAIT 2 265:00 0.00% intr{swi4: +}
12 root -60 - 0K 736K WAIT 2 264:52 0.00% intr{swi4: +}

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-06-2019 09:47 AM

Robert,

 

The mentioned PR states that chassisd coredumps will be seen so I suspect it could be our case? Since when did you notice the problem with the LED?

 

Lets try rebooting and see if it gets fixed. Then monitor the LED status and if the problem reoccurs, check if there is a new coredump file.

 

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-06-2019 10:04 AM

Right. We noticed the LED a few days ago and have been doing tshoot to understand why.
We are scheduling the box reset to start next week. Coming soon with more news.

 

Thank you so much for your support.

SRX Services Gateway
Solution
Accepted by topic author robertalexandrino
‎09-15-2019 08:43 AM

Re: Panel LED Frontal blinking RED - Online MX

‎09-06-2019 03:07 PM

Hi Robert

A reboot should most likely fix the issue. We can then upgrade to a build with the fix of both PRs to prevent that in the future.

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-15-2019 08:44 AM

Dear, Good afternoon!
We solved the problem by restarting the router. Thanks for the support of all, they helped me a lot in tshoot. We are now programming a major upgrade from junos on these routers.


Regards,

Robert Alexandrino.

SRX Services Gateway

Re: Panel LED Frontal blinking RED - Online MX

‎09-15-2019 08:46 AM

Thanks for the support!!! It all worked out after the reboot.