SRX Services Gateway
Highlighted
SRX Services Gateway

SRX-240 fxp0-IP-flapping

[ Edited ]
‎03-06-2014 04:31 AM


Hello,

at first, sry for my bad english!

I have a problem with my SRX-configs. First I will give some configuration information:


I have two SRX 240 in Clusterwork. The following settings are configured:

version 12.1X46-D10.2;
groups {
    Node0 {
        system {
            host-name node0;
        }
        interfaces {
            fxp0 {
                unit 0 {
                    family inet {
                        address 192.168.6.9/24;
                    }
                }
            }
        }
    }
    Node1 {
        system {
            host-name node1;
        }
        interfaces {
            fxp0 {
                unit 0 {
                    family inet {
                        address 192.168.6.10/24;
                    }
                }
            }
        }
    }
}
apply-groups [ Node0 Node1 ];
system{
[...]
    services {
        ssh;
        web-management {
            https {
                system-generated-certificate;
                interface [ reth0.0 fxp0.0 ];
            }
        }
    }
[...]
}
chassis {
    cluster {
        control-link-recovery;
        reth-count 1;
        redundancy-group 0 {
            node 0 priority 100;
            node 1 priority 1;
        }
    }
}
interfaces {
[...]
    fab0 {
        fabric-options {
            member-interfaces {
                ge-0/0/2;
            }
        }
    }
    fab1 {
        fabric-options {
            member-interfaces {
                ge-5/0/2;
            }
        }
    }
[...]
}

 



With show chassis cluster status I see that the cluster seems to work in the basic operation:
Cluster Status.PNG

And the follow pic show the ssh-access of both nodes:

i.O..PNG


And now, i want to explain my problem:
There is a kind of "IP-flapping". During the ssh-session to a node, i suddently become a ssh-fatal error - the connection is closed.

If i want to reconnect to this node, i'm logged to the another node with the same IP-address! This happens of both nodes every few minutes. It may also be, both IP-Adresses 192.168.6.9 & 192.168.6.10 logged to node0. Another time, both IP-Addresse logged to node1. Shown on the pics below:

 

only-node0.PNG
only-node1.PNG

vertauscht.PNG

 

What could cause the problem?

I am grateful for any response!

4 REPLIES 4
Highlighted
SRX Services Gateway
Solution
Accepted by topic author Johannes219
‎08-26-2015 01:27 AM

Re: SRX-240 fxp0-IP-flapping

‎03-06-2014 05:00 AM

Hi,

 

Your apply-groups look incorrect.

 

Try the following:

 

user@srx#delete apply-groups
user@srx#set apply-groups “${node}”
user@srx#commit

 

MMcD [JNCIP-SEC, JNCIS-ENT, CCNA, MCP]
____________________________________________________

[Please Mark My Solution Accepted if it Helped, Kudos are Appreciated Too]
Highlighted
SRX Services Gateway

Re: SRX-240 fxp0-IP-flapping

‎03-06-2014 06:09 AM

Hi MMcD!

 

Thank you! This was the solution i think. The last 30 mins. i haven't  registered any ip-flapping.

 

One little question i have (to understanding):

 

It's normal when i connect over J-Web to 192.168.6.9 & 192.168.6.10, only the address of the primary node is approved?

192.168.6.10 over J-web failed.

 

Highlighted
SRX Services Gateway

Re: SRX-240 fxp0-IP-flapping

[ Edited ]
‎03-06-2014 06:27 AM

Hi Johannes,

 

This is correct, only the primary node can be managed using the revenue port (fxp).  Failover and then the secondary should be manageable.

 

You can login from the primary to the seconday via ssh with the following comand:

 

user@srx>request routing-engine login node1

 

MMcD [JNCIP-SEC, JNCIS-ENT, CCNA, MCP]
____________________________________________________

[Please Mark My Solution Accepted if it Helped, Kudos are Appreciated Too]
Highlighted
SRX Services Gateway

Re: SRX-240 fxp0-IP-flapping

‎03-06-2014 06:58 AM

Thank you for answer.  The command could be useful for me.

 
I have no more questions. I think the thread may be closed now.  🙂
Feedback