SRX Services Gateway
SRX Services Gateway

SRX 345 - interface monitors not working

‎11-19-2019 06:57 AM

Hi,

Whenever we deploy SRXs we use interface monitors with redundancy groups and reths... this is the first time I've deployed on a SRX345 and also the first time I've had a major problem.

 

If I pull a cable (simulating an event) the interface monitor will identify there was an event and depending on the weight, move to the other node for that RG or simply subtract the weight from 255.

 

The issue is when I plug back in the cable, the LED status light is green but the interface shows down in the CLI , if I pull and put back in both interfaces in a RG... neither come back.

 

Can't replicate it on other SRXs and have never had this issue before. Software - we upgraded to the recommended JTAC version, which has a lot more layer2 default config and functionallity than older junos's so I reverted back to 15.1 which works on SRX 1500 and 4100, 4200's without any issue

 

show chassis cluster interfaces    
Control link status: Up

Control interfaces: 
    Index   Interface   Monitored-Status   Internal-SA   Security
    0       fxp1        Up                 Disabled      Disabled  

Fabric link status: Up

Fabric interfaces: 
    Name    Child-interface    Status                    Security
                               (Physical/Monitored)
    fab0    ge-0/0/14          Up   / Up                 Disabled   
    fab0   
    fab1    ge-5/0/14          Up   / Up                 Disabled   
    fab1   

Redundant-ethernet Information:     
    Name         Status      Redundancy-group
    reth0        Down        Not configured   
    reth1        Up          1                
    reth2        Down        2                
    reth3        Down        Not configured   
   
Redundant-pseudo-interface Information: 
    Name         Status      Redundancy-group
    lo0          Up          0                

Interface Monitoring:
    Interface         Weight    Status                    Redundancy-group
                                (Physical/Monitored)
    ge-5/0/12         128       Up  /  Up                 1   
    ge-5/0/11         128       Down  /  Down             1   
    ge-0/0/12         128       Up /  Up                  1   
    ge-0/0/11         128       Up  /  Up                 1   
    ge-5/0/8          255       Down  /  Down             2   
    ge-0/0/8          255       Down  /  Down             2  

 

 

set chassis cluster reth-count 4
set chassis cluster redundancy-group 0 node 0 priority 200
set chassis cluster redundancy-group 0 node 1 priority 100
set chassis cluster redundancy-group 1 node 0 priority 200
set chassis cluster redundancy-group 1 node 1 priority 100
set chassis cluster redundancy-group 1 preempt
set chassis cluster redundancy-group 1 interface-monitor ge-0/0/11 weight 128
set chassis cluster redundancy-group 1 interface-monitor ge-0/0/12 weight 128
set chassis cluster redundancy-group 1 interface-monitor ge-5/0/11 weight 128
set chassis cluster redundancy-group 1 interface-monitor ge-5/0/12 weight 128
set chassis cluster redundancy-group 2 node 0 priority 200
set chassis cluster redundancy-group 2 node 1 priority 100
set chassis cluster redundancy-group 2 interface-monitor ge-0/0/8 weight 255
set chassis cluster redundancy-group 2 interface-monitor ge-5/0/8 weight 255

 

 

Anyone come across this ?

1 REPLY 1
Highlighted
SRX Services Gateway

Re: SRX 345 - interface monitors not working

[ Edited ]
‎11-20-2019 02:25 PM

Hi,

 

Did you experience the same problem while on the recommended code 18.2R3?

 

How are you recovering the interfaces when they dont come up?

 

It definately sounds like a bug, I will suggest opening a ticket with JTAC if possible.

 

Please mark my answer as the Solution if it applies.
Feedback