SRX Services Gateway
SRX Services Gateway

SRX 650 booting to backup image

‎06-27-2013 09:14 AM

I have a SRX 650 and it is booting up to it's backup image. 

When I run the command "request system snapshot partition slice alternate" I recieve the following output.


root@Kona> request system snapshot partition slice alternate
Formatting alternate root (/dev/ad0s1a)...
Copying '/dev/ad0s2a' to '/dev/ad0s1a' .. (this may take a few minutes)
error: /dev/ad0s2a copy failed



When I run the command "show system snapshot media internal slice 1" to look at the snapshots it does not show the primary partition.


root@Kona> show system snapshot media internal slice 1
Information for snapshot on internal (/dev/ad0s2a) (backup)
Creation date: Jun 1 00:14:19 2012
JUNOS version on snapshot:
junos : 11.4R3.7-domestic



Also when I run the command ls /dev this is what I see.


root@Kona% ls /dev
ad0 ata cuau0 md0 smb
ad0s1 bo0s2a cuau0.init md1 stderr
ad0s2 bo0s2c cuau0.lock md2 stdin
ad0s2a bo0s3c devctl md3 stdout
ad0s2c bo0s3e devstat mdctl ttyu0
ad0s3 bo0s3f fd mem ttyu0.init
ad0s3c bo0s4a fido nfs4 ttyu0.lock
ad0s3e bo0s4c fileassoc nfslock urandom
ad0s3f bo0s4e gblmem null usb
ad0s4 bpf0 geom.ctl octpkt usb0
ad0s4a bpf1 gpio pci veriexec
ad0s4c cfi0 klog random xpt0
ad0s4e console kmem root zero
altroot ctty log rtfifo


Which is telling me that I do not have a "ad0s1a" partition. I am guessing that I will need to recreate this partition before I will be able to get a successful snapshot to work.


Anyone know how I can get the "ad0s1a" partition back without having to do a complete reinstall of the OS?