SRX Services Gateway
SRX Services Gateway

SRX, DHCP and rc.custom

‎07-26-2015 09:49 AM

I have a SRX210.  I am having issues getting a DHCP address from my provider.  From what I have read that is due to the TTL=1 in the dhcp request.


Work around states to add the line "sysctl -w net.inet.ip.mcast_ttl=64" to /cf/etc/rc.custom.


I created a rc.cutom file but noticed that the file is gone after a reload of the device.  There is still a sym link in /etc/rc.custom pointing to /cf/etc/rc.custom, but the file is not there.


Any ideas?  I am running 12.1X46-D35.1


root@% ls -l /etc/rc.custom
lrw-r--r-- 1 root wheel 17 May 14 19:05 /etc/rc.custom -> /cf/etc/rc.custom


root@% ls -l /cf/etc/rc.custom
ls: /cf/etc/rc.custom: No such file or directory

SRX Services Gateway

Re: SRX, DHCP and rc.custom

‎07-26-2015 10:21 PM

Hello ,


As a temporarl work around , we can copy the file from   /etc/rc.custom to  /cf/etc/rc.custom .


No seen this issue of getting custom files to erase after reload . But We have seen configuration files getting re-set after reloads .


Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too .....
SRX Services Gateway

Re: SRX, DHCP and rc.custom

‎10-01-2019 12:54 AM

Anyone solved the problem? I can change ttl value by 

root@srx% sysctl -w net.inet.ip.mcast_ttl=2

command, but when I try to save it in rc.custom 

root@SRX% cat /etc/rc.custom
sysctl -w net.inet.ip.mcast_ttl=2

root@SRX% chmod 755 /cf/etc/rc.custom

After reboot, router delete the file. It doesn't get address from ISP DHCP server and internet connection doesn't work. 

Some ideas?

SRX Services Gateway

Re: SRX, DHCP and rc.custom

‎03-10-2020 11:00 AM

Same issue.  Won't survive reboot.  I can get IP from ISP if I run command "sysctl -w net.inet.ip.mcast_ttl=2" and restart DHCP on interface.  But have not been able to get rc.custom to survive reboot.  I have opened a ticket with support.  If I get a resolution I will try to post on all of the related posts.