SRX Services Gateway
SRX Services Gateway

SRX DHCP client sends discover request with TTL=1

‎07-16-2011 11:08 AM

I've searched and searched, but I am unable to find a solution.  I don't know why this works sometimes and not others, but I'm using an SRX 210 and Comcast is my ISP.  I cannot pull a DHCP address right now, and I suspect it is either because comcast cannot deal with a TTL of 1, or my motorola surfboard modem drops it.  i'm leaning toward the former.

 

I can connect with my PC direct to the modem and get an IP from comcast.  my PC sends a TTL of 128.  when i plug in the fw, it uses a TTL of 1 and will not pull an address.  when I sniff, it looks like i get a response, but due to how cable works, they are responses to other customers.  So, i never get a DHCP offer, and because the only people in their tech support you can talk to are the level 1's that just tell you to reboot your modem/router/pc, they are no help.

 

So, my question becomes, how the heck do I configure the SRX to use a higher TTL value when acting as a DHCP client?  i'm not doing relay or anything of the sort.

 

If this is not currently possible, how do I get it added as an option under the interface dhcp config?

1 REPLY 1
SRX Services Gateway

Re: SRX DHCP client sends discover request with TTL=1

‎07-18-2011 06:45 AM

Hi

 

I'm not sure if TTL=1 for DHCP packet can be considered an SRX problem, but here's the

doc that briefly describes how to open an enhancement request (sec. 3.7)

 

http://www.juniper.net/us/en/local/pdf/resource-guides/7100059-en.pdf

 

Best Regards,
PK

Juniper Ambassador, Juniper Networks Certified Instructor,
JNCIE-SEC #98, JNCIE-ENT #393, JNCIE-SP #2253
Twitter: @JuniperTrain
GitHub: https://github.com/pklimai
[Juniper Authorized Education & Support in Russia]