SRX Services Gateway
Highlighted
SRX Services Gateway

SRX DHCP server not working

Friday

 Hello Experts,

 

Any reason following SRX DHCP server is not working

 

DHCP server

=========

set version 15.1X49-D120.3
set system root-authentication encrypted-password "$5$EfL9/iek$nDUSZ.5okbInm8fX8gVqsMkhPFaSBHCLudZC6tMjXr8"
set system services ssh root-login allow
set system services dhcp-local-server group lan interface ge-0/0/0.0
set system services web-management http
set security policies default-policy permit-all
set security zones security-zone trust host-inbound-traffic system-services all
set security zones security-zone trust interfaces ge-0/0/0.0 host-inbound-traffic system-services all
set interfaces ge-0/0/0 unit 0 family inet address 172.17.1.1/24
set interfaces fxp0 unit 0 family inet address 10.213.21.181/19
set routing-options static route 0.0.0.0/0 next-hop 10.213.31.254
set access address-assignment pool lan family inet network 172.17.1.0/24
set access address-assignment pool lan family inet range inside low 172.17.1.100
set access address-assignment pool lan family inet range inside high 172.17.1.110
set access address-assignment pool lan family inet dhcp-attributes name-server 8.8.8.8
set access address-assignment pool lan family inet dhcp-attributes router 172.17.1.1

 

DHCP Client

==========

set version "15.1-2018-05-17.0_JUNOS_151_X49_D140 [ssd-builder]"
set system root-authentication encrypted-password "$5$/FW5mtu0$9ME2sT/GZk4MUrBxVO8l1N4qAuNQ5MWrJmLrq04Spo0"
set system services ssh root-login allow
set security policies default-policy permit-all
set security zones security-zone trust interfaces ge-0/0/0.0 host-inbound-traffic system-services dhcp
set security zones security-zone trust interfaces ge-0/0/0.0 host-inbound-traffic system-services all
set interfaces ge-0/0/0 unit 0 family inet dhcp-client
set interfaces fxp0 unit 0 family inet address 10.213.21.217/19

Shirish
2 REPLIES
SRX Services Gateway

Re: SRX DHCP server not working

Friday

Hi Shirish,

 

Please refer below KB's for the configurtion referance for DHCP.

Server:

https://kb.juniper.net/InfoCenter/index?page=content&id=KB15754

 

Client:

https://kb.juniper.net/InfoCenter/index?page=content&id=KB15753&actp=METADATA

 

Also check the command outputs mentioned in KB for server config. If you still face the issue please provide error log which you are observing

 

*******

If my reply is helpful please mark as soultion accepted. Kudos is appriteated too 

SRX Services Gateway

Re: SRX DHCP server not working

Saturday

check the status of the srx dhcp

show system services dhcp client

show system services dhcp binding

 

Enable trace options and see what logs we get with the dhcp requests

set system services dhcp traceoptions flag all

set system services dhcp traceoptoins file dhcplog

 

After the dhcp requests are made

show log dhcplog

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home