SRX Services Gateway
SRX Services Gateway

SRX PIM DENSE MODE | RECEIVER AND SOURCE

09.10.17   |  
‎09-10-2017 10:02 AM

Hi everyone,

 

Please consider the following set up:

 

We are using PIM DENSE MODE

 

S-----f1 SRX1 f2--------f2-SRX2 -f1-----R

 

S:  Multicast source sending stream at 239.1.1.1

R; Receiver listening on 239.1.1.1

SRX1: FHR ( connected to S)

SRX2: LHR ( connecetd to R)

 

 

FHR i.e SRX connected to S:

 

In Cisco, I have to enable PIM under F1 on FHR , we can not use Ip pim passive, it has to be pim mode dense or all received multicast stream from S is ignored. ( again only consider these statements in the context of  PIM DENSE only)

 

How is it on SRX1? Do we have to enable PIM dense on interface facing the SOURCE?

 

LHR i.e SRX2 connected to RECEIVER:

 

In Cisco,   Ip pim dense also enable IGMP on the interface facing RECEIVER, that also means LHR is now sending PIM hello and IGMP query as well, if we do not have any PIM router on the interface just receiver which is the case here, we can use IP PIM PASSIVE which will stop PIM hello so basiclaly we have now IGMP between LHR and RECEIVER , router can still create ( *,G) entry in the tabe. ( ( again only consider these statements in the context of  PIM DENSE only)

 

ON  SRX2  Juniper, do we have to enable PIM on the Interface connected to RECEIVER or we can simply use IGMP  between LHR?  Will SRX still able to create ( *,G) state if we have ony IGMP running between SRX and Receiver as we see in Cisco?

 

Thanks and have a nice weekend!!

 

 

 

 

 

 

1 REPLY
Highlighted
SRX Services Gateway

Re: SRX PIM DENSE MODE | RECEIVER AND SOURCE

[ Edited ]
09.10.17   |  
‎09-10-2017 11:23 PM

I didn't check it myself but

 

"PIM Dense Mode: Minimum Configuration
To configure PIM in dense mode, you must include all the required interfaces under the [edit
protocols pim] hierarchy, and additionally, enable them for dense mode because, by default,
the mode is sparse. The default version of PIM in the Junos OS is version 2.
As mentioned before, make sure you enable PIM on interfaces that have been enabled for IGMP,
because otherwise IGMP does not work properly."

 

Regards, Wojtek