SRX Services Gateway
Highlighted
SRX Services Gateway

SRX100 doesn't boot, junos setup fails

‎07-01-2015 06:06 AM

Hello, 

I've a big Problem with my SRX100H2 Device. I tried to get a Snapshot on a USB Flash Drive. I tried it with the Webinterface (Maintain -> Snapshot). But I got a Error like: Could not access usb device. And it kicks me back to login screen and I got many PHP Line Errors. I tried a reboot, since then the device doesn't boot and I get the errors:

 

can't load '/kernel'

can't load '/kernel.old'

 

I tried to reinstall the JunOS Software over USB. I placed the tgz file in the root directory and tried to install the Software with the command install file:///junos-srxsme-12.1X47-D20.7-domestic.tgz  

But everytime I get the error: cannot open package (error 22).

 

I rebooted with USB drive plugged in an saw that my device doesn't find a mass storage
scanning bus for devices... 2 USB Device(s) dound
scanning bus for storage devices... 0 Storage Device(s) found

 

I tried the USB Stick in a different SRX100 and this one tells me that it has found 1 storage device. 

 

So i tried to install the JunOS over tftp, after enter the command the device started the installation. 

After a short while i get the Error:

ERROR: Target media /dev/da0 does not exist

and the srx reboots. 

 

Anyone an idea? Please help me. 

 

2 REPLIES 2
Highlighted
SRX Services Gateway

Re: SRX100 doesn't boot, junos setup fails

‎07-01-2015 07:21 PM

Hello ,

 

This looks like Fash corruption .  What you can try doing is that make the USB in FAT32 format ( and below 4GB)  , Copy a snaphot from another SRX100 that you have .  :

 

>request system snaphot media usb

 

Once its taken , connect it to our faulty SRX and reboot . It should reboot from USB since it does not find any install medium in the SRX Flash . If it boots up from USB , then copy that snapshot to our flash :

 

>request system snapshot media internal

 

If this also does not work  we may need to RMA the device bu opeing a JTAC case since you already tried other recovery method.


Thanks,
Sam

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too .....
Highlighted
SRX Services Gateway

Re: SRX100 doesn't boot, junos setup fails

‎08-19-2015 06:24 AM

Thank you Sam, 

sorry for my late response, I tried your solution. But this doesn't worked for me. The SRX doesn't recognize any USB Device. At the Uboot Screen the device shows me 0 Storage Device (s) found with a plugged in USB (of course I tried to boot from the created USB without success). The working SRX shows me 1 Storage device with a plugged in USB an I could create a snapshot. 

How can I create a JTAC Case? When I want to create a case from the customers support page I had to enter an Associated Account. 

 

Thank you so far. 

Feedback