SRX Services Gateway
SRX Services Gateway

SRX210 - No elf image at ...

‎10-27-2010 07:57 PM

I attempted to upgrade a SRX210H from 9.5 to 10.3. From the web interface everything seemed to go well but when the box rebooted I ended up at the U-Boot prompt (1.1.6-JNPER-1.9). I've searched for the error to no avail. I've found all sorts of information on using loader (which I don't have and seem to not be able to get). Anyone with any ideas on how I can recover?

4 REPLIES 4
SRX Services Gateway

Re: SRX210 - No elf image at ...

‎10-27-2010 08:14 PM

If you check the release-notes, you'll see there's always a paragraph which details a restriction of how many versions apart you can do an upgrade. You went too far. The supported upgrade limit is 3 major releases (so 10.1 should have been your target, then once that's complete 10.3 would have been OK). You can occasionally, by accident, get away with violating this rule, but that's the envelope within which we test and the only thing supported.

 

Hopefully you did "request system snapshot" (try that ScreenOS!) for a backup you should be able to easily recover.

 

-Keith

SRX Services Gateway

Re: SRX210 - No elf image at ...

[ Edited ]
‎10-27-2010 08:50 PM

No such luck. It was a fresh config and I decided to start by upgrading before doing anything else. I was actually trusting the little note on the side of the software page which seem to imply that it was okay to upgrade from 9.0 or later firmware. Well I'll have to read everything before proceeding next time. Smiley Sad

 

Any idea how I get my hands on a u-boot image with laoder and what the u-boot commands (address) are so I can get to loader so I can then do a tftpboot? I tried to access JTAC but was denied. I've also sent an email to our Juniper rep to see how we go about getting support.

 

Thanks

SRX Services Gateway

Re: SRX210 - No elf image at ...

‎10-28-2010 07:51 AM

The uboot and loader files are within the image. You can extract them (boot folder), they should also have been copied to your flash.

 

KB16248 may help. It's SRX650-specific, though, so I would not expect these addresses to be the same on a SRX210H. Someone with a working SRX210H may be able to pull the addresses for you using

 

nvram getenv boot.upgrade.uboot

nvram getenv boot.upgrade.loader

 


SRX Services Gateway
Solution
Accepted by topic author ncherry
‎08-26-2015 01:27 AM

Re: SRX210 - No elf image at ...

‎10-28-2010 08:36 AM

Here are the addresses from an SRX210H - good luck!

 

root@% nvram getenv boot.upgrade.uboot
boot.upgrade.uboot=0xbfc00000
root@% nvram getenv boot.upgrade.loader
boot.upgrade.loader=0xbfe00000

Kevin Barker
JNCIP-SEC
JNCIS-ENT, FWV, SSL, WLAN
JNCIA-ER, EX, IDP, UAC, WX
Juniper Networks Certified Instructor
Juniper Networks Ambassador

Juniper Elite Reseller
J-Partner Service Specialist - Implementation

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.