SRX Services Gateway
Highlighted
SRX Services Gateway

SRX210 doesn't boot after upgrade

‎06-07-2011 07:14 AM

Hi,

 

I tried to upgrade my SRX210 from JUNOS 9.6 to 10.2. I've downloaded the correct image, started the upgrade, validation was successful and the box rebooted. After the reboot, the installation was totally damaged. Here is the output:

 

U-Boot 1.1.6-JNPR-1.7 (Build time: May  4 2010 - 06:59:58)

SRX_210_HIGHMEM board revision major:0, minor:28, serial #: AAAH2513
OCTEON CN5020-SCP pass 1.1, Core clock: 400 MHz, DDR clock: 200 MHz (400 Mhz data rate)
DRAM:  1024 MB
Starting Memory POST...
Checking datalines... OK
Checking address lines... OK
Checking 512K memory for U-Boot... OK.
Running U-Boot CRC Test... OK.
Flash:  4 MB
USB:   scanning bus for devices... 3 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
Clearing DRAM........ done
BIST check passed.
Starting PCI
PCI Status: PCI 32-bit
PCI BAR 0: 0xf8000000, PCI BAR 1: Memory 0x00000000  PCI 0x00000000
Boot Media: nand-flash usb
Net:   octeth0
POST Passed
Press SPACE to abort autoboot in 1 seconds
## No elf image at address 0x00100000

 

 

Pressing SPACE when prompted doesn't help, I'm not able to get into the loader mode to recover my SRX.

 

Is there anywhere a documentation how to recover the SRX JUNOS image if I can't get into the loader mode?

Any hints?

 

Thank you!

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.
2 REPLIES 2
Highlighted
SRX Services Gateway

Re: SRX210 doesn't boot after upgrade

‎06-07-2011 08:19 AM

If you are unable to get the loader prompt (by pressing SPACEBAR) ... that it means your uboot (bootloader) component is malfunc ... so TFTP based solutions will not implementable ...

 

you will have to initiate a case with Juniper TAC

 

regards

Hafiz Muhammad Farooq
JNCIE-SEC, JNCIP-SEC, JNCIS-SEC, JNCIS-FWV
JNCIS-SP, JNCIS-SA, JNCIA-JUNOS
IBM Qradar Deployment Professional

[Please mark it as Accepted Solution if it works, Kudos if you like]

SRX Services Gateway

Re: SRX210 doesn't boot after upgrade

‎06-07-2011 09:29 AM

Moving from 9x to 10.x you need to manually update UBOOT before creating the dual root partitions.

Feedback