SRX Services Gateway
SRX Services Gateway

SRX300 - DHCP and IP phone

03.17.17   |  
‎03-17-2017 06:07 PM

I have an SRX300 and with DHCP configured.  When I connect my laptop to the SRX, it happily receives an IP address with all the options I have associated with the config.  If I connect an IP phone, it will not get an address.  I have tried this with 2 different phones from 2 different manufactures with the same result.  The same phones connected to a different network and router receive an IP address.

5 REPLIES
SRX Services Gateway

Re: SRX300 - DHCP and IP phone

03.17.17   |  
‎03-17-2017 08:40 PM

Hello,

 

 

I suspect IP Phones are expecting certain DHCP options from the server like Option 66 or Option 120 etc.

You can check the Manual of IP Phones you have tried so far to know such requirements.

 

Regards,

 

Rushi

SRX Services Gateway

Re: SRX300 - DHCP and IP phone

03.18.17   |  
‎03-18-2017 07:53 AM

Rushi, this isn't about options.  As I stated above, the phones don't even get an IP address.  

Highlighted
SRX Services Gateway

Re: SRX300 - DHCP and IP phone

03.18.17   |  
‎03-18-2017 08:01 AM
are you using dhcp or jdhcp? i have seen similar issues with dhcp . you can use "show system process extensive | match dhcp" to confirm the process.

if you are already using jdhcp then please enable dhcp traceoptions on srx.
can you collect "show dhcp server statistics" during problem state
Thanks,
Suraj
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too
SRX Services Gateway

Re: SRX300 - DHCP and IP phone

03.18.17   |  
‎03-18-2017 09:06 AM

Hello,

 

Can you let me know the Vendor name of IP Phones (any one) that you have tried so far in addition to the traceoptions that rsuraj has suggested?

 

Regards,

 

Rushi

 

SRX Services Gateway
Solution
Accepted by topic author bruce@tellarc.com
‎03-18-2017 11:05 AM

Re: SRX300 - DHCP and IP phone

03.18.17   |  
‎03-18-2017 11:05 AM

It is now working.  I tried dhcp and jdhcp and both failed.  I then upgraded to 15.1X49-D75.5 and it is now working with jdhcp.

 

Thanks for your help!