SRX Services Gateway
SRX Services Gateway

SRX340 15.1.X49 D150.2 PPPoE will not get passed PADI sent, whatever I try , and have been at it for a week full time now

[ Edited ]
‎11-15-2018 07:16 AM

I am ready to junk this box, throw it out of the window, hit the vendor etc. This is getting ridiculous.

I have a brand new location here, with a brand-new KPN supplied 500mbit fiber, supplied via an Alcatel Edge switch.

KPN brought in their own Cisco 897 pos router to show the connection is up and working and so prove that the problem is not theirs, but is the SRX (which is not Cisco, so they do not support it unless they sold it to me). Hopeless, hapless, helpless in fact.

 

So, for a week I have tried everything to get PPPoE up with their specs for the Cisco configuration emulated as much as possible. No joy, never gets passed PADI sent (see log). I even tried to set up IPoE but could not figure out how to do this as it required using KPNs CPE IP-address as the gateway which I could not imagine where to enter.

Here is a snippet of the log that has replicateed itself all day for the last 5 days or so.

Nov 15 14:36:04 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:36:22 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:36:55 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:38:01 Discovery phase timedout for intf pp0.0                                                                                                                                                                                              
Nov 15 14:38:05 ***Discovery Init: pp0.0                                                                                                                                                                                                             
Nov 15 14:38:05 allocated 1510 bytes at 0x4fe000                                                                                                                                                                                                     
Nov 15 14:38:05 *totlen=0x6 tp->len=0x2 ntohs(tplen)=0x2 tot=0x6 MAX_L=0x1502                                                                                                                                                                        
Nov 15 14:38:05 *totlen=0xa tp->len=0x0 ntohs(tplen)=0x0 tot=0xa MAX_L=0x1502                                                                                                                                                                        
Nov 15 14:38:05 IO send ... PADI for pp0.0                                                                                                                                                                                                           
Nov 15 14:38:08 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:38:13 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:38:22 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:38:39 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:39:12 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:40:18 Discovery phase timedout for intf pp0.0                                                                                                                                                                                              
Nov 15 14:40:22 ***Discovery Init: pp0.0                                                                                                                                                                                                             
Nov 15 14:40:22 allocated 1510 bytes at 0x4fe000                                                                                                                                                                                                     
Nov 15 14:40:22 *totlen=0x6 tp->len=0x2 ntohs(tplen)=0x2 tot=0x6 MAX_L=0x1502                                                                                                                                                                        
Nov 15 14:40:22 *totlen=0xa tp->len=0x0 ntohs(tplen)=0x0 tot=0xa MAX_L=0x1502                                                                                                                                                                        
Nov 15 14:40:22 IO send ... PADI for pp0.0                                                                                                                                                                                                           
Nov 15 14:40:25 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:40:30 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:40:39 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:40:57 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:41:30 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:42:36 Discovery phase timedout for intf pp0.0                                                                                                                                                                                              
Nov 15 14:42:40 ***Discovery Init: pp0.0                                                                                                                                                                                                             
Nov 15 14:42:40 allocated 1510 bytes at 0x4fe000                                                                                                                                                                                                     
Nov 15 14:42:40 *totlen=0x6 tp->len=0x2 ntohs(tplen)=0x2 tot=0x6 MAX_L=0x1502                                                                                                                                                                        
Nov 15 14:42:40 *totlen=0xa tp->len=0x0 ntohs(tplen)=0x0 tot=0xa MAX_L=0x1502                                                                                                                                                                        
Nov 15 14:42:40 IO send ... PADI for pp0.0                                                                                                                                                                                                           
Nov 15 14:42:43 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:42:48 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:42:57 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:43:14 IO send ... Packet resend for pp0.0                                                                                                                                                                                                  
Nov 15 14:43:47 IO send ... Packet resend for pp0.0           

this goes on forever

the config in use is attached.

 

Now, could you please please help me out of the morass and get this to work? Our oprtaions are now halted due to....lack of internet.

2 questions: how to get PPPoE up  and what about IPoE, which seems a much better solution to me. 

I will be pleased with any and all advice!  Do not mind the config, I know it is sloppy; I want the connection up, security comes after.

 

       

 

 

Attachments

4 REPLIES 4
SRX Services Gateway

Re: SRX340 15.1.X49 D150.2 PPPoE will not get passed PADI sent, whatever I try , and have been at it for a week full time now

[ Edited ]
‎11-16-2018 04:39 AM

Hi Attore,

 

you are right - Juniper is not Cisco... And thank god it's not. I can understand you - sometimes in Operations this can be frustraing but Juniper has a very good Community to help you.

 

If there is immediate need, you should contact JTAC (in case you hopefully have purchased support for this box) so that the new site can work.

 

Can I ask you to include a small Diagram of your Topology?

Do you have the working Cisco Config from KPN? --> If they provide you with this it's very simple to convert this to JunOS.

 

Regards
Chris
SRX Services Gateway

Re: SRX340 15.1.X49 D150.2 PPPoE will not get passed PADI sent, whatever I try , and have been at it for a week full time now

‎11-16-2018 09:02 AM

had already written a full answer and apparently was not signed in, so here we go again. still working out support, the box is brand new, we asked for installation, but our reseller didnt have availability until december, simply to late for us. and in any case, I am a guy who bought and used the very first Netscreen 1000 cluster in Europe, so who needs a reseller? ;-)
So, no support contract I am sorry to say. But I am sure we can all sort this out somehow. If a friggin piece of **bleep** router like the Cisco 897 can do it, so can we :-). 
Ok, 500 mbit fiber accesspoint, switched port on an Alcatel Edge Router. KPN has given us a 5 address range (31.161.5.208/29) and offer 145.54.104.213/30 as a possible IPoE gateway. I cannot get either to work for me. You have the PPPoE config used, and I have also made a IPoE config, with zero security zones and a static route 0.0.0.0/0 to 145.54.104.213 via our ge-0/0/0,0 with 145.54.104.214. The 145 adresses are not routable according to KPN, and they advise to put their 213 as a gateway (cant do with the SRX I think). I have enclosed the settings KPN uses on their Cisco routers, which they would place in front of a firewall. If we can translate that, things might have a better chance of working. Right now, I want a connection, PPPoE or IPoE, both fine. Security can follow after that, I need to see datastream! Thanks for your help so far!

Attachments

SRX Services Gateway

Re: SRX340 15.1.X49 D150.2 PPPoE will not get passed PADI sent, whatever I try , and have been at it for a week full time now

‎11-17-2018 03:11 AM

Ok, I have gotten IPoE to work by switching the box from flow to packet mode. Nice to finally have more then 4G at the office. Now I have to figure out how to get flow back to the parts where I need stateful inspection.  It is really to bad this option was not hardwired into some of the ports; if you are a router/switch/firewall all in one, basic routing should be the start, not the byproduct I think.

So a further question begs itself: what would be the best way to continue? I think zone is far better firewall-wise. 

 

Highlighted
SRX Services Gateway

Re: SRX340 15.1.X49 D150.2 PPPoE will not get passed PADI sent, whatever I try , and have been at it for a week full time now

‎11-19-2018 05:45 AM

I will check it this week and send you a possible way. You could do "Selective Packet mode" https://kb.juniper.net/InfoCenter/index?page=content&id=KB26757 however I'm sure that using 2 Routing-Instances would be a "better" way. I will look into this and get back to you ASAP Smiley Happy

 

But nice, that you got it working so far with packet mode - the rest is definitely "doable" Smiley Happy

Regards
Chris