SRX

last person joined: 4 days ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 01-14-2010 22:18

    Hi Guys,

     

    I have cisco switch and SRX 650

     

    How can I aggregate the ports on my SRX650 so I can connect it to etherchannel (aggregated) port on my cisco switch.

     

    I want also to add IP address to ae0.

     

    Does anyone who can assist me to how to configure it...

     

     

    Thanks in advance

     

     

     



  • 2.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 01-14-2010 23:46

    As far as I know Ethernet Link Aggregation (ag interfaces) is part of the "Advanced Switching" feature set and is not available on the 4 GE ports in the SRX650 base board. You can, however, configure it using ports of any optional XPIM.

     

    Which SRX650 interfaces are you using?

     

    Xavi



  • 3.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 01-15-2010 00:17
    I am using ge-2/0/x ports from the new module installed.


  • 4.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface
    Best Answer

    Posted 01-15-2010 04:30

    The following may be suitable:

     

    set chassis aggregated-devices ethernet device-count 1
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 unit 0 family inet address 192.168.100.254/24
    set interfaces ge-2/0/0 gigether-options 802.3ad ae0
    set interfaces ge-2/0/1 gigether-options 802.3ad ae0
    set security zones security-zone trust interface ae0 host-inbound-traffic system-services all

     

    You can instead define a vlan instead and attach this to your ae0.0:

     

    set chassis aggregated-devices ethernet device-count 1
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 unit 0 family ethernet-switching port-mode trunk vlan members all
    set interfaces ae0 unit 0 family ethernet-switching native-vlan-id 100
    set interfaces ge-2/0/0 gigether-options 802.3ad ae0
    set interfaces ge-2/0/1 gigether-options 802.3ad ae0
    set interfaces vlan.100 family inet 192.168.100.254/24
    set vlans vlan100 vlan-id 100 l3-interface vlan.100
    set security zones security-zone trust interface vlan.100 host-inbound-traffic system-services all

     

    For the above make sure you have a trust intra-zone security policy permitting traffic.

     

    "show lacp interfaces" will show your ae0 status (in this case it is down):

     

    Aggregated interface: ae0
        LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
          ge-2/0/0       Actor    No   Yes    No   No   No   Yes     Fast    Active
          ge-2/0/0     Partner    No   Yes    No   No   No   Yes     Fast   Passive
          ge-2/0/1       Actor    No   Yes    No   No   No   Yes     Fast    Active
          ge-2/0/1     Partner    No   Yes    No   No   No   Yes     Fast   Passive
        LACP protocol:        Receive State  Transmit State          Mux State
          ge-2/0/0                Defaulted   Fast periodic           Detached
          ge-2/0/1            Port disabled     No periodic           Detached

     

    Hope this helps!

     

    mikevaus



  • 5.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 01-15-2010 05:18

    Afaik family inet is not supported on aggregated-ethernet interfaces, so you'd have to go for option 2 (with the vlan setup).

     

    I think you might need to use:

    set interfaces ae0 aggregated-ether-options lacp

     

    in stead of:

    set interfaces ae0 aggregated-ether-options lacp active

     

    I believe that way the SRX creates a static aggregated interfaces in stead of using lacp, which i think your cisco does not support.



  • 6.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 01-15-2010 06:36

    @dennish wrote:

    Afaik family inet is not supported on aggregated-ethernet interfaces, so you'd have to go for option 2 (with the vlan setup).

     

    I think you might need to use:

    set interfaces ae0 aggregated-ether-options lacp

     

    in stead of:

    set interfaces ae0 aggregated-ether-options lacp active

     

    I believe that way the SRX creates a static aggregated interfaces in stead of using lacp, which i think your cisco does not support.


     

    I haven't actually tried it without a vlan attached to the ae interface, but it will let you commit with a family inet address.  Whether this works is another matter 🙂

     

    ae0 {
        aggregated-ether-options {
            lacp {
                active;
            }
        }
        unit 0 {
            family inet {
                address 192.168.100.254/24;
            }
        }
    }


      Logical interface ae0.0 (Index 71) (SNMP ifIndex 151)
        Flags: Device-Down SNMP-Traps 0x0 Encapsulation: ENET2
        Statistics        Packets        pps         Bytes          bps
        Bundle:
            Input :             0          0             0            0
            Output:             0          0             0            0
        Security: Zone: Null
        Protocol inet, MTU: 1500
          Flags: None
          Addresses, Flags: Dest-route-down Is-Preferred Is-Primary
            Destination: 192.168.100/24, Local: 192.168.100.254, Broadcast: 192.168.100.255

     

    You may be right about the active flag, I was assuming the cisco config included "channel-group x mode active" on each bundled interface and I believed lacp active was to be set on the SRX.


  • 7.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 01-15-2010 06:40

    Hmm i asumed cisco always uses pagp in stead of lacp, but i might be misonformed about that.

    Therefore i asumed on the cisco end you had to force a static eth-chan by setting mode on and on the juniper side disable lacp.

     

    If i recall correctly i did this with a EX4200 and a (good old) cat 4006...

     

     

    Regarding the fam inet on ae... i recall a SRX240 not committing that config...



  • 8.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 01-25-2010 18:10

    Thanks to all of you guys for your warm response. Especially to you mikevaus, your config works for us.

    By the way, Guys what is the maximum number of Ge-ports that can be bundle to one ae(x) interface?

    Is it possible to aggregate 5 Ge-interfaces on SRX 5600?

    Thanks,

    Mark


    #nkis


  • 9.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 03-15-2010 11:40

    U will able add uptill 8 equale speed links in and AE on stand alone and 16 in a cluster ( 8 pr not).

     



  • 10.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 10-20-2011 00:32

     



    As far as I know Ethernet Link Aggregation (ag interfaces) is part of the "Advanced Switching" feature set and is not available on the 4 GE ports in the SRX650 base board

       in release 10.4 situation hasn't changed?

     



  • 11.  RE: aggregate 2 GE interfaces and add IP address in aggregated interface

    Posted 05-29-2012 06:19

    @alk wrote:

     



    As far as I know Ethernet Link Aggregation (ag interfaces) is part of the "Advanced Switching" feature set and is not available on the 4 GE ports in the SRX650 base board

       in release 10.4 situation hasn't changed?

     


    It has not changed.