SRX Services Gateway
SRX Services Gateway

failed to upgrade u-boot

‎01-05-2010 12:14 AM

hi all,

 

i have srx650 already running software 10.0R2.10.

but there have chassis alarm :

Alarm time               Class  Description

2010-01-05 14:47:58 WIT  Minor  Host 0 Boot firmware requires upgrade

 

i found at this forum and KB, by that alarm we must upgrade the u-boot. By following this instruction http://kb.juniper.net/index?page=content&id=KB16317&cat=SRX_650&actp=LIST, also failed.

Then i found this instruction http://kb.juniper.net/index?page=content&id=KB16248&actp=search&searchid=1262673768570 .

But still cannot upgrade the u-boot. 

 

 

root@SRX% bootupgrade -u /boot/uboot -l /boot/loader

Error: upgrade address wrong 0xbfe00000 0xbfc00000 0

 

 

 

root@SRX% nvram setenv boot.upgrade.uboot 0xbfe00000

nvram: Invalid CRC on Saved Environment

 

need help

 

 

Regards,

ND
25 REPLIES 25
Highlighted
SRX Services Gateway
Solution
Accepted by topic author NDCool
‎08-26-2015 01:27 AM

Re: failed to upgrade u-boot

‎01-05-2010 08:11 PM

http://kb.juniper.net/KB16248

 

This article hsa just been updated. The info you need should be there. Try these shell commands instead.


kenv boot.upgrade.uboot=0xbf400000
kenv boot.upgrade.loader=0xbf600000

 

Then try the bootupgrade command again and reboot.

 

-Richard

SRX Services Gateway

Re: failed to upgrade u-boot

[ Edited ]
‎01-05-2010 09:57 PM

Hi Richard,

 

thanks for the updates, and working now to update the env value.

 

But after run that command, and restart the box, i cannot access the srx, even by console also.

I look at RE board, all led is off.

 

What should i do ?

Regards,

ND
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-06-2010 05:02 PM

does anything show up on console after pwoer cycle?

****pls click the button " Accept as Solution" if my post helped to solve your problem****
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-06-2010 06:55 PM

Hi WL,

 

No, srx doesn't show anything after power cycle

any suggestion ?

Regards,

ND
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-06-2010 06:59 PM

Hi

 

Hmm, I would suggest

- hard power cycle

-reseat RE

 

If that still fails, no lights on RE, then I think only way is to RMA the RE unfortunately, if nothing is seen from console for boot then there could be some other underlying hardware issue Smiley Sad

****pls click the button " Accept as Solution" if my post helped to solve your problem****
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-06-2010 09:13 PM

Hi 

 

- hard power cycle -> done, no effect

- reset RE -> done, no effect also.

 

better i request RMA to TAC to solve this issue.

Regards,

ND
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 01:37 PM

Is the device still usable? I am affraid that I might get the same issue when I upgrade my SRX240 if I need to RMA it I would like it atleast to be able to perform its features.

SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 02:30 PM

which ver are you upgrading from and to?

****pls click the button " Accept as Solution" if my post helped to solve your problem****
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 03:39 PM

SRX240 upgrading from Junos 10r1.6 to 10r2

SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 03:44 PM

Should be fine, try to upgrade using cli and have console access as well.

****pls click the button " Accept as Solution" if my post helped to solve your problem****
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 06:27 PM

do you already upgraded or not ?

Regards,

ND
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 07:06 PM

upgraded to 10R2 with latest boot loader using the shell worked fine no issues at all from my understanding this issue only happens to the srx650's

SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 07:19 PM

Hi, 

 

do you change this variable on your srx ?

 

kenv boot.upgrade.uboot=0xbf400000
kenv boot.upgrade.loader=0xbf600000

 

after i change this variable and restart the box, my srx unable to boot up.

Regards,

ND
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 07:51 PM

Hi

 

Actually that KB is only for SRX650. The bootenv is specific to that. For 240 it should be this:

root@SRX240-A06_31% kenv | grep uboot
boot.upgrade.uboot="0xbfc00000 "
root@SRX240-A06_31% kenv | grep loader
boot.upgrade.loader="0xbfe00000 "

 

You need to revert back. If that does not work you need to reload the uboot, loader then install from usb

****pls click the button " Accept as Solution" if my post helped to solve your problem****
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 08:26 PM

How can I reload the U boot, I cannot access from the console.....

 

Is there any literatur to deploy Uboot on the SRX?

 


Please advice

 

 

Cunny

SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 09:37 PM

for uboot upgrade from tftp :

 

http://kb.juniper.net/index?page=content&id=KB14175&smlogin=true

 

for uboot from shell:

http://kb.juniper.net/KB16317

only for 10.0

 

you will definitely need console actually.

 

****pls click the button " Accept as Solution" if my post helped to solve your problem****
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-07-2010 10:05 PM

what if the u boot is crash, can I recover it?

SRX Services Gateway

Re: failed to upgrade u-boot

‎01-08-2010 09:34 AM

you should be able to break the boot seq then reload the uboot and loader. if you are already at the loader prompt, then if you have usb you can reinstall junos to recover the box.

****pls click the button " Accept as Solution" if my post helped to solve your problem****
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-11-2010 01:25 PM

Just wanted to post that I successfully upgraded u-boot following http://kb.juniper.net/KB16248 for my SRX650. I was getting the CRC errors indicated in the KB.