SRX Services Gateway
SRX Services Gateway

ip-monitoring set preferred-route pp0 or change metric of access-internal routes

‎10-27-2014 02:56 AM



im using a scenario on my SRX110 with two upstream-connections, one via cable-modem that is connected to a fe-port which is set to be the dhcp-client, cable-modem is the dhcp-server. 

backup upstream-connection is an adsl-connection, this route is also set via dhcp. 


my goal is to make the dsl-upstream the default upstream by ip-monitoring service.


i have a problem applying routes in the ip-monitoring policy


im trying to set (for testing purposes) 

preferred-route {
   route {

      next-hop pp0.0


the route is applied, my rpm-probes work (failing correctly), but the next-hop is set to, as opposed to the "qualified-next-hop" statement in global routing-options static route, where the gateway is set correctly.


any way to achieve this with pp0`? (obviously since the upstream ip is dynamic, i cant set the next-hop ip since it changes.)








You can also find me on Freenode IRC in #juniper, my handle is "cy[]"