SRX Services Gateway
Highlighted
SRX Services Gateway

jFlow once was working but stopped

‎11-13-2014 08:15 AM

Hi,

 

We were using jFlow to monitor interfaces however it stopped after we stopped NTP for some reason. We enabled NTP again after a while but jFlow is still not working. We also deleted jFlow configuration and added again but it didint work.

 

The configuration is below;

 

set interfaces reth0 unit 81 vlan-id 81
set interfaces reth0 unit 81 family inet sampling input
set interfaces reth0 unit 81 family inet sampling output

set forwarding-options sampling input rate 100
set forwarding-options sampling input run-length 0
set forwarding-options sampling family inet output flow-server 10.100.0.250 port 2056
set forwarding-options sampling family inet output flow-server 10.100.0.250 version 5

 What do you think the problem is ?

 

Thanks in advance

3 REPLIES 3
Highlighted
SRX Services Gateway

Re: jFlow once was working but stopped

‎11-13-2014 06:29 PM

Is this on SRX-Branch series of High end? On branch this feature is not supported I blve (sampling on reth) and if thats the case you may try a reboot and it may start working again.

 

Thanks,

Suraj

 

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too

Thanks,
Suraj
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too
Highlighted
SRX Services Gateway

Re: jFlow once was working but stopped

‎11-25-2014 01:27 AM

Thanks rsuraj, we didnt restart it yet but I believe we have to restart it.

 

In addition this is an SRX3400 device.

Highlighted
SRX Services Gateway

Re: jFlow once was working but stopped

‎11-25-2014 09:38 PM

you can also try using fireall filter to do sample instead of specifying directly under interface.

 

Thanks,

Suraj

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too

Thanks,
Suraj
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too
Feedback