SRX Services Gateway
SRX Services Gateway

juniper srx650 node 0 hardware failure

a week ago

Dears,

 

We have a Cluster HA active -passive Juniper SRX650 enviornment(Node 0 was active).

Now the node 0 is down and Node 1 is the primary and everything working fine .

I want to replace the faulty  power adapter and what  are the necessary steps I have to take to replace it  without donwtime.

Notes:

set chassis cluster redundancy-group 1 preempt     /// is enabled

Attached the screenshot of current cluster status

 

Thanks & Regards,

SS

 

 

Attachments

5 REPLIES 5
SRX Services Gateway

Re: juniper srx650 node 0 hardware failure

a week ago

The safest approach is probably to follow the full RMA node replacement procedure as outlined in this kb article.

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB21134

 

But if there are no configuration changes made since the power supply failure and the hardware replacement is just that you likely can simply add the unit and power up the SRX.  The cluster should reform and become healthy again.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
SRX Services Gateway

Re: juniper srx650 node 0 hardware failure

[ Edited ]
a week ago

Thanks ! 

 

I just added the firewall and still the node 1 (primary)is up for me -(Node 0 was faulty ,which is replaced)... Cluster status is also fine.

So the commit on node1 (the primary  now) will replicate in Node 0 with updated config?

 

Because

> request routing-engine login node 0        is not allowing me  to enter the node0(which came up now)  with node1 credentials

Cluster status is showing fine.

 

Thanks & Regards,

SS

 

SRX Services Gateway

Re: juniper srx650 node 0 hardware failure

Thursday

Yes, if the cluster is UP with "show chassis cluster status" showing priority as "Non-Zero". Config should be in sync between node1 and node0.

 

Regards,
Rahul
SRX Services Gateway

Re: juniper srx650 node 0 hardware failure

Thursday

THanks Rahul!

 

My issue is  request routing-engine login node 0 to connect node 0 is not allowing ;

I suspect the config is not sync.

 

I am planning to commit the node 1 (primary now) . this will push the existing configuration to node 0 ?

Or it is done already?

Attached the cluster status

 

THanks & Regards,

SS

Attachments

SRX Services Gateway

Re: juniper srx650 node 0 hardware failure

Monday
I just added the firewall and still the node 1 (primary)is up for me -(Node 0 was faulty,
which is replaced)... Cluster status is also fine.

What exactly did you replace?

If the main SRX was replace which would include the internal ssd then you do need to perform the procedure outlined in the kb article for RMA replacement.

https://kb.juniper.net/InfoCenter/index?page=content&id=KB21134

 

But if you only placed an power supply module.

And the device is the same as before.

And there have been NO changes in the configuration.

Then you might be able to take the shortcut.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home