SRX Services Gateway
SRX Services Gateway

srx-210 boot issue

‎11-17-2010 12:14 PM

I have an srx-210hm  running 10.2R2 code. When the device boots up it gets to the point:

 octpkt0: <Octeon RGMII> on obio0,


then it crashes and says the following and exits to a db> prompt. If I restart the device several times eventually it will make it past this point and bootup as normal. I tried reinstalling the o/s from TFTP and formatting both the backup and primary partitions. Still has this problem. I am running u-boot 1.7


cpu0: trap error = 7 stop octeon.hw.shutdown



below let me past some info for the box:


Hardware inventory:
Item             Version  Part number  Serial number     Description
Chassis                                AD2609AAXXXXX      SRX210h
Routing Engine   REV 28   750-021779   AAAH2277          RE-SRX210H
FPC 0                                                    FPC
  PIC 0                                                  2x GE, 6x FE, 1x 3G
Power Supply 0


 show system firmware
Part             Type           Tag Current   Available Status
                                    version   version
Routing Engine 0 RE BIOS        0   1.7                 OK
Routing Engine 0 RE BIOS Backup 1   1.7                 OK


 show chassis routing-engine
Routing Engine status:
    Temperature                 45 degrees C / 113 degrees F
    Total memory              1024 MB Max   553 MB used ( 54 percent)
      Control plane memory     560 MB Max   347 MB used ( 62 percent)
      Data plane memory        464 MB Max   204 MB used ( 44 percent)
    CPU utilization:
      User                       6 percent
      Background                 0 percent
      Kernel                    12 percent
      Interrupt                  0 percent
      Idle                      81 percent
    Model                          RE-SRX210H
    Serial ID                      AAAH2277
    Start time                     2010-11-17 13:59:09 EST
    Uptime                         1 hour, 12 minutes, 1 second
    Last reboot reason             0x200:chassis control reset
    Load averages:                 1 minute   5 minute  15 minute
                                       0.09       0.14       0.15



 show system storage partitions
Boot Media: internal (da0)
Active Partition: da0s1a
Backup Partition: da0s2a
Currently booted from: Active (da0s1a)

Partitions information:
  Partition  Size   Mountpoint
  s1a        293M   altroot
  s2a        293M   /
  s3e        24M    /config
  s3f        342M   /var
  s4a        30M    recovery




I am at a loss, any help would be appreciated.

John Burns
SRX Services Gateway

Re: srx-210 boot issue

‎11-17-2010 02:13 PM

Hi ,

I think you can try Reimaging the box


1-get a flash &  fromt it   then put junos.tgz copy on it ( without creating flodres)

For Format : Use FAT if USB size is less than equal to 2GB or FAT32 if USB is greater than or equal to 4 GB.


2-insert the flash into the SRX  at one of the USB ports


3-Reboot the SRX , When junos is coming up , you will see the message : " Hit Enter to continue or spac bar for loader"  , here you shoul Hit space , you will be at loader mode , the prompt should be "loader>"


If the prompt is " > " , type   > boot  to make it   ">loader"


4- Type the command : loader> install file:/// junos-srxsme-10.0R2.10-domestic.tgz ( The red part change depending on your  version )


**************  Click on the button saying " Accept  as Solution"  if  My Post solved your problem  **************



SRX Services Gateway

Re: srx-210 boot issue

[ Edited ]
‎11-17-2010 07:17 PM

Hi John, you do not need to reimage the box. This problem may be caused by incorrect environment settings. We'll update you shortly on how to detect and fix the problem.


SRX Services Gateway
Accepted by topic author bufo333
‎08-26-2015 01:27 AM

Re: srx-210 boot issue

‎11-17-2010 10:09 PM

John, please try this:


1. Reboot the system

2. Press space to go to u-boot prompt when you see this message:

    Clearing DRAM....... done
    BIST check passed.
    Boot Media: nand-flash usb
    Net:   pic init done (err = 0)octeth0
    POST Passed
    Press SPACE to abort autoboot in 1 seconds

3. You will get a => prompt

4. Run the following commands:




5. Check if your system boots properly now


SRX Services Gateway

Re: srx-210 boot issue

‎11-20-2010 10:54 PM

That worked great, thanks so much. Is there a kb or anything that lists the env variables of the loader prompt and or commands for that environment?

John Burns
SRX Services Gateway

Re: srx-210 boot issue

‎11-22-2010 11:38 AM

Is this a common problem with SRX 210 devices?  Is it related to a bug in the boot loader or other onboard software?  Will a future Junos / loader update correct whatever the issue is?



If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated.
SRX Services Gateway

Re: srx-210 boot issue

‎11-23-2010 06:34 AM


This issue has been fixed in BIOS (u-boot+loader) version 1.9 and above.

SRX Services Gateway

Re: srx-210 boot issue

‎01-31-2013 06:24 AM

'printenv' from that prompt lists all the valid commands.

All views and opinions shared are my own, unless they happen to be quotes, or links, naturally, of course.
SRX Services Gateway

Re: srx-210 boot issue

‎09-27-2016 04:46 AM

Hi Kaustav,

    I know this is a six year old thread however is the closest thing I have found to my issue so far. I have tried the below however i dont get a responce from the command "setenv". It just echo's back to the next line. 


Firstly it boots to uboot instead of the loader prompt regardless of when or how many times I hit space. 



I have a new image on a usb stick but cannot for the life of me work out how to load/install/ etc.


Thanks in advance


SRX Services Gateway

Re: srx-210 boot issue

‎10-02-2016 05:07 PM



Use this procedure.  The starting portion describes how to set the environment variables from the prompt you have.


the bottom portion gives the install instructions from the USB drive attached.

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)