Wireless LAN
Wireless LAN

Aruba AP option 43

‎11-22-2018 01:55 AM

Good Day, can anyone please share a working config for DHCP option 43 on Junos for aruba access points.

7 REPLIES 7
Wireless LAN

Re: Aruba AP option 43

‎11-22-2018 06:18 AM
Wireless LAN

Re: Aruba AP option 43

‎11-22-2018 11:24 AM

I use:

 

    pool wireless-pool {
        family inet {
            network 10.0.0.0/24;
            range wireless {
                low 10.0.0.10;
                high 10.0.0.254;
            }
            dhcp-attributes {
                router {
                    10.0.0.1;
                }
                option 60 string ArubaAP;
                option 43 ip-address 10.10.1.100;
            }
        }
    }
Wireless LAN

Re: Aruba AP option 43

‎11-22-2018 11:53 PM

Thanks for you reply. Config you provided is related to Junos ELS type. I am looking for EX2200 config.

Wireless LAN

Re: Aruba AP option 43

‎11-23-2018 07:56 AM

It has nothing to do with ELS.

 

root> show version                
fpc0:
--------------------------------------------------------------------------
Model: ex2200-48p-4g
JUNOS Base OS boot [12.3R12-S11]
JUNOS Base OS Software Suite [12.3R12-S11]
JUNOS Kernel Software Suite [12.3R12-S11]
JUNOS Crypto Software Suite [12.3R12-S11]
JUNOS Online Documentation [12.3R12-S11]
JUNOS Enterprise Software Suite [12.3R12-S11]
JUNOS Packet Forwarding Engine Enterprise Software Suite [12.3R12-S11]
JUNOS Routing Software Suite [12.3R12-S11]
JUNOS Web Management [12.3R12-S11]
JUNOS FIPS mode utilities [12.3R12-S11]

{master:0}
root> show configuration          
## Last commit: 2018-09-22 00:25:56 UTC by root
version 12.3R12-S11;
system {
    services {
        dhcp-local-server {
            group local {
                interface vlan.100;
            }
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members wireless;
                }
            }
        }
    }
    vlan {
        unit 100 {
            family inet {
                address 10.0.0.1/24;
            }
        }
    }
}
access {
    address-assignment {
        pool wireless-pool {            
            family inet {
                network 10.0.0.0/24;
                range wireless {
                    low 10.0.0.10;
                    high 10.0.0.254;
                }
                dhcp-attributes {
                    router {
                        10.0.0.1;
                    }
                    option 60 string ArubaAP;
                    option 43 ip-address 10.10.1.100;
                }
            }
        }
    }
}
vlans {
    wireless {
        vlan-id 100;
        l3-interface vlan.100;
    }
}                                       
poe {
    interface all;
}

{master:0}
root> show dhcp server binding    

IP address        Session Id  Hardware address   Expires     State      Interface
10.0.0.10         1           00:00:a3:04:1b:31  86206       BOUND      vlan.100            

{master:0}
root> 
Wireless LAN

Re: Aruba AP option 43

‎11-26-2018 07:31 AM

Hi,

 

We have the domestic version running and only those versions are availible for download. So the configuration is different on this software.

 

Thanks,

Wireless LAN

Re: Aruba AP option 43

‎11-26-2018 10:32 AM
I use the same download pages as everyone else. You’re zero for two so far.
Wireless LAN

Re: Aruba AP option 43

‎11-26-2018 11:18 AM

Thanks for information provided so far. I will continue investigating myself.