SRX Services Gateway
SRX Services Gateway

Re: failed to upgrade u-boot

‎01-14-2010 08:10 PM

Hi Versello,

 

Did you rebooted your SRX after changes the variable ?

 

 

Regards,

ND
SRX Services Gateway

Re: failed to upgrade u-boot

‎03-26-2010 01:03 PM

I have a SRX-240H that got the failed to upgrade boot loader:

Upgrading Loader...
bootflash write failed: Operation timed out
loader upgrade failed: Operation timed out

 

Tried to down grade back to 10.r2 and now the box is not accessible. I found the KB14175 article. This article references a u-boot-crc.bin and laoder_crc. Where can I find these files? I am assuming once i have them on a TFTP server I can then start the upgrade process again.

 

Thanks!

SRX Services Gateway

Re: failed to upgrade u-boot

‎03-29-2010 07:19 AM

> Hi, 

> do you change this variable on your srx ?

> kenv boot.upgrade.uboot=0xbf400000
> kenv boot.upgrade.loader=0xbf600000

>  

> after i change this variable and restart the box, my srx unable to boot up.

> Regards,

> ND

 

When you say your SRX does not boot up, what does it mean?

 

  • It does not show any thing on console after hard power cycle?
  • It stops at bootloader?
Merely kenv commands do not change persistent state of the system. So, even if you execute the kenv commands above and hard power cycle, the system should boot up.
Is there any thing else you tried before or after these commands. That might give a clue as to what went wrong with the system.
Regards

 

SRX Services Gateway

Re: failed to upgrade u-boot

‎03-31-2010 01:25 PM

@j-daniel:

 

Open a case with J-Tac....I had the same with our SRX210...

Be sure to ask specifically for those files and be sure to mention the KB article.

 

The engineer I had never experienced it before, but after searching he found the 2 files at posted to me.....

After another 5~10 minutes and the box was back up Smiley Very Happy

 

Maarten

SRX Services Gateway

Re: failed to upgrade u-boot

‎03-31-2010 05:54 PM
@amjain, yes...it do not disply anything after hard power cycle. I have requested DOA to JTAC and they agree with that. At the beginning my suspect is the RE was failed. But the funny thing , JTAC said they will replace new chassis without replace RE, they assume chassis failure. When received the new DOA chassis.....the box still won't boot up. And my question now is, does JTAC have tried to power on or anything my failed unit before replace the new one??
Regards,

ND
SRX Services Gateway

Re: failed to upgrade u-boot

‎04-01-2010 10:26 AM

"does JTAC have tried to power on or anything my failed unit before replace the new one??"

 

No, those units go back to manufacturing for root-cause analysis. JTAC does not normally have access to returned units.