vMX
vMX

DHCP Relay from a routing-instance

04.16.17   |  
‎04-16-2017 08:39 AM

A vMX router failing to forward DHCP OFFER packet from server to Client. 

Topology Note: DHCP Server and DHCP Client in different routing-instance. 

root@vmx1# show | no-more | display set

set version 16.1R4.7

set system host-name vmx1

set interfaces ge-0/0/1 unit 0 family inet address 10.0.0.1/24

set interfaces ge-0/0/2 unit 0 family inet address 192.168.0.1/24

set forwarding-options dhcp-relay server-group DummyConfig

set routing-options interface-routes rib-group inet DHCP

set routing-options rib-groups DHCP import-rib inet.0

set routing-options rib-groups DHCP import-rib DHCP.inet.0

set routing-instances DHCP instance-type virtual-router

set routing-instances DHCP interface ge-0/0/1.0

set routing-instances DHCP routing-options interface-routes rib-group inet DHCP

set routing-instances DHCP forwarding-options dhcp-relay server-group DHCP-SERVER 192.168.0.2

set routing-instances DHCP forwarding-options dhcp-relay active-server-group DHCP-SERVER

set routing-instances DHCP forwarding-options dhcp-relay group ALL interface ge-0/0/1.0

3 REPLIES
Highlighted
vMX

Re: DHCP Relay from a routing-instance

04.16.17   |  
‎04-16-2017 11:23 PM

Hello,

 

For configuration part, you can refer this link.

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB30584

 

Regards,

 

Rushi

vMX

Re: DHCP Relay from a routing-instance

04.17.17   |  
‎04-17-2017 12:18 AM

Hello Rushi,

 

I went through kb which is for QFX. Wondering how DHCP server i.e. 20.0.0.2 is reachable from VRF.inet.0. I m trying to relate configs to my vMX. Added some configs regarding forwarding-options from kb to my earlier config but it didn't work. Config is something like this.

 

manoz@vmx1# show | display set

set version 16.1R4.7

set system host-name vmx1

 

set interfaces ge-0/0/1 unit 0 family inet address 10.0.0.1/24

set interfaces ge-0/0/2 unit 0 family inet address 192.168.0.1/24

set forwarding-options dhcp-relay forward-only-replies

set routing-options interface-routes rib-group inet DHCP-RELAY

set routing-options rib-groups DHCP-RELAY import-rib inet.0

set routing-options rib-groups DHCP-RELAY import-rib DHCP-RELAY.inet.0

set routing-instances DHCP-RELAY instance-type virtual-router

set routing-instances DHCP-RELAY interface ge-0/0/1.0

set routing-instances DHCP-RELAY routing-options interface-routes rib-group inet DHCP-RELAY

set routing-instances DHCP-RELAY forwarding-options dhcp-relay overrides no-allow-snooped-clients

set routing-instances DHCP-RELAY forwarding-options dhcp-relay forward-only routing-instance default

set routing-instances DHCP-RELAY forwarding-options dhcp-relay server-group DHCP-RELAY 192.168.0.2

set routing-instances DHCP-RELAY forwarding-options dhcp-relay active-server-group DHCP-RELAY

set routing-instances DHCP-RELAY forwarding-options dhcp-relay route-suppression destination

set routing-instances DHCP-RELAY forwarding-options dhcp-relay group DHCP-RELAY active-server-group DHCP-RELAY

set routing-instances DHCP-RELAY forwarding-options dhcp-relay group DHCP-RELAY interface ge-0/0/1.0

vMX
Solution
Accepted by topic author manoj.karmacharya
‎09-12-2017 04:09 AM

Re: DHCP Relay from a routing-instance

08.15.17   |  
‎08-15-2017 09:13 AM

I just got this working on QFX10k (17.2R1)

 

There are 2 VRFs: Tenant-1 and Tenant-2.  DHCP Client is in Tenant-1 and Server is in Tenant-2.  Routes are leaked between VRFs so there is reachability between all subnets.

 

Here are the key config components.  Basically for Tenant-1, specify that incoming DHCP packets are to be relayed to "Tenant-2".  In Tenant-2 VRF, forward the "replies" back to Tenant-1 VRF.

 

set routing-instances Tenant-1 forwarding-options dhcp-relay forward-only routing-instance Tenant-2
set routing-instances Tenant-1 forwarding-options dhcp-relay server-group test 100.0.22.2
set routing-instances Tenant-1 forwarding-options dhcp-relay active-server-group test
set routing-instances Tenant-1 forwarding-options dhcp-relay group DHCP-RELAY active-server-group test
set routing-instances Tenant-1 forwarding-options dhcp-relay group DHCP-RELAY interface irb.10011

 

set routing-instances Tenant-2 forwarding-options dhcp-relay forward-only-replies

 

 

Hope this helps.