vMX
Highlighted
vMX

ECMP over two LSP not working

a month ago

Hi everyone,

I am trying to learn ECMP using two LSP. 

SET UP:

Capture-LOVE.PNG

MX2 must use ECMP over two "RSVP LSP MX2-MX7 " to reach 57.57.57.0/24, however I do not see  it happening.

We can see MX2 has 57.57.57.0/24 pointed  to two LSPS.

root@MX2> show route

57.57.57.0/24 *[Static/5] 01:20:07
                          to 24.24.24.4 via em4.24, label-switched-path MX2-MX5-SEC
                              > to 23.23.23.3 via em5.23, label-switched-path MX2->MX5
                                 [OSPF/10] 04:32:44, metric 3
                               > to 23.23.23.3 via em5.23

 

But only one next hop is installed for 57.57.57.0/24 :

root@MX2> show route forwarding-table destination 57.57.57.0/24
Destination Type RtRef Next hop Type Index NhRef Netif
57.57.57.0/24 user 0 indr 342 1     23.23.23.3 ucst 340 9 em5.23

######################################################

MX2 CONFIG:

set interfaces em1 vlan-tagging
set interfaces em1 unit 192 vlan-id 192
set interfaces em1 unit 192 family inet address 192.168.1.2/24
set interfaces em1 unit 192 family mpls
set interfaces em2 vlan-tagging
set interfaces em2 unit 16 vlan-id 16
set interfaces em2 unit 16 family inet address 16.16.16.2/24
set interfaces em2 unit 16 family mpls
set interfaces em4 vlan-tagging
set interfaces em4 unit 24 vlan-id 24
set interfaces em4 unit 24 family inet address 24.24.24.2/24
set interfaces em4 unit 24 family mpls
set interfaces em5 vlan-tagging
set interfaces em5 unit 23 vlan-id 23
set interfaces em5 unit 23 family inet address 23.23.23.2/24
set interfaces em5 unit 23 family mpls
set interfaces lo0 unit 0 family inet address 2.2.2.2/32

set forwarding-options hash-key family inet layer-3
set forwarding-options hash-key family mpls label-1
set forwarding-options hash-key family mpls payload ip layer-3-only
set routing-options static route 57.57.57.0/24 lsp-next-hop MX2->MX5
set routing-options static route 57.57.57.0/24 lsp-next-hop MX2-MX5-SEC
set routing-options forwarding-table export load-balance


set protocols rsvp interface all subscription 1
set protocols rsvp interface em2.12 subscription 1
set protocols rsvp interface em5.25 subscription 1
set protocols mpls label-switched-path MX2->MX5 from 2.2.2.2
set protocols mpls label-switched-path MX2->MX5 to 5.5.5.5
set protocols mpls label-switched-path MX2->MX5 bandwidth 10m
set protocols mpls label-switched-path MX2->MX5 no-cspf
set protocols mpls label-switched-path MX2-MX5-SEC from 2.2.2.2
set protocols mpls label-switched-path MX2-MX5-SEC to 5.5.5.5
set protocols mpls label-switched-path MX2-MX5-SEC bandwidth 2m
set protocols mpls label-switched-path MX2-MX5-SEC no-cspf
set protocols mpls label-switched-path MX2-MX5-SEC primary TEST
set protocols mpls path TEST 24.24.24.4 strict
set protocols mpls path TEST 45.45.45.5 strict
set protocols mpls interface all
set protocols ospf area 0.0.0.0 interface all interface-type p2p
set protocols ospf area 0.0.0.0 interface em1.192 passive
set protocols ospf area 0.0.0.0 interface em4.24 metric 200
set policy-options policy-statement load-balance then load-balance consistent-hash

 

What am I missing?

 

Thanks and have a good weekend!!

 

 

2 REPLIES 2
Highlighted
vMX
Solution
Accepted by topic author sarahr202
3 weeks ago

Betreff: ECMP over two LSP not working

a month ago

Hello sarah,

 

can you please check if this helps you achieving your goal:

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/load-balancing-bgp-session.html#i...

 

Additionally, this may help as well:

 

routing-options {
    forwarding-table {
        export ECMP-per-packet;
    }
}
policy-options {
    policy-statement ECMP-per-packet {
        then {
            load-balance per-packet;
        }
    }
}
--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.
Highlighted
vMX

Betreff: ECMP over two LSP not working

3 weeks ago

So there is no issue with config, something to do with vMX JUNOS 18 because when I loaded the same config on vMx JUNOS14, tunnles came up right away .