vMX
Highlighted
vMX

LACP issue in vMX in Juniper Virtual lab/ Cloud lab

4 weeks ago

Hi All,

 

Could anybody suggest why lacp enabled interfaces are not coming up in Juniper Virtual lab and Juniper cloud lab vMX device.

FYI, I am using Juniper virtual lab and Juniper cloud lab to build LACP for MC-LAG but here lacp enabled interfaces are not coming up. However, i used "force-up" command to make the lacp enabled interface up but its not communicating each other for which the IRB vlan is passing over the lacp interface. If "force-up" command is not used then interface will not come up.

 

Please let me know if anybody overcome this issue in juniper virtual/ Cloud lab.

 

Below is the vMX's config:

vMX1:-

jcluser@Core-A> show configuration |display set | match ae0
set interfaces ge-0/0/0 gigether-options 802.3ad ae0
set interfaces ae0 description "ICL-LINK b/w Core A & B"
set interfaces ae0 flexible-vlan-tagging
set interfaces ae0 encapsulation flexible-ethernet-services
set interfaces ae0 aggregated-ether-options minimum-links 1
set interfaces ae0 aggregated-ether-options link-speed 1g
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic fast
set interfaces ae0 aggregated-ether-options lacp force-up
set interfaces ae0 unit 0 family bridge interface-mode trunk
set interfaces ae0 unit 0 family bridge vlan-id-list 1-4094

 

jcluser@Core-A> show interfaces terse |match ae0
ge-0/0/0.0 up up aenet --> ae0.0
ge-0/0/0.32767 up up aenet --> ae0.32767
ae0 up up
ae0.0 up up bridge
ae0.32767 up up multiservice

 

jcluser@Core-A> show bridge domain

Routing instance Bridge domain VLAN ID Interfaces
default-switch ICCP 1
ae0.0--->> This interface should be indicated as ae0.0* if the lacp ineterface working properly, Here no * indication even after configured the "force-up" command on ae0.

jcluser@Core-A>

 

vMX2:-

jcluser@Core-B# show |display set |match ae0
set interfaces ge-0/0/0 gigether-options 802.3ad ae0
set interfaces ae0 description "ICL-LINK b/w Core A & B"
set interfaces ae0 flexible-vlan-tagging
set interfaces ae0 encapsulation flexible-ethernet-services
set interfaces ae0 aggregated-ether-options minimum-links 1
set interfaces ae0 aggregated-ether-options link-speed 1g
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic fast
set interfaces ae0 aggregated-ether-options lacp force-up
set interfaces ae0 unit 0 family bridge interface-mode trunk
set interfaces ae0 unit 0 family bridge vlan-id-list 1-4094

[edit]


jcluser@Core-B# run show interfaces terse |match ae0
ge-0/0/0.0 up up aenet --> ae0.0
ge-0/0/0.32767 up up aenet --> ae0.32767
ae0 up up
ae0.0 up up bridge
ae0.32767 up up multiservice

[edit]


jcluser@Core-B# run show bridge domain

Routing instance Bridge domain VLAN ID Interfaces
default-switch ICCP 1
ae0.0----->Here also ae0 interface is not indicated by star (*).

[edit]
jcluser@Core-B#

2 REPLIES 2
Highlighted
vMX

Re: LACP issue in vMX in Juniper Virtual lab/ Cloud lab

[ Edited ]
4 weeks ago

Hi Iam_Chethan,

What is the version that you are using? LACP on VMX was not supported on 14.1, supported started on 14.1R5 and later release.

Please check: https://apps.juniper.net/feature-explorer/parent-feature-info.html?pFKey=1201&pFName=Link%20Aggregat...)

Also, as per the below LACP is only supported on SRIOV not VIRTIO Type vMX:
https://forums.juniper.net/t5/vMX/VMX-LACP-configurion-down-aggregate-interface/td-p/323647

Hope this helps 😊

 

Please mark "Accepted Solution" if this helps you solve your query.

Kudos are always appreciated!













Highlighted
vMX

Re: LACP issue in vMX in Juniper Virtual lab/ Cloud lab

4 weeks ago

Hi